Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

Can’t get podcasts to download to iPhone over WiFi

Can’t get podcasts to download to iPhone over WiFi

I have tried all the solutions other folks have posted. It doesn’t work. I literally only downloaded this app for ONE PODCAST and it will not download. I’ve tried others and they won’t either. Every other app I have downloads fine, including podcasts. It is ONLY Spotify that won’t download podcasts to my phone. There is plenty of storage. And the fact that there isn’t actual HELP makes it even more worthless. If anyone can help I’d be super happy, I’ll buy you a beer. Because I’m about to throw my phone against the wall.

Reply
26 Replies

Hey there @dcedgar

 

Thanks for reaching out to us about this - we'll be glad to help you out here.

 

Most common issues can be fixed with a quick reinstall of the app. In some situations however, a clean (more thorough) reinstall of the app might be needed. This way, you can start afresh with Spotify on your device. 

 

Check out this help page in order to find the steps for clean reinstall on the relevant device. 

 

Hope this helps. Let us know how it goes. 

I have the same problem, but a clean re-installation of the Spotify app did NOT solve the problem!

I tried both solutions offered and neither worked.
When I hit the download button next to a given episode, it appears that it has started downloading, but never gets passed about 1/4 through and it just stays there. Or it isn’t keeps spinning and never starts downloading. I’ve also tried to use the solution given of turning WiFi off, closing the app, reopening the app, turning WiFi back on and hitting download. Nothing is working. I don’t seem to have a problem playing the episode while on WiFi or using cellular - it’s just the downloading that is the issue.

Exactly the same issue for me!

Hey there @dcedgar and @ElisaK

 

Thanks for keeping us in the loop.

 

It's also a good idea to test if you observe the same under a different network. If it works with another connection, it's best to contact the service provider of the original network for more information. For example, some shared or public networks (e.g. schools/work/office) might restrict access to certain services, which would explain what happened here.
 

If that doesn’t do the trick, just let us know and we’ll provide you with further help. 
 

Hope this helps. We'll look out for your reply. 

It’s my personal WiFi, there are no restrictions. I have tried 2 other places with WiFi and not been able to download. I have ZERO issues downloading podcasts from iTunes, or anything else for that matter. Bandwidth is not an issue either - I can stream Netflix and other platforms with no problem. It is just Spotify podcasts that are the issue. I’m getting responses from other people in this string and in a Facebook post that say they have the exact same issue...

Hey there @dcedgar

 

Thanks for getting back to us.
 

It's also a good idea to log in to your Spotify account on another device just to check if you observe the same.

 

If it doesn't occur on a different device, we'd suggest making sure that your original device is up to speed with any software updates available.

 

Hope this helps. Keep us posted. 

In resume, there is no chance this is an isolated issue. I'm in Brazil, very good internet connection, not a single podcast gets downloaded. It takes about an HOUR to save offline one episode, and if try to stream it keeps breaking, seems to have limited bandwith.
Tried clean reinstall, 4G, Wifi, other devices, different platforms, always same result: Ultra slow download.
Please consider this being on application side, not user error.

I observed now that I cannot even download songs, no matter if using wifi (at home, with good connection and high rate) or mobile internet (LTE). 
But this seems to be an iPhone/mobile phone problem since I can download songs with the app on my MacBook (same wifi obviously). Since I did a clean re-installation of the app on my iPhone, it cannot be the case that I am "missing an update" or something like that.

 

Plus, I have the same experience as @caiones that during the streaming of a podcast episode it keeps breaking (with wifi and LTE).

I tried on my iPad as well, same problem.

Same!! I can get it to play just fine over appleTV and on my computer. I did all of the things suggested on my iphone and I even did the support chat on spotify and when I used a test account it worked perfectly! I logged back into my account and the podcast played for about 3 minutes before stopping again. It will not download. And it takes several minutes to "buffer" and constantly cuts out for long periods of time. When I download it shows the circle with nothing happening. My internet speed is 35 mbps, private wi-fi, uninstalled/reinstalled, logged-out and back in, restarted phone, cleared cache...This has been happening for several days and I am over it. 

@dcedgar right there with you! My phone may have been tossed in frustration a time or two..

quick update: won't play on my browser either.

I'm having the exact same problem, it's only podcasts, only in the spotify app. I can download them without problem using either wifi or lte on any other app. I did everything everyone says, both a quick and clean reinstall, logging out and in again, turning off and on my cellphone in between all the other actions, and there are about 10Gb free yet, so definitely not a storage issue. Until about 3-4 weeks ago I had been downloading (and then deleting) podcasts almost daily for MONTHS, and never a problem until now... 

Ivan, I really hope you can return to this thread and offer some assistance. I am having the same issue myself, and have been scouring the internet for a solution that I cannot seem to find. I CANNOT download using wifi. This has been getting progressively worse over the past 24 hours. Initially it started as just a very slow download speed (in the range of 2 hours to download an hour long podcast episode) but now not a single thing will download. If I turn on cellular data, podcasts and songs will download in a matter of SECONDS. The only thing I have been told by support is to delete the app and reinstall, but after reading dozens of responses from users claiming that this did nothing to fix their issue I'd rather not delete everything that I downloaded since the LAST time I had to delete the app and reinstall it because of an issue.

 

 

Sorry folks - meant to get back on give you the solution, because I found what works. Apparently, if you read the tiny print on one the pages it says something about needing to have the app up and running, with phone lock OFF for the entire time the podcasts are downloading. Not sure why the Spotify guy or anyone else who seems to loooove this awful app didn’t know the “simple” but absolutely frustrating answer. My podcasts still sometimes take HOURS to download (it is this app NOT my WiFi - I can stream and download literally anything else on my iPad, phone, and tv at the same time with no issues), and I have to keep my phone plugged in so it doesn’t die while it’s got the screen lit up, but they do eventually download. I hated this app already, and now I hate it even more. If it weren’t for my favorite podcast moving to this platform exclusively I’d delete it and never look back. 

What I’ve found is when I was downloading an episode it wouldn’t let me go past the downloaded part but when I pressed new episode and the episode I was on it suddenly started playing and downloaded 

Mine does the same thing. I noticed that you have to keep the app open on that screen otherwise it won’t download them. I forgot to do this last night and the podcast I selected to download still weren’t downloaded this morning! **bleep**ing annoying. 

I had the same issue, podcasts and songs wouldn’t download on wifi or cell service and not one of the suggestions worked, i.e. reinstalling the app, restarting phone, clean reinstall…. what worked for me after punching my phone was clearing the cache then removing my downloads in the storage tab in the settings. Obviously you have to redownload anything you already had installed but this worked for me. Hope this works for somebody else!

My fix was that I had to turn off my "low-power" mode (which activated "background app refresh"), close the app, reopen and download the podcast episode.

Suggested posts