Confused screen orientation

Confused screen orientation

power_max_9000

tl;dr track screen layout is off as in confused by actual screen orientation.

 

I've been having this problem for about a month now. I don't certainly know how to reproduce it, but I see it quite often. I launch Spotify on iPad and everything looks fine, but when I pull out the track/queue screen (one with large album art and play controls) it has layout as if iPad was in another screen orientation. In portrait mode controls are 'squeezed' in the top part of the screen and are off the right boundary. When I turn iPad into landscape mode: all controls re-shuffles and become visible, but they scaled down and take up only the top-right part of the screen. Basically, see screenshots attached, it's easier to see what's up. I have to force close the app (swipe it away in the app dock) and restart to bring it back to normal.

 

Spotify version: 5.7.0.1055

iPad model: Mini, ME276NF/A

iOS version: 9.3.4

 

IMG_0038.PNG
IMG_0037.PNG
Reply
13 Replies

power_max_9000

Another screenshot. This time play controls are off the screen.

IMG_0045.PNG

KatesHere

Hey there @power_max_9000 and welcome to the community!

 

This doesn't look right. Have you tried a clean re-installation?

 

Hope this helps!

K

-------------------------------------------------------------------------

Treat others the way you want to be treated!
I can help in english, français or ελληνικά
Follow me on Spotify | What is a Community Star? Join us!

power_max_9000

Thank you. I have re-installed the app, but since there is no clear scenario to reproduce the problem, it will take a while to watch it. I will report back again to this thread shall I experience a problem. Cheers!

KatesHere
@Powe_max_9000 Great!
Keep us posted 🙂
-------------------------------------------------------------------------

Treat others the way you want to be treated!
I can help in english, français or ελληνικά
Follow me on Spotify | What is a Community Star? Join us!

power_max_9000

I cannot reproduce the problem so far. I mark it as solved for now and will "re-open" shall it happen again. Thank you for support!

power_max_9000

Hey there, sorry to un-resolve your suggestion, but apparently I face this bug after clean re-install again, haha. Can we escalate it to the bug-reporting forum, please?

 

 

IMG_0049.PNG

KatesHere
Hey again @power_max_9000, sorry to hear the clean re- install didn't work out.

Would you mind answering the following questions to get a better understanding of the situation before we escalate it to the right team?
- Does this happen to any other app?
- Does this happen during playback - i.e. while streaming?
- Is this only happening when listening using the bluetooth speaker attached? (as shown in screenshot)

Let me know 😃
K

-------------------------------------------------------------------------

Treat others the way you want to be treated!
I can help in english, français or ελληνικά
Follow me on Spotify | What is a Community Star? Join us!

KatesHere
Hey @power_max_9000, any news on this?
K
-------------------------------------------------------------------------

Treat others the way you want to be treated!
I can help in english, français or ελληνικά
Follow me on Spotify | What is a Community Star? Join us!

power_max_9000

Hey there! Sorry for the delay - was away from Internet for a long while.

 

- No, it does not happen to any other app. I have been observing this behaviour in Spotify app and on iPad only.

- Yes, it happens during playback/streaming. However I always stream from iPad, so cannot say if it is limited to playback only.

- Again, yes, it is happening when listening via a bluetooth speaker, but I rarely use built-in speaker, so cannot say if it is limited to bluetooth play only.

 

Hope this helps. Glad to provide you with more details.

KatesHere

Hey @power_max_9000, welcome back 🙂

 

I've conveyed the right team your answer, I'll keep you posted with any updates.

 

K

-------------------------------------------------------------------------

Treat others the way you want to be treated!
I can help in english, français or ελληνικά
Follow me on Spotify | What is a Community Star? Join us!

KatesHere

Hey again @power_max_9000 🙂

 

Thanks for your answers, I've conveyed them to the right team. Moreover, in the quest of identifying the issue, would you mind checking something else too? For example, if it's not a problem, could you check the built-in speakers to see if it reproduces the bug?

 

Also, did this always happen? And if not, did you notice when it started happening (for example, an update or installation of new software/hardware)?

 

Again, I'll make sure to pass on any info to the tech teams 🙂

K

-------------------------------------------------------------------------

Treat others the way you want to be treated!
I can help in english, français or ελληνικά
Follow me on Spotify | What is a Community Star? Join us!

KatesHere
Hey again @power_max_9000!

Are you still having this issue? Keep an eye out for the new update as well, as it may fix this.

K
-------------------------------------------------------------------------

Treat others the way you want to be treated!
I can help in english, français or ελληνικά
Follow me on Spotify | What is a Community Star? Join us!

R2danny2

I've been having these problems too today. What I did to sort the problem out was close the programme and start again and that worked. A bit of a pain to have to do, but at least it's sorted for now.

Suggested posts