Announcements

Help Wizard

Step 1

NEXT STEP

Control4 Speakers: Playlist Stops After First Song

Control4 Speakers: Playlist Stops After First Song

When using Control4 speakers to play a playlist, the first song plays successfully, but the playlist stops and does not automatically continue to the next track. I don't have the issue when playing through the iPhone itself, it's only when I connect to "Spotify" on the network that I have the issue.
Reply
20 Replies

Hey there, 

 

Thank you for posting and welcome to the Community. 

Sorry to hear you're experiencing issues with the Connect feature, lets troubleshoot this together shall we. 

 

First off we would suggest to try Connecting via another device on the network to test if the same outcome will happen. 

Have you also tried restarting your Wifi router, that may be a reason why this is happening.

Lastly, we'd suggest that you disable any antivirus software temporarily to see if that helps - if it does, please set the Spotify app as an exception. 

 

Keep us in the loop.

MartinModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hello, I've tried multiple devices but it's still an issue. It might be one of the most annoying things because once a track ends I have to hit the next track to hear the next one on the playlist. 

Hey there @santo23

 

Thanks for getting back to us. 

 

Just to confirm, have you already tried restarting your router? If so and it didn't do the trick, could you give a different internet connection a go to see if the same happens? 

 

If the issue persists, could you ask a friend or a relative to log in to their account on your device to see if they can replicate this behavior with their account? 

 

We'll be on the lookout. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Hey, thanks for your response! I have tried restarting my internet. I've also tried this on different devices including Windows PC, Mac Laptop, and another iPhone but I get the same result, I'll play a song on a playlist and it will playthrough but then not play the next track on the playlist unless I hit next track manually. 

Hi there @santo23,

 

Thanks for keeping in touch and for trying out our recommendations. 

We understand you tried from different devices, but did you have the chance to try with a different account? If you don't have another account, you can ask a relative or friend to give it a try.

Additionally, if you haven't, try rebooting the speaker. Usually, speakers are powered cycled by pressing and holding the power button. However, to know exactly how to do it, we'd recommend checking the installation guide.

Lastly, let us know the exact model of the speaker. 

We'll be here.

Susan_GPModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hi Susan, thanks for the suggestion. I have a family account so I naturally tried with another family member's account. I also tried power cycling the speakers and the entire system (including the wifi) but I still have this issue.

I am also having the same issue and it is infuriating!  My Spotify app works fine with all other listening devices but is intermittently not advancing ONLY with Control4.  Something is up with the integration I assume

 

I'm so glad I'm not the only one with the issue. Do we think it's something on the control4 side or spotify?

Hey folks,

 

Thank you for keeping in contact.

 

It's possible that the issue could be related to the speaker directly since the app works properly with other speakers. In this case, @santo23 would you mind (if possible) checking with a different speaker to see if the issue persists?

 

Also, to continue investigating this from our end, include in your next response the make, model, and OS version of your device you're connecting to your speaker, along with the Spotify version you're currently running.

 

We'll be on the lookout.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello Oscar, thanks for your response. When I connect to the "speaker" it connects to a control4 server that is connected to multiple speakers set up in different rooms. For example, I have a Family Room, Dining Room, Living Room, Kitchen, and Office that all have their respective speakers. I can turn the speakers on in 1 or all of these rooms and connect Spotify to them via wifi.  

Hey guys,

 

We did some digging on the topic and it seems like there's more reports on the matter that have been made directly to Control4 on their forum. We would recommend reaching out there for further help as the issue is narrowed down to that system integration.

 

Remember the Community will always be here to help if you have any other questions.

 

Cheers.

MartinModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hello, thanks for your response. I want to point out, that the forum you linked doesn’t have any control4 admins. It’s a forum full of dealers of control4 systems and the people who use it. It won’t be much help coming to a solution for this. I appreciate you digging around for it though.

Hey @santo23,

 

Thanks for your reply.

 

We've checked the thread again and can confirm that the second user that responded (ChrisHenderson) is a Control4 employee, however, they still haven't posted a solution/official response to this issue. In the meantime, make sure to check out the troubleshooting steps suggested by other users.

 

We hope this helps.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

same issue santo23!!   I've tried all the solutions below!

Hello, I have been having this same issue for a couple of weeks now. My installation company has come out and been on with control 4 reps. They has concluded that Spotify has changed there backend API systems and has caused the issue for control 4. Supposedly they are working on a “fix” but this is highly frustrating at the moment. 

There is an update that's being released at the end of the month from the control4 side that should fix the issue. I agree that it's annoying to deal with.

I am having the same issue. But with a downloaded album. Plays first track then stops. Can manually advance, but won’t play continuously itself. Issue is only with Spotify 

For us this issue is solved with Control4 update OS 3.4.2.709259.

Having this same issue since mid April 2024. Did anyone figure out the resolution ? 

Suggested posts