Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Disable autoplay when connected to Bluetooth

Disable autoplay when connected to Bluetooth

Give an option to not play music when connected to a Bluetooth device like the car. The android client has this why not iphone?

This issue has been brought up in 2018, 2019, and 2020 and the mods keep saying it's a user issue and to reinstall. Please stop lying to us as its a spotify feature issue. 

Reply
22 Replies

Hi there! Welcome to the Community! 🙂

Thanks for reporting this! We know how difficult it is when the app starts acting up. No worries, I'm here to help you.

Let me understand your problem better. Are you mean when you are listening to Spotify connected to the Bluetooth on your car, Spotify keeps auto-playing music, right?

Spotify has an option under Settings where you can disable the auto-play option, this might help you solve this problem.

Go to Settings > Playback > Autoplay (turn off this option).

I'll be on the lookout for your reply. Hope it helps you.
Have a great Sunday!

MateusMSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Per Spotify, that autoplay feature is to enable or disable the following: "When you reach the end of an album, playlist, or selection of songs, Spotify automatically plays similar songs so the music never stops."

So that suggested solution does not fix music playing automatically when Bluetooth connects.

Hi again @HLMem!

 

Thanks for keeping in touch and giving us more details. I got what you mean.

 

This autoplay when you connect to the Bluetooth device is an OS thing, this is an easy way to start or continue listening to a song where you've stopped. Android does the same, just like other apps like YT Music, Apple Music, etc.

Did you try to force kill the app and see if it still starts auto-playing music when you connect to the Bluetooth device? 

I'll be on the lookout for your reply.

Have a great week! 🙂

MateusMSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

This issue exists on android as well but a feature to turn it off was added to spotify

Which feature? I don't have it... I have tried many suggestions on internet but most of those settings doesn't exist for my Android + Spotify. How I can disable autoplay function?

Hi @Mr_city,

 

Thank you for your post on this thread. 

 

In Settings you can find the option Autoplay. When activated, the music will keep playing after you finish a playlist or an album.

 

However, if you're experiencing the issue where the music starts playing automatically after connecting a Bluetooth device, we suggest you check your Android settings, since this automatic playback setting is built-in on the operating system as @MaMarquezini posted.

 

Hope this helps!

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Android/Samsung S20 5G/ USA - I too struggled with this issue in my car for a long time and after thoroughly testing disabling certain things in my Android settings (because Spotify showed me no setting related to this particularity in the app), these changes finally stopped the automated opening and playing of audio in the car when I connected the Bluetooth. 

 

Step 1: Settings Advanced Features 》Android Auto 》(Uncheck) Automatically resume media

 

Step 2: Settings Advanced Features 》Android Auto 》(Uncheck) Wireless Android Auto

 

Note: Tested and worked, but only as far as connecting and the app opening automatically and playing without my consent. Once I open Spotify myself though, it will automatically begin playing audio and the volume knob in my car will still also trigger to unpause the audio and play (a different but related issue I've had as well). 

 

Good luck! 

Your suggestion helped me, thank you. Android Auto interface has always been confusing, but the newer ones are making a effort to be clumsy.

The issue continues in Apple iPhone all models and Spotify  still dint have an option. Real problem: How to disable Spotify auto opens and play on Bluetooth connect of any device like: Apple Airpods, Bluetooth Car Radio, Bluetooth speakers etc..  An option to disable still not exist for Apple like Android has.

Hello @Novy, you have misunderstood the issue. The problem is not that Spotify keeps playing when am album or playlist is finished, but that when you have Bluetooth headphones or Bluetooth speakers connected to your iPhone when you open the Spotify app, whatever song you listened to last automatically starts playing. Turning Autoplay of or on does nothing to solve this problem

Go to Settings>Apps>Spotify>Notifications and dissable Playback

It's unbelievably frustrating to see Spotify mods acting like they don't understand this issue. It's been an issue for YEARS. You can find dozens and dozens of threads of people complaining about this and still they act like this is something new that they haven't heard about. Or they blame it on the OS which is hilarious because I have maybe 10 apps on my phone at this moment that stream audio in some capacity and not a single other one does this.

Not on iphone, unless I am missing it

You're right. It's for Android

I just tried this and it still happens. Maybe because I don't use Android Auto?  I have it but I don't like it so I don't use it, so it is just the normal Bluetooth connection to my car and it is so annoying when I'm listening to something else and spotify cuts in on top of just starts on its own when I didn't want to listen to it. 

Yes, this is still an issue.  And super frustrating the "mods" seem so clueless about this issue when it's been a constant annoyance for years.   For iphones, there is no way to definitively turn off:  "when connecting to a bluetooth device the phone just decides to start playing music over the device"  This happens with Spotify and the iphone Music App.  Sometimes I don't know how the phone decides which one to open and start playing automatically.  It goes back and forth between the two apps.  Beyond Frustrating.  Turning off autoplay on Spotify options does nothing for this issue.  That is just a playback functionality to allow music to keep playing after a selected album ends.   It's the iphones OS pushing this issue, but would be nice if Spotify built something in the app to turn off the ability for the iphone OS to essentially hit play on the Spotify app when we the user didn't whenever it connects to BT.  I should be able to choose when music plays or not on my phone.  Just because I connect a BT device does not give the phone my consent to start playing music on it's own.

has this been resolved at all? I'm close to uninstalling and quitting Spotify all together over it. I have the autoplay setting turned off in spotify and I have checked all notification settings in IOS and see nothing to stop autoplay. Music still starts loudly when I turn on bluetooth headphones to get ready to make a call and when I get in the car and the bluetooth connects to my phone. I only want music to play when i decide to play it please...

I made an account just to post a response here because this was annoying me to no end.

 

It's not actually a Spotify issue but rather your bluetooth device (generally crappy, older BT car stereos and some other devices). Ironically - specifically for me it was the Spotify CarThing that was causing the issue.

 

Anyways here's what's happening. These crappy devices are sending your phone a play command when it connects.

 

Here's my hacky solution that works for modern iOS versions (i.e. anything with Shortcuts)

 

Create an automation that is triggered by bluetooth connection to your device (or all devices) and have it trigger the pause command. You might need to add a "wait" to avoid race conditions but it should solve your problem. 

as @nordness suggested: https://www.youtube.com/watch?v=fXutzK-9gWQ 

 

ridiculous that there's no toggle switch (in either spotify, or in apple bluetooth settings) to do this, but now, when i connect by BT headphones and open spotify... there's silence ☺️ then i select the music i want to play...

Suggested posts