Disable repeat and autoplay

Reply

Re: Disable repeat and autoplay

DanifC
Composer

Good afternoon, 

 

Clearing the cache is a good idea, that might help. Here is the page that tells what the cache is used for: https://support.spotify.com/using_spotify/system_settings/storage-and-data-information/. Clearing the cache can sometimes fix problems. 

 

You should be able to keep your preferences separate on a family account, so it shouldn't be a problem with that as far as I know. If we can't get this figured out with the cache, I'll escalate the post and see if a moderator or Rock Star can help us out here. 

Re: Disable repeat and autoplay

DanifC
Composer

Also try logging out and back in to Spotify on your devices. You can do this individually on each device or on all your devices by accessing your account page: https://www.spotify.com/is/account/overview/

Re: Disable repeat and autoplay

SeanGunns
Visitor

I have had this same issue with Repeat auto-enablifng itself and have narrowed the issue down to my car's bluetooth system. I drive a Ford Everest/Endeavour and every single time my phone/spotify connects to the in-vehicle entertainment system it enables repeat. It is HIGHLY annoying but I can't seem to find anyway to sort it out on Spotify or in the Ford entertainment system. Perhaps you have a vehicle that connects to spotify automatically too and it's causing it to enable Repeat like mine does?

Re: Disable repeat and autoplay

armcknight
Regular
I’ve been using a USB connection for some time, since before I created this report initially, so maybe. I only started using the Bluetooth connection in the last few weeks so that definitely isn’t it, but what I can say is that Spotify’s interface on the phone is different between when I use USB vs Bluetooth methods. With USB, it seems to just send audio like an AUX output; with Bluetooth, it looks like CarPlay.

Re: Disable repeat and autoplay

Dan159
Visitor

It is your car (or possibly another Bluetooth device) that does it. In my car, VW2017, the settings button that shows while media is playing from the phone has a checkbox for “repeat/shuffle”. I unchecked that and now it doesn’t happen anymore!

Re: Disable repeat and autoplay

Mihail
Moderator
Moderator

Hey there @armcknight,

 

Thanks for searching for the answer you need here!

 

Just to make sure that we're on the same page - you tried performing a clean reinstall using the steps here and disabled repeat and autoplay as described here and here, right?

 

We also understood that you're also connecting to a car system . Does the option reenable itself only after you connect to your vehicle or at random? 

 

We'd also appreciate it if you leave a post with your Spotify version and the make, model and operating system of your device. 

 

We'll be keeping an eye out for your reply.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards
SUGGESTED POSTS