Announcements

Local files not playing on iPhone 13

Local files not playing on iPhone 13

_pltqb9q-0nz8

Plan

Premium student 

Country

England

Devices

iPhone 13 and MacBook Pro 2020

 

I’ve recently changed my phone so when setting up the new one I noticed my local files were greyed out and not able to play on my phone. I have followed all previous help pages but nothing has worked.

The local files play on my laptop. 
I am definitely on the same WiFi for both devices and local audio files is ‘on’ on my phone. 
previous help sections mention selecting device from a prompt to sync devices but I never get the option to select a device to sync with my phone. Thank you 

 

 

 

3CB10EDF-C1AD-4109-AE4B-618FE0DCE898.png
3C4CAE03-881C-495C-8090-3BC5DC8F03FB.png
84442D32-8429-413E-AE3B-2DA97A9E976D.png
Reply
10 Replies

Kiril

Hey @_pltqb9q-0nz8,

Thanks for your post in the Community.

We understand that your new mobile device doesn't play your local files, which are currently stored on your Mac. First off, it's important to be sure that the Spotify apps and your phone's firmware are all up to date. Then maybe you'd need to resync your devices for the new mobile phone to be able to locate and play the files. You can check out the article here, where you have the needed steps to do this for iOS as well as to see all the supported file formats. It might also be worthwhile to play around with the actual files  - like moving them in a new folder on your Mac and then letting the devices rediscover them.

Hope this helps. Let us know how you get on.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

_pltqb9q-0nz8

Hello,

 

Unfortunately, I've tried all the steps you recommended but none of them worked, I still can't play the local files on my phone that I can on my Mac. 

I followed the article you linked and everything was set up as it was meant to be, until the last step: 

Enable sync from desktop.
Note: You need to allow Spotify to find devices in the prompt that shows,

I don't not receive a prompt of devices available, but it does recognise that I have one device available to sync.

I'm also not sure what "mark playlist containing song for off-line since on computer or phone" when I look as playlist options this is not an option.

I've also removed all the local files from my laptop and then added them back and changed sources as you suggested, but nothing has worked yet. 

Thank you

 

 

 

Eni

Hey there @_pltqb9q-0nz8

 

Thanks for getting back to us. 
 

Could you send us a screen recording of the steps you take when trying to enable the syncing from the PC so we can take a closer look? You can attach it to your next response by using the Insert Video option in the post editor. You can also upload it to Google Drive and share the link with us (make sure the video has the permissions for anyone to see it).

 

On another note, in order to download your songs in the PC, you just need to click on the arrow icon as the option to download from the menu isn't available there. For more info, we suggest that you check this article.

 

Lastly, we'd recommend temporarily disabling the firewall on your PC while the songs are synced from desktop to mobile. Afterwards, you can enable it again.

 

We'll be on the lookout for your reply.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

_pltqb9q-0nz8

https://drive.google.com/drive/mobile/my-drive?utm_source=en 

Hello,

I’ve tried again to add the songs by removing them and then adding them again and did turn off the firewall on my laptop but it made no difference. I’m still unable to play the local files on my phone. I’ll try and upload the requested screen recording. 
thank you. 

_pltqb9q-0nz8
Video should be on the drive link and I have added permission to anyone with the link

Eni

Hey @_pltqb9q-0nz8

 

Thanks for your reply. 
 

We're afraid we couldn't open the video on the link you sent. Could you please give it a try again? 
 

We'll be waiting for your reply.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Eni

Hi there @_pltqb9q-0nz8,

 

Thanks for the info you've sent. 

 

Would you mind checking if the OS of your devices has any pending updates?

 

On another note, would you mind giving these steps a try to see if they make the difference?

 

Keep us in the loop. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

_pltqb9q-0nz8

Hi there,

My phone is up to date on software updates.

I followed the steps on the link provided but encountered a problem,

 

3 - Scroll down to the Local Files option and select it.

4 – Switch Show audio files from this device on.

Note: A pop-up will ask permission to access your local network. Accept this permission to enable Local Files transfer between desktop and mobile.

 

I have never had the pop up appear , but now I only get the option of allowing local files on my phone to appear (which is just my Apple's own Music app library songs)

 

_pltqb9q0nz8_0-1655723935201.jpeg

 

Thank you for your continued help.

Alex

Hi there @_pltqb9q-0nz8,

 

Thanks for the post.

 

The way local files work has changed a bit recently. You can follow this FAQ guide on how to synch files from your computer to the phone as well.

 

Hope this helps.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod