Announcements

No audio after WhatsApp phonecall using Apple CarPlay

No audio after WhatsApp phonecall using Apple CarPlay

Plan

Premium Family

Country

ID

 

Device

(iPhone 7 Plus)

Operating System

(iOS 15.4.1)

App Version

(8.7.18)

 

My Question or Issue

Whenever I am using Apple CarPlay while driving and listening to Spotify (music, podcasts or whatever), and there's a WhatsApp phone call, the audio is just silent after the call ends. No audio whatsoever, but the progress bar continues which means the audio is playing. I have to disconnect and reconnect my phone to restart CarPlay to fix it, which is annoying and very distracting while driving. Normal phone call does not seem to create the same issue. I tried to restart the phone, reinstall Spotify, reinstall WhatsApp, even tried to reset my phone but the same issue persists. Anyone have a clue what happened here?

Reply
5 Replies

Hi @rionaldc,

 

Thanks for posting on the Community.

 

Just to confirm, did the issue start after a recent OS or app update? Also, let us know if this happens with Apple CarPlay only, or with another type of connection (Bluetooth, cable).

 

Keep us in the loop.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi, I think the issue started when I updated my device’s iOS version to iOS15. My car’s Carplay connection mode is wired so I can’t try to test bluetooth / wireless mode.

Hi there @rionaldc,

 

Thanks for keeping us in the loop.

This could be related to some changes on your OS done by Apple affecting CarPaly and the media integration with other apps which can control the sound streams like WhatsApp, however this is hard to be confirmed remotely. You might want to also check if your WhatsApp needs updating as well and if yes to run it.  If this doesn't help, then is it possible for your to try with another device (and possible another OS version) to see if this behavior occurs again or it works as expected?

 

If the issue is consistent and you're experiencing it again regardless of the device and OS version, then could you please record a short video of it, so we can take a closer look and advise you better. 

Let us know how things work out, we'll be keeping an eye out for your reply.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello,

 

Sorry for the late reply. I have confirmed that WhatsApp on my iPhone is already on the latest version but the issues still persists. I also tried to use another phone (iPhone XS, same iOS version) and the problem still persists. I've provided the link below for the short video since the file size is too big for me to upload here

 

https://streamja.com/5Kllp

 

Thanks

Hey @rionaldc!

 

Looks like WhatsApp might be it's taking control over the device's audio output. Spotify doesn't aggressively try to retake it and instead only sends out a request upon device connections, so there's most likely some sort of incompatibility between WhatsApp and Spotify together in conjunction with CarPlay. If you haven't already, try taking to WhatsApp's attention so they can have a look into it.

 

In the meantime, you can test if the same incompatibility occurs between other apps.

 

Hope this gets sorted out soon. The Community is always here if there's anything else you need assistance with.
 

Take care.

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts