Song won't play when pressed

Song won't play when pressed






iPhone Xs

Operating System

iOS 12.4


My Question or Issue

This morning when I tried to use the spotify app, when I tried to play a song it wouldn't play. The app recognized I pressed it but didn't actually play it. The player above the navigation buttons at the bottom of the screen was also missing. I tried playing songs from my "Discover weekly" and my Liked Songs library and neither worked. I also tried closing the app through multitasking and restarting it and that didn't work either. Restarting the phone didn't work either.


I found a solution by playing a song on my PC then changing the device used to play to my phone, but I want to know if there is another way to fix this that doesn't require a second device. Unfortunately I don't have any steps to reproduce since this occured this morning and the app was working fine for me last night.

21 Replies

Hi there @sushijean,


Thank you your reply. 


We understand you already reinstalled the app, in this case can you perform a clean reinstall? This one is more thorough than a regular one and can be helpful to get rid of any cache that might be causing trouble. 


Also, if you're using an SD card please remove it, reinstall the app and see how it works that way. 


Lastly, please let us know if you already tried creating a new account to test it on your devices. 


Hope this helps!

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Kinda ridiculous that this is still a problem. 6 months later we shouldn’t have to go through the hassle of setting up a new account when Spotify had 6 months at the very least to address the issue. I’m gonna deal with it but if they don’t fix it soon Pandora is the next best thing πŸ€·β€β™‚οΈ

Suggested posts