Songs won't play...

Reply

Songs won't play...

monkeycrow
Casual Listener

I know it sounds like a dumb, basic question.  But songs that are downloaded play fine, however, if I try to play a song that is not downloaded, sometimes just refuses.  To be clear, it doesn't bring up a message like "Can't play the current song", nor does it seem to start playing but no sound, etc., just nothing. Happens probably once or twice a day.  Often happens if I go to an artist I'm listening to to listen to a different track on same album. I can play the tracks that are downloaded from the album, but none that aren't.

 

Have restarted, deleted and reinstalled the app, and have cleared the cache.

 

Very frustrating after paying for a premium account to have this repeatedly happen.

 

Plan

Premium

Country

Canada

Device

iPhone 11

Operating System

iOS 14.3

 

5 Replies

Mihail
Moderator
Moderator

Hey @monkeycrow,

 

Thanks for reaching out to the Community.

 

Good job on checking first whether or not a reinstall solves the issue, in most such cases it does. However, could give it another go with these steps and run a clean reinstall? These ones are more thorough. That way you can make sure the cache is not causing this issue.

 

It's also a good idea to check if you observe the same under a different network. If it works with another connection, it's best to contact the service provider of the original network for more information. 

 

Keep us posted! We'll be happy to lend a hand if you need more help. 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

monkeycrow
Casual Listener

Thanks for the reply. 

Tried the clean re-install, didn't seem to work.  Issue persists...pretty frustrating.

 

CarlosE
Moderator
Moderator

Hi again @monkeycrow,

 

Thanks for getting back in touch and trying a clean reinstall.

 

Just to confirm, did you check if it was happening when using a different connection, such as another WiFi network or mobile data?

 

Also, make sure that Spotify doesn't have any battery optimization, cache clearing, or data restrictions enabled on your phone.

 

Keep us in the loop.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

monkeycrow
Casual Listener
Yes - when this happened again, I tried turning off wifi and using data,
and then went to a different network, none of which worked...

m.

Jeremy
Moderator
Moderator

Hey there @monkeycrow,


Thank you for your reply and confirmation.

 

Can you try from another device to see if the issue persist?

It would also be great if you can let a friend or a family member log in with their account on your device to see if the same thing happens to them.

 

Also - can you let us know which version of the app you have?

We'll keep an eye out for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂
SUGGESTED POSTS