Announcements

Spotify Connect stopped working on my MultiRoom system

Spotify Connect stopped working on my MultiRoom system

Allan_AA

Premium 

Denmark

Device is I Phone X max

Operating System is 15.3.1

 

 

I have a Samsung MultiRoom system that has run without no problems for years but now it suddenly stopped a while back. Now I’ve had time to try a lot of different things like restarted speakers, reset router, clean uninstalled all apps involved, reinstalled etc etc but nothing seems to work. 
when I hit play it just doesn’t play. If I use the Samsung MultiRoom app and streams radio directly to the speaks it works fine. Just not with Spotify. 

many help what to try?

 

kindest, 

Allan

 

Reply
Top Answer
OscarDC
Moderator

Hey folks,


Thanks for keeping in contact.


In this post, we get some information about Samsung discontinuing their product. In this case, there's nothing we can do on our end, as fixing this would require a firmware update on the speakers' end.

 

Unfortunately, such situations can arise, as backends (APIs) change and it's completely natural for devices that don't get constant updates to not work forever.

 

Please note, that we cannot influence compatibility on all devices out there, especially when it concerns third-parties and their decision to end their support for a certain product. 

 

Hope you’ll find this information useful. If anything else comes up, the Community will be here for you.

253 Replies

Kiril

Hey @Allan_AA,

 

Thanks for posting and welcome to the Community!

We understand that you're not able to enjoy your Samsung MultiRoom alongside the Spotify app. This feature is available in the Premium tier of the app and could be done via the Spotify Connect feature. In case you are not seeing your MultiRoom system as device, then you can also try the steps given in Samsung's official article here and see if following the steps there will make any difference for you. 

 

You've mentioned that you've already reinstalled the apps involved in your setup, but it could be worthwhile doing another so called clean reinstall (it has just a few extra steps) of our Spotify app to get rid of any previously cached files that might be causing trouble in the moment. See if this will shake things up and get things going for you again.
 

Hope this helps. Let us know how you get on.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Zigge

Hallo Allan

 

I have the exact same problem, with Spotify Connect and Samsung Multiroom speakers, it just won't start playing, but pauses again right away, even though I can see the speakers in the Spotify app. And as you say, it works fine with like internet radio, so the problem seems to be Spotify or Samsung that have done something with their Spotify compatibility. It worked fine for years, but then just the other week it stopped working, first on one speaker and later on all of them.

 

I exactly got it to work again the other day, but for a short time. I got a new router and reconnected the speakers and then the all worked again, but not for long, so I guess it's probably not the network/router. I'm from Denmark as well, but I guess that it's just a coincidence.

 

Hopefully we can a solution.

 

Zigge

Hello Kiril

 

Thanks for the reply, but none of it helped as I have the same problem, see the above post. 

Jeremy

Hi there @Zigge,

 

Thank you for your reply in this thread.

 

Can you confirm that you followed the steps that's provided in this article? There's some more steps to help thoroughly uninstall the app from your device, so if you haven't, we'd highly suggest it since the steps will make sure there's no old cache files causing this.

 

It would also be great if you can let us know if you have any pending OS updates?

 

On another note, there's a similar thread here. We suggest that you head over there and provide the information that's being asked by @dinomight.

 

We'll keep an eye out for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Allan_AA

I've tried that several times but It still doesnt work, unfortunately. 

 

Any other suggestions to try?

 

/Allan

dinomight

Hey there @Allan_AA! Just jumping in on this since I also have a Samsung multiroom speaker and have run into similar bugginess on occasion in the past. The biggest thing that has normally helped me resolve issues like you're experiencing has been to perform a hard reset on the speaker, which refreshes the device and lets you run through the whole setup process again. I only have one speaker, so your experience might be a little different with multiple speakers and a hub. It would probably be a good idea to test your speakers one at a time before reconnecting to the hub. 

 

Also, exact methods for performing a hard reset may vary depending on your exact device. I have an M5 model, and in my case I have to perform the steps on this page, but be sure to check for specifics on your model in case it works a bit differently.

 

One other suggestion would be to try connecting from another device, such as a PC, if possible, either through the desktop app or the web player. That would at least let us know if this is limited to just your phone or Spotify as a whole within your system.

dinomightSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

MrMEEE

Hi

 

I have the same issue... Spotify on all of my devices (3 phones, 4 tablets and in browser on pc) have stopped working with all of my 11 multiroom speakers.. The spotify clients have no problems connecting, but when press the play button, it switches quickly to the pause symbol and then back.. I even get the "pling" sound when connecting with spotify, so the connection works.. Playback from the multiroom app also works perfectly..

 

Has there been some kind of change in codec/format? Maybe you have changed to something that the multiroom speakers can't play?

 

Please help

Zigge

Hi Jeremy

 

Thank you for the reply.

 

I have tried to perform a clean reinstall of the app, but it didn't help and I also have the same problem using a computer or another phone.

 

I don't have any pending OS updates.

 

I have tried to reset the speakers and it doesn't help. 

MrMEEE

@Jeremy

 

I don't think this is related to the other issue that you refer to..

 

This is clearly something new, that apparently a lot of people are facing...

Kim_ras

Plan
Premium

Country

DK

Device

iphone 13

 

My Question or Issue

I can’t get Spotify to play Music on my Samsung MultiRoom speakers anymore. 

it connects to the speakers fine, But when i Press play it stops immediately again. 
no Music at all.

i have updated the speaker software, reinstalled Spotify app an Samsung MultiRoom app and reconnected speakers to my wifi.

the issue is the same on with my wife’s androide phone.

Anny suggestions?

thanks,

JohnnyHefty

I experience The same 

Eni

Hey there folks, 

 

Thanks for reaching out about this here in the Community. 

 

@Kim_ras, great troubleshooting so far, we can add a few more steps to make sure we've covered all bases. You mentioned that you've already reinstalled the app, but would you mind going through the steps of a clean reinstall, as it's more thorough than a normal one? In case the issue persists, we recommend trying with a different network, for example creating a hotspot on your phone and using that to see if that makes the difference.

 

@JohnnyHefty, first up, we suggest that you try restarting your router and check if that makes the difference. If this doesn't do the trick, would you mind checking if the firmware of your speakers is up to date?

 

Keep us posted.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

JohnnyHefty

Yeahh I booted my router, reinstalled spotify on both pc and phone, and it's the same.

 

Firmware is up2date.

 

I can listen to raidio via the multiroom app without any problems

Kim_ras
thanks for the assistance but unfortunately it does not work. have tried
to do a clean reinstall and tried to go on another network. nothing has
worked.

Eni

Hey folks,

 

Thanks for your replies. 

 

Could you let us know if this started happening after a specific event such as an update? 

 

On another note, just to confirm, have you tried hard resetting your speakers with the steps @dinomight sent previously?

 

Lastly, we suggest that you make sure the firmware of your speakers is up to date.

 

We'll be waiting for your replies.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Allan_AA

Hi again

 

im not sure what triggered the problems with using my speakers with Spotify. 

I can confirm doing a reset on the speaker and paring it back with my Wi-Fi.

 

speakers are up to date on firmware. I run with the ‘automatically update speakers’ setting but checked manually if they are up to date. 

kindest

Allan

CarlosE

Hi again to everyone!

 

In order to check this further, could you send us the model and firmware version of your speakers? Also, send us over the model and OS version of your mobile devices, as well as the Spotify version you're running.

 

Lastly, let us know if this happens with other streaming apps. 

 

We'll be looking for your reply. 

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

MrMEEE

I can confirm that hard reset does nothing for me...

 

And my speakers are all up-to-date..

Kim_ras

Hi,
iPhone 13mini iOS 15.3.1
Speakers:
Wam550WWB-3117.1/87R
Wam350WWB-3117.1/87R
HW-MS650WWB-1147.2/196R

Spotify 8.7.16.1370

Thanks,

Kim

Suggested posts

Env: prod