Turn off recommended songs?

Solved!
Reply

Turn off recommended songs?

Bhood2006
Regular

 

Plan

Premium

Country

US

Device

(iPhone

Operating System

(iOS 

My Question or Issue

I am new to Spotify premium, I have spent days researching how to stop recommended songs from playing while I listen to my created playlists and can’t make it stop. It will play 1 song from my list and then just start playing random songs that are nothing like my playlist. I have gone to settings and turned off the auto play option, I have deleted a playlist after that and remade it to try again and it’s still the same. Is this just how Spotify works? Are users required to listen to recommended songs on their playlists? I’d really like to know because, if that’s how Spotify works, I’d like to cancel my account. Please advise.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Turn off recommended songs?

Bhood2006
Regular

OK after 30 mins chatting with a Spotify rep, it’s now resolved. Idk if they worked some voodoo but at the end I had to delete the app and download it again, log out and log back in. My theory is that when I upgraded to Premium the settings remained the same as a free account and in order to get it to change this feature I needed to kick start it by doing all that stuff. Conclusion: If you sign up for premium and Spotify continues to recommend songs in your playlists then sign out, delete the app, download it again and sign in. 

View solution in original post

9 Replies

Re: Turn off recommended songs?

anupmak
Casual Listener

I have the same problem and it bugs the **bleep** out of me, how dare they put songs into my playlist. 

One of my playlists is learning another language and instead of staying on that, I get random F...... songs play!!!!

The work around I've found is to press the repeat all button, then it only plays the songs in my playlist.

Hope that helps

Re: Turn off recommended songs?

Bhood2006
Regular
That doesn’t work for me, it still adds songs. I don’t know if I’m doing something wrong or if I’m just cursed. I go to my playlist, tap shuffle play then tap the repeat all option...doesn’t fix it.

Re: Turn off recommended songs?

anupmak
Casual Listener

I've checked different playlists and it works for me, maybe try logging out of your account and having another go?

Re: Turn off recommended songs?

Bhood2006
Regular
Thank you but that doesn’t work either.


Re: Turn off recommended songs?

anupmak
Casual Listener

I feel for you, it's really a terrible service!

Solution!

Re: Turn off recommended songs?

Bhood2006
Regular

OK after 30 mins chatting with a Spotify rep, it’s now resolved. Idk if they worked some voodoo but at the end I had to delete the app and download it again, log out and log back in. My theory is that when I upgraded to Premium the settings remained the same as a free account and in order to get it to change this feature I needed to kick start it by doing all that stuff. Conclusion: If you sign up for premium and Spotify continues to recommend songs in your playlists then sign out, delete the app, download it again and sign in. 

View solution in original post

Re: Turn off recommended songs?

anupmak
Casual Listener

Thanks for letting me know. One question:- Once you did reload the app, what was their recommendation for turning off the recommended songs feature? Was there an actual formula or switch to do this or did they just tell you to press the repeat play button?

Cheers

Re: Turn off recommended songs?

Bhood2006
Regular
I didn’t touch any more buttons. Just redownloaded the app, logged in, tapped a playlist and tapped shuffle play.
Highlighted

Re: Turn off recommended songs?

Emgallll
Newbie

That worked for me. Thank you!  Was driving me crazy. For those where it’s not working I find you can jump over (FF) the unwanted songs in the beginning and then it won’t include them going forward. 

SUGGESTED POSTS