WTF, my iPod touch is refusing to play!!!


Re: WTF, my iPod touch is refusing to play!!!




I did get a (fairly quick) reply from Spotify when I registered the problem but I'm not sure that their suggestion would have worked - and anyway, by then I had solved it myself by going nuclear on the ipod touch.  (Easy for me to say, though, because I now use it ONLY to play music and don't use it for data storage or other apps.)


I restored the ipod to factory settings via iTunes, having first barred it from syncing with any other devices.  Then I downloaded the Spotify app for OS4 (not 5, which it apparently won't take) directly onto the ipod, bypassing iTunes.  Note that I located the correct version of the app by searching for 'Spotify' in the app function, which turned up a number of different versions.  Finally, I synced the rest of my (non-Spotify) music library (but nothing else) onto the ipod via iTunes.


That seems to have done the trick.  But clearly there is a problem that Spotify hasn't cracked.  I suspect that it has updated an app without thinking about the requirements of the Touch.  It's interesting that there are now several versions of the Spotify app available .....


Good luck.

Re: WTF, my iPod touch is refusing to play!!!

Casual Listener

Its March 2013 and the problem is still alive and well. My ipod touch is running ios4, only being used to deliver music. Spotify worked fine for 2 weeks but now plays for one minute then stops.


Any suggestions other than completely wiping this ipod?  it has literally done nothing else, no other apps loaded or anything but just decided to stop working.