Help Wizard

Step 1

NEXT STEP

music controls bug, no sound

music controls bug, no sound

I reported this issue on Twitter, but figured I'd open a topic here so others can chime in if they are seeing the same issue.

It seems Spotify (v3.9.0) and iOS 9 (and maybe previous versions?)?don't play nicely together when music controls are used in control center. I have reinstalled the app, hard rebooted the phone, soft rebooted the phone.

Steps to reproduce...

1. Force close Spotify app
2. Open Spotify app, but do not play any songs
3. Minimize Spotify.
4. Swipe up to open control center and select Play once. The button will not switch to a Pause symbol.
5. Open Spotify, song from last playlist is playing with no sound.
6. Try playing or pausing again from control center while Spotify app open. Icons don't update but you can see the song pausing and playing. Still no sound.
7. Pressing Play/Pause in Spotify app fixes song and sound. It also seems to resync control center music controller with Spotify app.

The real reason why this bug is annoying is that it breaks the new iOS 9 proactive music app selector. This feature makes it easy to resume music from other music apps (like Spotify) but fails to function with the control center music controls bug.

Alternate steps to reproduce that are triggered by the iOS 9 proactive resume...

1. Open Spotify, then force quit Spotify.
2. Open control center and notice Spotify is listed. Press play once. Wait a few seconds, press again.
3. Open Spotify, notice song is playing but no sound.
4. Pressing Play/Pause in Spotify app fixes song and sound. It also seems to resync control center music controller with Spotify app.

This bug does not exist with Rdio, iHeartRadio, Pandora, or the Apple Music App, which makes me doubt it's an iOS bug. I can open, then kill any of those apps and resuming playing them from control center without even opening the app. I think someone in the CarPlay thread complained about a similar playing but no sound issue with Spotify but not other apps.

Maybe this is an issue with Spotify's use of the MPMusicController API? If anyone from Spotify needs more information, let me know. Would love to see this fixed.
Reply
1 Reply

@dtshepherd

 

Thanks for the bug report. I have passed this on to be looked into. 

MattSudaSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Suggested posts