Announcements
We're experiencing some issues with the 2023 Wrapped experience. More info here.

Help Wizard

Step 1

NEXT STEP

premium account

Solved!

premium account

i was logged into my premium account on my i-pad yesterday all day.... not its telling me i am not a premium subscriber.  do you know why this is happening?

 

username:[Snip! - Mod]

Reply

Accepted Solutions
Marked as solution

Have you tried logging out on the iPhone, fully restarting the phone and then logging in again? 

The restart seems to force the client to pick up the subscription. 

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

View solution in original post

18 Replies

Hey!

Just taken a look at your account, and you should be up and running on Premium now. Try logging out and back in, and you should get up and running.
Airhorn Enthusiast

just logged out and logged back in..... still not working

As anyone else logged into their Facebook account on your iPad recently? You might want to ensure you are logged in correctly there first, and then try logging into Spotify using the "Login with Facebook" function.
Airhorn Enthusiast

no one has touched my i-pad.... just logged out and logged back in "login with facebook" and still not working

any other idea's

Hmm, odd. Our database seems to state that you are fully up and running with Premium. I saw that the Premium was updated today, and generally happens pretty quickly. You may need to wait a couple more hours and hopefully should be fine.
Airhorn Enthusiast

ok, cause it works fine on my computer.  and when i try to play on my i-pad... its say "only premium users can stream on demand"..... WHICH I AM

Hi I have the same issue but with my iphone 4. I just switched from free acct to a premium acct and now when I try to stream music, I get the "only premium users can stream on demand". But I am a premium acct holder. I too have tried logging in/out several times on both my computer and on my iphone. And nothing seems to work. When I check status on my computer it does say I have and "active premium acct".

I am having the same problem. My iPhone 4S has lost all playlists and says I am not a premium subscriber. Still works on my Windows phone and just checked online and my account seems all in order. 

 

Help. 

Marked as solution

Have you tried logging out on the iPhone, fully restarting the phone and then logging in again? 

The restart seems to force the client to pick up the subscription. 

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

I'm having the same issue - for offline playlists and songs I can listen fine on my iPhone 4S, but if I try t search for a given song, I get that same "Only Premium users can stream" message. I am a Premium member! 

FYI, after posting this I noticed the comment about doing a full restart of my phone and it worked! Success! Streaming away ... thanks. 

I tried all the steps above. Still having the same issue.


@CAM2615 wrote:
I tried all the steps above. Still having the same issue.

Hey! Welcome to the community 🙂

I would suggest you have a read at and try the steps outlined in this post.

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

Working fine yesterday, now I'm logged in but can't get premium access. I tried steps above still no good. My payments are current, please help

Please help


@user-removed wrote:
Working fine yesterday, now I'm logged in but can't get premium access. I tried steps above still no good. My payments are current, please help

Hey! Welcome to the community 🙂

Try the steps outlined in this post, any better?

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

I was logging in through Facebook and I just changed my password there and all is fine now!

Suggested posts