Announcements

Who Me Too'd this topic

No sound through Heos and Spotify Connect

Right, I've been having a big problem with my Denon Heos 1 speaker and Spotify Connect.

 

Initially, my Heos speaker was connected to my wifi, and I could find it on Spotify Connect, then I would go through the process to play through the speaker, but no sound would come out the speaker. The track would progress along the timeline as normal, but it was as if I had muted it (I hadn't on Spotify or my speaker). However, when I pressed pause, the track timeline would reset to the beginning of the track. Further, the Heos app couldn't find the speaker.

I contacted Denon, and they have provided numerous solutions, I have since managed to connect to the speaker through the app. I can play music through any service: Deezer, Tunein Radio etc. However, I still cannot play using Spotify. The only difference now is that when I pause, the track timeline pauses as it should. There is still no music being played.

 

I have soft and hard resetted the Heos speaker, changed network settings etc., and it appears the problem with the speaker is solved. I am using a Macbook Air and iPhone 6 on the latest OS. I have uninstalled the Spotify app on both, restarted both devices, reinstalled the Spotify app, then restarted both devices again, logged into Spotify on both, and the problem still remains. Yet I can still play music using any other service.

 

I have recently gone from Spotify student premium to Spotify family, so I have premium, but that's the only thing that has changed, I'm not sure how this could have affected it.

 

I have restarted my router (BT Homehub 5), I have checked all the settings for it, turned off and on again the UPnP settings.

 

Anyone have any solutions before go insane from a lack of music in my life?

Who Me Too'd this topic