Help Wizard

Step 1


Spotify Premium DOESN'T Work!!!!


Spotify Premium DOESN'T Work!!!!

Just upgraded my Spotify account to premium, have a receipt but every time I log in my account on my iPhone its still the same regular spotify! Please help or I'm going to have to cancel!

Accepted Solutions
Marked as solution

OK - seems to be working now.

View solution in original post

Marked as solution

Marked as solution


Clean reinstallation fixed.

Thanks o/

View solution in original post

111 Replies

The same thing is happening for me please help

Same issue for me.  I upgraded earlier today, and after logging out of the Spotify desktop application, logging back in, and even restarting and reinstalling, I still cannot get Premium features on my desktop.  Also, the mobile app does not recognize me as a Premium user.  Everything on both platforms looks exactly the same as when I was a free user.


Please fix before I have to unsubscribe and petition for a refund.

I have the same issue.  Just upgraded to Spotify premium today and it isn't being recognized on any of my platforms (desktop PC + iPhone + Macbook laptop)

I have the same problem!! I had premium a few months back, cancelled, and subscribed again just 15 minutes ago. Everything is good to go on my desktop but not on my iPhone. Help!!


Username: 1233383300

I have the same problem, Spotify tells me to upgrade my account or change my country in my settings even though I bought premium yesterday. Do anyone know if you have to wait for 24 or 48 h before it kicks in? I've already tried to reinstall the spotify software, didn't help..

I just signed up today as well and my desktop will work but not on my iphone.   it wont let me play anything but the radio and keeps saying i have to be a premium user to play anything but radio.   but spotify has me registered as a premium user.  

I just upgraded and am having the same problems. This is an extreme turn off when hsving an issue 10 minutes after paying them.

I am having the same problem.  I just bought it today as well.  I have uninstalled the program, restarted my computer, cleared my cache, logged in and out.  I'm not sure what else to do, but like everyone else, my credit card was charged immediately and I still have the same screen I had when I had free service.  I can tell it's not new because I have a link to "upgrade" and I am hearing ads still.  This is lame!

Is anybody from Spotify listening?  I just purchased the upgrade - same problem - no access on iPhone.  This is a terrible experience.  In this day and age such a UX Fail is just ridiculous.  


Spotify ppl whats the story??

Since my upgrade about 5 hours ago. I have tried installing, reinstalling, restarting, and everything else recommended by the users with the same result.
For something that is $10 bucks a month I expect at least some sort of response from customer service. Is there even customer service that's the real question. The idea and the program/app is great when it works, but when it does not your stuck commenting on a forum that has way more problems and questions then answers.

As mentioned in earlier post my spotify premium does not work on my iPhone. What's the next step besides trying to get my money back?

Please respond

Yes, happening to me also. Not good enough guys.

Hello all.

There's a number of threads relating to this issue, so I apologise for the delay in responding. We're investigating why some users have been unable to get access to the Premium service after upgrading.

The first troubleshooting step to try would be to log out and back in again. If this doesn't seem to work, just let me know in this thread and hold tight for a moment - we're on the case!
Airhorn Enthusiast

I have tried several times. I am using Facebook to log in. I dont have a sraight spotify account. Does that make a difference.

C'mon guys get it together. This is really frustrating.

@DavidChan wrote:

C'mon guys get it together. This is really frustrating.

We're on it, David! Great name, by the way 😉

Airhorn Enthusiast

Logged out for the 10th time. Re-installed, still not working.

I've re-installed and relogged out/in multiple times.  I've done the same for all my devices.  There's no change: the problem still persists.

Tried everything but still not working

Thanks for getting me know so far. No updates yet, sadly.
Airhorn Enthusiast

Suggested posts