Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Autoplay when connecting to bluetooth

Autoplay when connecting to bluetooth

 I've been having an issue with Spotify automatically starting and resume playing anytime bluetooth connects to my headphones or truck.  I've tried all the "solutions" that I've found listed online and none of them work, or are terribly inconvenient, like logging out or turning the settings for my Bluetooth devices to not be used for media, or restricting back ground usage (then the app won't work at all if the screen times out, which creates other problems).  Since the devs over at Spotify won't add an in app option to disable it auto starting and playing in the menu (like other apps are said to have because some developers actually listen to the people who use their app).   This isn't a complete solution because you still have to clear Spotify from the back ground when you're disconnecting the Bluetooth device, otherwise it starts autoplaying as soon as it reconnects.  I've been having this issue since Android 8 and am currently on Android 11 on a LG V60.

 

In your phone settings go to: apps > Spotify > app notifications.

 

Tap on the playback option and change it from "high importance" to "medium importance"

Switching it to "low importance" would also work, but then you lose playback controls in the notification shade.

 

I've tested this with my headphones and it works, I still need to test it in my truck but am confident it'll work there too.  I don't know if this is a work around if iOS has this issue or not.

 

I've attached a screenshot of the notification option to change, hopefully this helps someone.

 

EDIT: unfortunately this ended up not being a long term solution, as Spotify is now acting the same as it was before.

Screenshot_20220306-111604.png
Reply
47 Replies

I am about to cancel Spotify unless I can find a fix after this post. I Have been searching for 2 weeks and this is the only post I've found which remotely addresses the issue.  Using a Samsung S23 Ultra.  EVERY time I get in my car it just starts autoplaying!!?   Why would Spotify not have a fix for this.  I

In the Spotify app there is a setting "Allow connect to run Spotify in background" or words to that effect. That should work. Also you can still play Spotify while using other apps, that is not 'background'. See if that fixes it. 

If Spotify connect had anything to do with Bluetooth that might work.  Except the fact that Spotify connect is only used to stream the music on other devices, like speakers or a TV, as long as their connected to a TV. 

On vacation right now with the family, my phone is automatically auto playing in my family's car and it's annoying, even with the app off.

 

Thank God my problem doesn't extend to other devices like some of the others on this thread, if it did, I would definitely jump to a different music streaming service.

After a long time of fighting with every possible setting in this Andoid hellscape I have finally figured out a fix.

 

 

I will preface this answer by saying that I have a 2016 Mazda, it is Bluetooth enabled but DOES NOT HAVE ANDROID AUTO COMPATIBILITY. I use a basic Bluetooth connection, not any special app or anything for functionality with my car.

 

Go into your app settings and go to Android Auto. DISABLE THE APP COMPLETELY USING THE "DISABLE" BUTTON AT THE BOTTOM LEFT NEXT TO "FORCE STOP"

 

This will block all permissions at the base level and shuts the app off completely. Even if you do not use or have compatibility with Android Auto, apparently it still has an effect on the system enough to force open apps when using Bluetooth and, for whatever reason, defaults to spotify.

 

Again

 

-open settings

 

-go to app settings

 

-scroll to Android Auto and click to open app settings

 

-click "Disable" in bottom left corner

 

-never have to worry about screaming at spotify to shut up in your car or on Bluetooth again

 

I have now spent 15 minutes turning Bluetooth on and off and have reconnected multiple times to my car without having the issue happen. I will update this answer should it change, but 6 months of fighting with this is finally over and I'm ready for a drink and a cold shower.

 

Cheers, and happy (quiet) driving.

Agree!! I've left a one star review on Spotify - I think it's the only 1 star review I have ever given! It is so annoying. On a more serious note, my 3 year old daughter was in my car and I had to run back inside to get something and took a few minutes finding it. When I came out Spotify had turned on FULL volume! It was very loud and she was screaming not knowing how to turn it down. She got scared every time the radio was on for months afterwards. And the f**ckers at spotify don't give a dam.  

this doesn't work for most devices.  even with android auto completely uninstalled, not just disabled, spotify still acts the same. 

When I connect my Bluetooth device, Spotify automatically starts playing songs which is annoying

Suggested posts