Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

[Connect] Disable automatic switching between devices

[Connect] Disable automatic switching between devices

Spotify Connect is great but the automatic switching is not for everyone.

 

Please allow us to disable automatic switching between devices. I understand Spotify doesn't like user to play in more than one device and I am happy with that, but the application shouldn't switch devices if the user does not want to do this. It clearly creates frustration amongst users.

 

In my particular case I work from home listening to music on my computer. I find really annoying when I plug my headphones in my phone to take a call and suddenly the music starts playing in my headphones.

 

This is what happens step by step:

  • Spotify is in my mobile running in the back.
  • Spotify is playing in my computer.
  • My phone rings.
  • I take the call at the same time that I get my headphones on me.
  • I listed to a combination of my client/colleague and the music that I was playing in my computer, usually very loudly.
  • I stop the music.
  • I comment with my client/colleague how bad is Spotify.
  • I finish my call.
  • I go to my computer, change the playing device on Spotify to my computer and play again.
  • I do this a couple of times until I get fed up of Spotify and I play music from somewhere else.

This problem has been already described here: LINK  but it has incorrectly tagged as repeated (the problems and solutions suggested are different).

Reply
106 Replies

Hi,

 

I haven't found anything on this but maybe my search terms were not precise enough. I mostly use Spotify Connect to play music on my Sonos. That works well until I connect my bluetooth headphones to my Pixel 3. When I do, normally to listen to podcasts in another app when leaving home, this makes Spotify switch the playback device to my phone and continue playing there. Normally, I don't want this - I'd prefer my Sonos to keep playing until I decide otherwise.

 

Any way I can prevent this behavior?

 

Cheers

Ben

Hi,

for some reason, I have encountered this really annoying feature - as far as I know this is new.

 

I have Spotify Connect playing on my home speakers via my android Samsung S9 and I connect put in my headset (maybe to receive or make a call), Spotify automatically switches from Connect to the device and starts playing on my headphones.

 

This is REALLY annoying. I understand it in normal playback (on the device, not Connect), but  Connect is Connect, I don't want what's happening on the phone interfering.

 

Is there any way to turn this off?

Hey @50lwjk_-htbts!

 

Thank you for reaching out on the Community and sorry for the delayed reply.

 

It sounds like the playback of the music is changed back to the device connected to your phone via Bluetooth, which is expected at this point.

 

We appreciate you taking the time to share your feedback. We recommend leaving a +Vote on this idea if you'd like to see this changed.

 

If you're interested in how ideas work and how your feedback reaches the right teams here, check this page out.
 
Let us know if there's anything else we can do for you. We'd be happy to help.

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey @HidalgoF,

Thanks for reaching out on the Community!

We've moved your post to a relevant Help Board where it fits better, as the auto-play functionality isn't completely dependent on Spotify, so we can't guarantee an idea about it would get implemented.

 

Different phone models, handle the auto-resume of music when devices are connected (either via Bluetooth, or aux) differently and a lot of it is based on the individual firmware (ROM) of said device. The best way to guarantee your device doesn't switch to music playback from Spotify is to ensure that Spotify is completely closed and isn't loaded in the background. If music starts automatically even when Spotify has been closed completely, let us know and we'll see what we can suggest.

Hope you find this useful. Keep us posted if you have any questions.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi,

Thanks for your answer but I am sorry to disagree. Spotify only starts
playing on my headphones when it is playing somewhere else, otherwise
nothing happens when I plug my headphones and Spotify is open.

Kind Regards,
Fer

Hi @HidalgoF,

 

Thanks for your reply.

 

Can you let us know if this also happens when you're listening to Spotify on your computer, but you don't have the app open on your phone?

 

We'll be on the lookout.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hi @CarlosE,

 

Thanks for getting back to me so quickly. I have done a bit of testing and this what happens when I plug my headphones in my phone:

  • When Spotify is playing in my computer and it is closed in my phone it does not start playing automatically.
  • When Spotify is open in my phone but it is not playing anywhere else, it does not start playing automatically.
  • If I have YouTube Music or any other music provider and I plug my headphones in my phone, nothing happens.
  • When Spotify is playing in my computer and it is open in my phone (even in the back), it starts playing automatically, even if I am in the middle of a call. This is the problem that I reported.

I think this is not related to my phone, because it only happens when Spotify is playing somewhere else, so Spotify has the control to start playing in my phone or not. This does not happens with other music apps.

 

Thanks,

Hi @HidalgoF,

 

Thank you for your reply. 

 

Please go to your phone Settings > Apps and check if your default music app is Spotify. In case it is, please disable it as the default one and check if the issue persists.

 

If it doesn't do the trick, let us know the make, model and OS of your devices, as well as the Spotify version you're running. 

 

Lastly, let us know if this issue occurs when you have connected your headphones or also when you're using the phone's speaker. 

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Happens to me to each time I listen to music on my Bose Sounbar with Spotify Connect. Every time I take my earpods out of the case to make a call the playback switches to the earphones. Is there a way to stop this? The situation is extremely annoying! Thanks

Same here.
Casting music to google nest from my pc. When I connect my galaxy buds to phone, music stops and start playing from headphones.
There is no such think like default music app on my phone.
Samsung galaxy note 20 ultra
Galaxy buds 2
app version 8.7.8.1206

Hi @basforce,

 

this is currently the expected behavior if the app is open on your phone, even in the background. To prevent this from happening, make sure the app is fully closed and isn't running in the background.

 

The intent here is to allow for seamless transition to listening from one device to the other. When the app is active on the second device, plugging in headphones is interpreted as an intent to listen to music on the device. If you your specific usage scenarios differ, make sure to close the app and you should be good to go.The autoplay should not kick in then.

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I agree with the originating post of this conversation.

 

I have the same specific problem. I am running Spotify on a Mac, which then uses Airfoil to distribute the music throughout the house, and I often use Spotify Connect on my iPhone to control the music remotely. Often, when I put my AirPods in to make a phone call, or for some other purpose on my iPhone the music automatically switches to my headphones. This *only* happens with Spotify.

 

There are times when I appreciate and enjoy this feature,
especially when I’m about to go out for a run or a bike ride and want to take the music with me. And then there are other times when I find it frustrating and/or inconvenient.

 

I don’t necessarily want to have to take the extra step to force quit the Spotify app on my phone running in the background every time I want to make a phone call.

I feel that there should be a more elegant solution. Perhaps a user interface upgrade where there is an option or prompt to allow the user to have control over whether or not the music transfers to the phone automatically.

I have the same problem..driving me crazy. (Samsung phone)

 

 

WORK AROUND:

I had the exact same problem (Samsung Galaxy S10, Android 12)

 

I agree that when a call comes in you don't want to start messing around with closing down background apps.... you just want to plug in your headset and take the call.

 

... It looks like I was able to solve it by removing spotify's permission to nearby devices... As a result Spotify will not show the name of the Bluetooth headset connected if I tell it to play on the phone, but I'm happy with my solution.

 

The correct way to solve this is for Spotify to add In its options the ability to turn this autoplay on headset attachement feature off... Blaming it on the OS is BS, proven by my workaround.

 

SPOTIFY TEAM, SEARCH THE INTERNET TONS OF PEOPLE ARE HAVING THE SAME PROBLEM, PLEASE PROVIDE THE SIMPLE OPTION REQUIRED.

 

Note my workaround only solves it for Bluetooth headsets, problem still occurs with wired headset.

 

 

Hi @kecologic,

 

Thank you for your reply and feedback in this thread.

 

We're always testing things by adding or removing features to make Spotify better overall and we’re constantly aiming to improve our features. We’re sorry that this means you’re not able to use Spotify like you wish to do at the moment.

 

You can read more about how your feedback reaches Spotify here.

 

Once again - thanks for the feedback, we appreciate it. Let us know if we can help you with anything else. 

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Thanks! This worked out great on galaxy s20 as well.

Hey @krazineurons,

 

Thanks for the reply.

 

Glad to hear that everything is working fine again 🙂

 

Don't hesitate to give us a shout if you need help with anything.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I just want to add my voice to the original post. This is unintended behavior of the "seamless transition to listening from one device to the other" in Spotify and it causes so much trouble.

Unfortunately for me I can't use the workaround. My use case is typically that I'm playing music from Spotify on my phone, cast to smart speakers in my kids' rooms. This is at night, playing soft music to help them go to sleep. I then connect headphones with no intention of using Spotify at all, maybe I'll watch a movie or play music using another player, and Spotify immediately resumes playing on my phone. I didn't ask for this! Honestly I'm not even sure who uses that seamless transition feature, but it should at least be behind a user controlled on/off setting.

This better get resolved asap or I'm done.  I have a laptop with Spotify installed and I use to be able to use my phone or a tablet to control Spotify on the laptop.   Now it just keeps switching back and forth.  Connect feature is now completely worthless.  Spotify has so many bugs now that I'm looking for other music apps.  I'm tired of messing around with their bugs.

Suggested posts