Announcements

Help Wizard

Step 1

NEXT STEP

Option to disable automatic playback on Bluetooth Connect

Option to disable automatic playback on Bluetooth Connect

Spotify automatically opens and starts playing music whenever I connect my phone to a bluetooth device. I really need an option to disable this!

 

This occurs on all devices I've tested and has been an issue for a while.

Reply
58 Replies

Hi there!

 

To turn off auto play please try the following:

  1. Tap Home .
  2. Tap Settings .
  3. Under Playback, scroll down to Autoplay and switch it on (green) or off (gray).


If that does not work for the bluetooth, I’d suggest starting a new thread in the Community Ideas Exchange.

This’ll allow users, Stars, and Moderators to vote and comment on it.

Jack 🙂

Hi, thanks for your reply. Unfortunately that autoplay toggle is for automatically playing related songs after a playlist ends, so unrelated.

Oh Ok I now unserstand what your talking about,

So your issue it that it plays different songs after the playlist ends right?

Jack


@Jᴀᴄᴋ wrote:
Oh Ok I now unserstand what your talking about,

So your issue it that it plays different songs after the playlist ends right?

Jack

 

No.

 

I really appreciate you trying to help but please read the OP and my previous post again. I really wouldn't know how I'd be able to explain the issue I'm experiencing in clearer terms than I did there. 

Any updates on this? Running into the same problem.

Same problem here. 

 

How in the world can the developers think that this is a good idea, especially when not even giving an option to disable it? Nobody, I repeat NOBODY want's the stupid #€%# to start automatically making noise whenever you turn on your headset.

 

Fix it, now.

I agree this is most annoying.

 

Ideally there should be a setting to prevent spotify from playing any song uppon startup.

 

Problem: whenever I start spotify (does not matter if I start it manually or if it starts automatically on bluetooth connect), spotify resumes playing whatever song was playing last time it was turned off/powered off/shutdown.  A must embarasing thing when friends are in the car and your "solo drive home/meditation playlist" start playing.

 

Only solution I have found is to logout out (settings /logoff) every time I am finish listening.  Needless to say I stopped using spotify regularly - all due to this problem.

 

Eric

Hey everyone,


You might be interested in following and supporting this Live Idea: https://community.spotify.com/t5/Live-Ideas/Android-Bluetooth-Stop-Spotify-Autoplaying-on-App-Open/i...

I also experience the similar issue. Whenever I open my spotify app with a bluetooth earphones connected on my device, the all autoplays the last song that was played. It is so annoying. I don't think it's even in the settings. Could it be a bug of the latest update? I never experienced this before.

Same issue here. Who the **bleep** on the dev team thought that this was a great idea? Seriously.

My favorite is getting an important call to my laptop Teams client, grabbing headphones and running to a more silent place in the office leaving the phone on the desk. When I turn on the headphones to answer the call they connect also to the phone and**bleep** which I was listening on the way to work in car starts autoplaying. ARGH.

 

At least give us an option to disable the behaviour in some other way than uninstalling the Spotify client. 

I seem to have the opposite problem, but I assume it is caused by the same behaviour..

On the Windows App, if I am listening with Bluetooth headphones or a Bluetooth speaker and I stop/pause the playback, the music stops, but it will then start playing automatically when I turn off the Bluetooth headphone/speaker. 

It's very annyoing because my Bluetooth speaker has a timeout for shutting down if no music plays for a while, so if I leave for lunch for example, when I come back the music has started playing on its own through the laptop's speakers while I was away.

I like this app, but there has to be a better app that does not have this issue. Says solved. It is not solved!

I've just managed to solve the problem on my android phone. While the Bluetooth headset is connected: 1) go to phone settings 2) Go to sound settings 3) Earphone mode 4) Disable the 'Auto Play' function. Worked for me. Hope this will help 😊

Double post

That does not solve the problem. Autoplay in app settings is a feature to continue playing similar music after your track ends. It does not address the problem where Spotify plays endlessly in the background while you are listening to other audio sources. Starting phone or connecting to your car's Bluetooth or other apps opening Spotify causes it to start playing and wastes data as a result. Need an option where Spotify only starts playing tracks if you press the play button in the app or a connected app.

THANK YOU! YOUR COMMENT IS THE ACTUAL SOLUTION! For everyone searching for a fix to Sotify auto-playing on Android...
The fix to this problem is:
in Android Settings > Sound > Earphone mode> Autoplay > CHANGE THIS SETTING TO OFF!!!

YAY!!! Thank you, I'm so happy

Android settings, you mean the settings on my phone? It doesn't have an "earphone mode" setting on my phone so 🤷‍♂️.

Have you tried while you Bluetooth headset is turned on?

Suggested posts