Announcements

Help Wizard

Step 1

NEXT STEP

Option to disable automatic playback on Bluetooth Connect

Option to disable automatic playback on Bluetooth Connect

Spotify automatically opens and starts playing music whenever I connect my phone to a bluetooth device. I really need an option to disable this!

 

This occurs on all devices I've tested and has been an issue for a while.

Reply
Top Answer
Mihail
Spotify Legend

Hey everyone,

 

Thanks for reaching out and reporting this behavior to us.

We'll make sure to take it into account while moving forward, however we can't set an exact timeframe for when this will be fixed. The reason is that the autolaunch &autostart  functions are dependent on the way a device is configurated to interact with the app API. We recommend that you reach out to the manufacturer to report the issue with them as well.

 

That being said, some users report that they managed to fix this by altering certain settings on their device. We've compiled a list of possible solutions for you to try bellow:

 

Hope this helps!

58 Replies

Yes

As Eriksen mentioned, I would see if having your Bluetooth headset turned
on and connected to your Android phone forces an ephone submenu in the
sounds section of settings. If not, I would explore the menus available in
settings and look for something related to sound and headphones or
earphones and any kind of reference to autoplay. In our experience, it was
an annoying Android feature that was on by default, rather than an unwanted
feature of Spotify.

I have fixed this on my Huawei P20 Pro and stop Spotify launching on my AirPods. 

Go to:

Settings>Apps>Apps>Spotify>Power Useage Details>App Launch

Turn off the Manage Automatically Option

Then underneath you have 3 options to manage manually. 

Turn off the Auto-Launch Option.

Press OK. 

Screen shot of how the final option should look attached. 

I haven't fouund a way to stop my car from launching and playing Spotify yet.

Screenshot_20191215_221153_com.huawei.systemmanager.jpg

I just want to get in my car and Spotify does NOT immediately start playing, even though I stopped playback before I left the car, turned off the app, AND the app isn’t even on so I can’t stop the music. So imagine me on the phone during a conference call while getting back in my car, starting the car, and then fumbling for my iPhone to turn the app on just so I can turn the music off. It makes me want to NOT use the app.  But I guess I know what Ek’s response to that would be.

 

I can’t help but wonder if the dev team is being intentionally obtuse. It’s a great app, and a popular service. So the notion that such a simple support request comes up so often and almost always receives an answer to the wrong question really makes me wonder. Are they simply blowing wind to cover a marketing strategy? It sucks, but after Daniel Ek response about privacy, I guess that’s what I would expect. The alternative is that they really are just not getting it, which is actually more disturbing.

No solution to Spotify starting when I start my car. Very problematic on many levels. Amazing, when I stopped subscribing, it never once began playing when I started my car.

Hi there. Great! But where is this settting on the S10+? 

So, for anyone still wondering why your bluetooth automatically begins playing the music (especially, if you are in the car).

 

To solve this, go in spotify to settings, scroll down to Car view and turn off "turn on automatically".

 

Worked for me! 

Never use car mode but have tried enabling then disabling. No go. Only time
this didn't happen (Automatically start playing when I start my car and my
phone connects to BT) was when I was a free user. Ever since I became a
paid subscriber, there isn't a way to assure that Spotify can be prevented
from starting automatically. If anyone has figured out how, let me and the
rest of the annoyed Spotify subscribers who dislike this "feature" know.

Same!! IDK why Spotify refuses to acknowledge this issue! I will likely stop using it altogether and put my money into a premium Pandora subscription if this isn't fixed. ONCE AGAIN, the issue is that the Spotify app automatically opens in the background and begins playing whatever song was playing last as soon as the phone connects to a Bluetooth device (in my case, my car). NOBODY WANTS THIS. I often get into my car early in the morning and don't want to automatically get blasted by music. Or maybe I want to listen to the news or a Youtube video. And maybe during my drive I want to pause that video. That DOES NOT mean I want Spotify to start up again! I've dealt with this in multiple cars for too long and can find no setting (whether on my phone, my car stereo or the Spotify app) to disable this, except to keep my phone's Bluetooth setting turned off all the time. 

I have car view turned off and I still have this problem.  Whenever I switch to BT mode in the car, Spotify starts automatically.  I can't find a solution.

Pretty much anyone with Spotify can't turn this off. Tried direct Spotify
support with no results. Waiting for a fix or another app.

Worked for me with an Android Galaxy S10. Go to your phone settings, into Apps then into Spotify. Once in Spotify settings go to Battery and disable Allow Background Activity. This stops the app from doing anything without being manually opened.

Great I will try this!

This was not the solution.  Who was the person who termed this problem solved.

 

It is not solved and this mistake hurts everyone.

I'm not sure why it affected the Spotify app, but I was able to stop the bluetooth auto-play on my Pixel through a setting in Google's 'Play Music'.  Steps:

 

Open Play Music -> Press the 3 line button (aka hamburger button) -> Settings -> Scroll down to "Allow external devices to start playback" and disable it.

 

Hope this helps someone else!

Just tried on Pixel 4 and didn't work.

I have the same issue on pixel 4. Have speakers linked to my phone via BT. However when the speaker is on and used for TV sound. Of I start Bluetooth on phone it will auto connect to the speaker and open Spotify instantly and play. This is getting annoyed and seems that a fair few have the same issue. Please make an option to disable this 'feature'.

Thank you finally a workable answer for my note 9

To summarize - a solution to this issue has yet to be suggested (other than a few workarounds that don't work for everyone). I have a Samsung Galaxy S10 and in the Spotify app there is no setting called "Battery" or a toggle to "Allow Background Activity." Disabling "Allow Gapless Playback" only stops Spotify from playing similar music after you've searched for and played a specific song. The app continues to open in the background whenever it wants, which is annoying if you don't want to hear music at the moment or you're using a different app (Ex: Listening to a Youtube video and you need to pause it for a second. That is NOT an invitation for Spotify to open in the background and start blasting the most recently played music.) It's frustrating that Spotify continues to ignore this issue and I know many people who no longer use the app because of it. Personally I just deal with it because I don't like the Pandora app and at least Spotify Student is cheap, but I'm really starting to lose my patience. 

The setting is not in the spotify app. It is a system setting and only
maybe visible when your phone is connected to a Bluetooth device

Suggested posts