Help Wizard

Step 1


Spotify stop playing after every song. Sony Xperia Z5 compact

Spotify stop playing after every song. Sony Xperia Z5 compact

After the latest update to the playback stops at the end of every song. No error message is shown and if I press next the next song will play but then stop again at the end.
47 Replies

I'm having the exact same issue as of today pal. Also not great because I'm on free, so to get it to continue playing I have to press skip, but can only do that so many times and then I'm stuck with no music


Edit: Mine is a normal Z5, not a compact (although I doubt that makes a difference)

Same problem here using z5compact with premium account.
Spotify doesnt play the next song automatically.
Tried uninstall and reinstall spotify and the same problem persists

Looks like it's an Xperia issue. Do you also have issues on your Z5s work the controls disappearing from the lock screen? I payed about our Lady week but nobody replied 😕

It started with the update that came yesterday. Before that there was no issue, so something on the spotify side has changed. But I have also had issues with the controls sometimes not showing up in the lock screen.

Same Problem for me. Spotify stops after every track, does not matter if its a generated playlist, album or on shuffle etc. Spotify Settings still has "seamless playback" enabled. Did anyone solve that yet?

I'm having the same exact problem as of the update, also with an Xperia Z5 compact.  I've tried restarting, changing the playback quality, deleting the app and reinstalling... nothing. 

I have exactly the same issue for the regular Z5.  It is really annoying and also started with a recent update. 



I can't gurantee if this will work but if you have your Spotify app linked to your sony music account, try unlinking it by deleting the "Sony Entertainment Network" account under Android settings, restart the app and see if this fixes it.  

In my case I don't have that connection so the root cause should be something else.

I spoke too soon, it worked once then it stopped again.  It must be something else that's causing it, it's so frustrating!

The same here with a z5 i tried almost everything but nothing worked

I have just emailed technical support but after trying all the various methods they told me to perform factory reset my phone (!), which of course I am not going to do since I am pretty sure it won't fix it.  As the app was working fine until the update last night I am guessing it must be something that conflicts with either a setting or configuration in the Z5. I think it woud be a good idea for everyone to get in touch so that they know about it. 

I had the same problem. I got a Z5 regular one. I uninstalled the application and reinstalled it using this app:


Thanks very much, that was exactly what I was hoping to find! It's working fine again now.

For everyone else, please DO NOT factory reset your phone to try to fix this!!

Same problem but a regular Z5.

Same problem here on z5 compact

Same here on Z5 Compact, tried uninstalling, clean install, downloaded an album locally, still not working, will try link above, so annoying, their testing is awful for every upgrade.

Ok then, clean install then install from link above has sorted it, many thanks Schwinnie, as per the adivce DO NOT INSTALL UPGRADE after installing.

Have been talking to spotify via twitter andit has been forwarded. I don't see this on my Z2 tablet so it's something in the Z5 range.

Suggested posts