Stops playing on Samsung Galaxy S7 Edge

Solved!
Reply

Stops playing on Samsung Galaxy S7 Edge

Kensel
Casual Listener

Hello,

 

Since a few days I've got the Samsung Galaxy S7 Edge to replace my  Galaxy S6.

 

But when I'm listening to my playlists and the phone gets locked (screen turns to black and I need to enter my fingerprint to 'wake up' the phone) Spotify stops playing after the current song has ended.

 

I tried to change the 'wake up security' to password, pattern, just swipe but with all these the problem remains.

I also tried to delete the cache and data and even re-installed Spotify completely - but without effect.

 

Does anybody knows what setting I need to change or how I can fix this so I can listen to my music either if my phone locks.

 

To totally give up the security is not an option.

 

Hope that anyone can help.

 

Device: Samsung Galaxy S7 Edge (SM-G935F)

Android 6.0.1 - Marshmallow

Spotify version: 4.9.0.992

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Analbatross
Casual Listener
If your phone has a battery saving option, you might want to turn that off if its on and then try using spotify again while locked to see if it worked. That was the issue with mine and when i turned it off it started working fine while locked. Im using a Galaxy S7.

View solution in original post

Solution!

Cerda45
Casual Listener
If you go into power saving mode settings, at least on the s7 edge, you can turn off the "restrict background data" and it will fix the problem even with ppwer saving mode on.

View solution in original post

48 Replies

Mikemike14
Newbie
Same here I'll get about 2 songs the it stops.

Jdawg253
Newbie
Same here...thought I was the only one.
Solution!

Analbatross
Casual Listener
If your phone has a battery saving option, you might want to turn that off if its on and then try using spotify again while locked to see if it worked. That was the issue with mine and when i turned it off it started working fine while locked. Im using a Galaxy S7.

View solution in original post

Kensel
Casual Listener
This worked for me also.
Thanks for the information!

Gtap84
Newbie
Changing the battery saving option fixed the problem. I had a feeling it was the phone from the start, but could quite figure out how. The music would stop playing after every song. It would even stop if I skipped a song. Until I came across this post, I didn't think the issue would be resolved, unless it was on Spotify's end. Definitely. Thank you for the info.

Aviate27
Regular
This needs to be fixed, this is not an acceptable solution. Spotify needs to address this immediately.

ConfuzledB
Newbie
I had this problem too. Thanks for this solution. I was also wondering, as this occurs due to power saving mode being activated, is there a way to change how much data is restricted by the power saving feature? Or even change the restrictions for specific apps?

mcjunkinj
Newbie
Mine was an issue with the background data being restricted. I had the same symptoms, but didn't have power saving turned on. I had turned off background data, which would stop my music after 2 songs (presumably the next song had already buffered). I thought it was worth mentioning here as I didn't find a lot of posts reporting this problem.
Solution!

Cerda45
Casual Listener
If you go into power saving mode settings, at least on the s7 edge, you can turn off the "restrict background data" and it will fix the problem even with ppwer saving mode on.

View solution in original post

Analbatross
Casual Listener
You're a genius! I hadn't been using power saving mode because of this issue, but now I can start using it again! Just tried it and it works! Thank you for the tip

Cerda45
Casual Listener
Hey, glad i could help out, it flustered me for a bit until i figured it out as well haha

Nessiemupfeki
Casual Listener
My power saving mode has always been off but i still get the same problem . Anyone with anotjer solution?

Joe
Community Legend

Double-check the following android settings.

 

  • Wifi/More/keep wifi on during sleep - set to always
  • Battery - Power saving modes off
  • Battery/App power saving/details - make sure Spotify is not listed. If it is, select and disable

Multiply
Newbie

This is by far the best solution. Thanks.

Emmuh
Newbie
Thank you! This helped for my phone too!!

TNspotUser
Casual Listener

That did the trick, THANKS!!!

nickyw71
Casual Listener

I've tried all of this and nothing stops the lock screen activating on my S7 - Spotify seem unable to help.  Never had this problem on my S4, seems like the technology has gone backwards.

sultansaaty
Newbie
Wow. We didnt notice this man. U a genius. U spotted the fakin obvious since we dum fuks dont already know it has to do w the power saving mode.
SUGGESTED POSTS