Announcements

Help Wizard

Step 1

NEXT STEP

The Data Saver always remains on in my Motorola Edge 40

The Data Saver always remains on in my Motorola Edge 40

Anybody know how to change the audio quality as it always shows data saver is turned on but its actually off ?

Screenshot_20231201-235410.png
Reply
54 Replies

Hey @Soumabho,

 

Thanks for reaching out. We've moved your post to the Help board as it better fits here.

 

We'd recommend reaching out to Motorola support to check if there are any device-specific settings that might be limiting the data that the Spotify app is allowed to use.

 

Let us know how it goes.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Yes, getting the same error. Not sure how to solve this. Please help if someone got the solution 

Turn on "allow background data usage".That fixed it for me

I had the exact same problem on my Moto G84.

Gnote3's solution seems to work...even if Motorola's data saver is off, go to it in the phone's settings and add  Spotify to the "apps without data limits"

Have to turn on Datasaver in android and toggle "allow background data usage"  for the spotify app to fix it. Afterwards the issue automatically returns and have to do the fix again. On Motorola Edge 40 neo.

Here's the fix that I found out. Go to app info page of Spotify. In mobile data and wifi, toggle "unrestricted data usage"  button. Do this even if it is switched on already. It works for some time but the issue return again after some time.

Do we all have Motorola's? All in the edge 40 family? Or same generation like the G84?

I'm on a Samsung S22 with One UI 6.0

On Edge 40

Same issue on my motorola edge 40.... This needs to be fixed, it is very very annoying as the low sound quality is very bad. Turning unrestricted data usage off and on again fixes it but only temporarily. Feel free to reach out if details about device / spotify are needed.

Plan

Premium

Country

Czechia

Device

Motorola Edge 40

Operating System

Android

 

My Question or Issue

My audio quality settings are greyed out and locked on low. I tried looking for solutions, but nothing worked. I do not have Spotify Connect on, I do not use a data saver, not in the app, not in my Android. I tried reinstalling, which fixed the issue for a bit, I was able to change the quality, but a day later it had switched itself back to low quality and got greyed out again. The only way for me to listen to any music is by downloading it prior, because the low quality is ubearable. And having to download entire playlists is just ridiculous. If I didn't have other people in my Family, I'd cancel my plan immediately, as Spotify has just completely lost it's value to me. I'm losing my mind over this.

Hi, Motorola sends me directly to Spotify. The Spotify app has this bug and needs to be fixed by Spotify. 

What's next?

Hey folks,

 

Does this occur only when connected to a bluetooth device? I'd recommend logging out and signing back in to your account twice in a row - this will trigger an internal refresh of the app that may help here. If you use any battery or app optimization settings, try toggling them off to see if that does the trick.

 

In case the issue persists, please share a screenshot which shows how things look on your end, along with the exact version of Spotify you're running so we can investigate further.

 

Keep us posted. Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

No, not related to bluetooth as the quality is once again set to low, with the Spotify app stating that the Android Datasaver is on, which is not. And i havent had my bluetooth on since yesterday.

 

The logging out twice thingy doesnt help.

 

 

 

Something makes Spotify think that the Android Datasaving setting is on. But what is it?

 

 

 

Also: keeping Spotify in the list of apps that can use unlimited data does not make the issue go away. You really have to toggle Spotify to have unlimited data within the Android datasaver option again to enable high audio quality.

 

I never use the datasaver option and i'm only toggling it to get rid of this bug.

 

Imagine having to do this multiple times a day because you hear the audio quality is returns to low...

The issue returned over night. Toggled the unlimited data button for spotify and it's fixed for the next couple of hours. I don't even have to turn datasaver on off. It's off the whole time. Somehow Spotify reacts to that unlimited data button behind the datasaver button even though the main button is off all the time.

Screenshot_20231218-092042.png

What I did was uninstall spotify then connected to a different network then installed spotify and surprisingly saw the audio quality settings unlocked then I changed my wifi to the previous one which I was using first and then checked that the issue returned or not and to my surprise the issue no longer persisted.

Why is a reaction marked as solution that was a temporary solution? 

Issue was gone for a few days, but returned after using Android Auto.

This is not solved! The solution above is a workaround at best and I seriously doubt its effects will actually last.

Suggested posts