Announcements

Spotify Debian package for Jessie(testing)

Solved!

Spotify Debian package for Jessie(testing)

The package that is on spotify repository is not working in Debian Jessie, this is happening because Debian Jessie has libssl1.0.0 and spotify works with libssl0.9.8. I removed the dependency for ssl from the package and i add to data folder the compilied files of libssl and libcrypto. I just sharing this package for other people that using Jessie and have the same problem, until the problem solved officialy from spotiy.

 

  1.  Download the package
    http://83.212.107.72/spotify-client_0.9.4.183.g644e24e.428-1_amd64.deb

  2. Install the spotify-client(is only for 64bit)
    dpkg -i spotify-client_0.9.4.183.g644e24e.428-1_amd64.deb

  3. The next command is needed if you have missing dependencies
    sudo apt-get install -f (maybe you have to install dependencies manualy)
Reply

Accepted Solutions
Marked as solution

Hey @equex,


You can get your hands on the .deb package here. This package is working with libssl1.0.0.

You will need to install it manually using 

 

dpkg -i spotify-client_1.0.14.12*.deb 

 

 

View solution in original post

Marked as solution

@dreadlord,

 

Many big THANKS! for your post! Works great!

 

Gramps

 

View solution in original post

Marked as solution

The Debian Wiki has another solution:

 

https://wiki.debian.org/spotify

View solution in original post

22 Replies

Just tried this as well, works great! Thanks man

Thank you for that interims solution!

 

One of my computer runs with Debian unstable. I had to install the following two packages before spotify could installed and running:

sudo apt-get install libnspr4-0d libnss3-1d

 

Everything works fine in that version except the "discover" page. Here no content is shown.

The discover page issue might be caused by locales:

http://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/Bug-Desktop-Linux-0-9-0-133-gd18ed589-Hav...

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

Good morning Peter,

 

I will try that solution today in the evening. Thank you for that hint.

 

Have a nice day,

Daniel

 

Edit (in the evening):

your link to the solution by setting LC_NUMERIC works fine. The discover page and all others working great.

 

Now, I start spotify with the following (added new starter element to my XFCE4 menu) that calls:

env LC_NUMERIC=en_US.utf8 spotify

 

Have a nice evening!

 

 

 

THANK YOU!!  The playback sound quality is night and day between Native and Wine. 

Is there a package in 32bits architecture?

I added stable and oldstable to my sources.list, it worked. It's a bit of a shame that you need libs from oldstable to install spotify. Can we have a new build?

Just wanted to let you know that of course we have known about this problem for a long while, but like always with the Linux version, we have no resources to work on it. The next version will have this fixed. I have no idea when that will be released though. We usually don't do tiny point releases to only fix one problem, which be an option here, to release the exact same version, but linked to libssl1.0.0. Instead we batch up a ton of new features and try to get those out. That is much harder to do of course which sort of delays the process even more. Sorry, not the answer you were wanting to hear, but that is the state in general for the Linux client and the reason for this not being fixed in particular.

 

Thanks for the reply. I know from experience how it is with ressources for less-popular platforms. Actually, right now I'm quite happy with the current linux build. It still has the old design, which I vastly prefer to the new one (because it's more compact), and gapless audio always works (in the current windows version, it sometimes breaks for me until I toggle crossfade). On top of everything, libssl0.9.8 was immune to heartbleed... That doesn't mean a new version wouldn't be useful, especially since I think the average user has trouble installing the current one without help. Just wanted you to know that right now I'm happy. The important thing is that a linux version exists, I wouldn't have gotten Spotify without one.

Thanks alot for this solution miza, I recall having to fix this myself manually a few times and it's not fun. Just wanted to let you know that this was greatly appreciated.

 

And I also appreciate replying to this thread and I'd also like to add that I very much appreciate a Linux client and I can deal with using workarounds like this and having the software slightly out of date, as long as it's still usable 🙂

 

Thanks again!

Hi guys, I'm happy to learn that this dirty fix helped other users also 🙂

If anybody's interested: I've created a 32-bit version as well, and added them to our SolydXK community repository.

You can download the packages directly from here: <link removed - mod.>

 

They install fine, but there's still a problem that needs to be solved: I couldn't get it to play any file.

I opened a topic for that on our forum: http://forums.solydxk.com/viewtopic.php?f=58&t=3844

 

It probably has something to do with pulseaudio

Works great.

 

Thank you.

 

LMDE Cinnamon.

Hi.  Debian Jessie is stable now and has been released for over a month.  I still cannot install Spotify, whether I add the stable or testing repo.

 

Thanks.

 

Mark

Hello,

 

I'm a long-term Debian user, and used Spotify on Wine. Now that winSpotify won't start anymore (broken on my wheezy) I looked at what's going on with Spotify Linux development, so

 

I installed Spotify on Debian GNU/Linux 8.1 like instructed here: https://www.spotify.com/fi/download/linux/

No errors occurred.

I can see the Spotify icon on Applications menu > Sound & Video. Clicking on it, does nothing.

 

Ran spotify in terminal:

spotify: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory

 

How to fix this one?

I already found myself using the libgcrypt "fix".

 

Downloaded .deb from here: https://packages.debian.org/wheezy/amd64/libgcrypt11/download

and installed using native tools.

 

Spotify runs now, significantly faster than under Wine.

 

Thank you.

Cannot get anything from that address:
Connecting to 83.212.107.72:80... Connecting to 83.212.107.72:80... failed: Connection timed out. Retrying. --2015-09-24 21:56:07-- (try: 2) http://83.212.107.72/spotify-client_0.9.4.183.g644e24e.428-1_amd64.deb Connecting to 83.212.107.72:80...

Anyone have a mirror?
Marked as solution

Hey @equex,


You can get your hands on the .deb package here. This package is working with libssl1.0.0.

You will need to install it manually using 

 

dpkg -i spotify-client_1.0.14.12*.deb 

 

 

Marked as solution

@dreadlord,

 

Many big THANKS! for your post! Works great!

 

Gramps

 

Suggested posts