Announcements

Unable to Add a Directory to Play Local Files (linux)

Solved!

Unable to Add a Directory to Play Local Files (linux)

HI!

 

I'm using the Desktop version of Spotify on linux (Kubuntu), and I'm having some trouble when trying to add a Local diretory to import some local files.

 

I click oh the "Add a Source" button under Settings, but nothing seems to happen.

 

I was wondering if someone could help me out fixing this issue.

 

I've already uninstalled and reinstalled it several times, with no success.

 

Thx.

 

Reply

Accepted Solutions
Marked as solution

Yep. This is a problem. We don't bundle a local version of the ffmpeg libraries. The current version of Spotify can only use old versions of the libraries that were found in Ubuntu 14.04 trusty. It is still possible to install those, but it feels quite hacky.

 

 

echo deb http://se.archive.ubuntu.com/ubuntu trusty main universe | sudo tee /etc/apt/sources.list.d/temp-trusty.list
echo deb http://security.ubuntu.com/ubuntu trusty-security main universe | sudo tee -a /etc/apt/sources.list.d/temp-trusty.list
sudo apt update
sudo apt install libavcodec54 libavformat54
sudo rm /etc/apt/sources.list.d/temp-trusty.list
sudo apt update

 

View solution in original post

Marked as solution

Omg, It finally worked!! hahaha

 

Thank you for the support, I really apreciate it 🙂

View solution in original post

6 Replies

Thanks for reporting. It looks another case of missing dependencies in the deb file. Install zenity:

 

apt-get install zenity

and try again.

 

HI!

 

Thank you for the support, I'm now able to do it!

 

However, it seems that I got into another problem 😕

 

After installing zenity I added the directory that I wanted, but everytime I try to play one of my local files (either the mp3 or the m4a ones) Spotify crashes.

 

I tried to search about it on the internet, and it seems that the problem is related with ffmpeg or something, but I was not able to fix it by myself.

 

Any solutions?

 

Thanks in advance.

Marked as solution

Yep. This is a problem. We don't bundle a local version of the ffmpeg libraries. The current version of Spotify can only use old versions of the libraries that were found in Ubuntu 14.04 trusty. It is still possible to install those, but it feels quite hacky.

 

 

echo deb http://se.archive.ubuntu.com/ubuntu trusty main universe | sudo tee /etc/apt/sources.list.d/temp-trusty.list
echo deb http://security.ubuntu.com/ubuntu trusty-security main universe | sudo tee -a /etc/apt/sources.list.d/temp-trusty.list
sudo apt update
sudo apt install libavcodec54 libavformat54
sudo rm /etc/apt/sources.list.d/temp-trusty.list
sudo apt update

 

Marked as solution

Omg, It finally worked!! hahaha

 

Thank you for the support, I really apreciate it 🙂

I am having the same issue, unable to add a local source on linux client 

However I followed these instructions and now not only can I not add a local source, my client will also not allow me to open settings at all.. settings were opening prior to this


@dschaef2 wrote:

I am having the same issue, unable to add a local source on linux client 

However I followed these instructions and now not only can I not add a local source, my client will also not allow me to open settings at all.. settings were opening prior to this


You probably experience the problem discussed in this thread:

 

https://community.spotify.com/t5/Desktop-Linux/Settings-don-t-open-on-Linux/td-p/1478736

 

We still don't understand why this happens for a few users. It seems to be slightly more common for users not running Ubuntu, but it happens for some Ubuntu users too. It is very likely a Spotify bug though. No other app seems to behave like this for these users.

 

Suggested posts