Spotify Skipping every song, not playing for more than a second

Solved!
Reply

Spotify Skipping every song, not playing for more than a second

mattebad
Casual Listener

I just installed Spotify onto my brand new lenovo laptop and copied my backup from my old laptop over. These problems started immediately after I copied my backup over so I think it has to do with that as I previously had spotify installed on my old laptop. I went and reinstalled spotify completely, running CCleaner after uninstallation, then reinstalling it and it still won't play any songs. Just skips every song and no matter what it is. I went and deleted spotifys storage folder and cache folder manually then restarted spotify, still didn't work. Unchecked all of the checkboxes in preferences including hardware acceleration and it still won't work.

 

Any help would be appreciated otherwise I'll have to cancel my premium subscription before it renews this month

 

Running Windows 10 home edition

4 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Ox1
Roadie

Hello!
Please try changing your default playback device to your computer's speakers (http://www.7tutorials.com/how-change-default-playback-recording-audio-device) restart Spotify and try it again.
Tell me if it worked, please. You can give me a kudo too if you want 😉

View solution in original post

Solution!

Ox1
Roadie

Hello @zrazzle!
Change it to your laptop speakers, restart Spotify, change it back to your headphones and restart Spotify again.
Tell me if it worked, please 😉 Kudos would be appreciated!

View solution in original post

Solution!

Drfail21
Casual Listener

If solution above does not work for you try this solution first close spotify, find the control panel>admin tools>services>Windows Audio Endpoint Builder (near the bottom of the list) Restart the service, check spotify. This solution is primarily for people want play music through the audio jack and and any default speakers on like a laptop. Step by step picture instructions will be uploadedFinding Control PanelFinding Control PanelFinding Admin ToolsFinding Admin ToolsTo ServicesTo ServicesTo Windows Audio Endpoint Builder then resettingTo Windows Audio Endpoint Builder then resetting

View solution in original post

2 Spot Fix.JPG
3 Spot Fix.JPG
Solution!

King-Felix420
Newbie

Thanks "Polvda" 

That really helped i did exactly what you said because everything else was not working.

Then i opened up spotify again and it played music! 

 

 

 

Thanks

 

View solution in original post

42 Replies

EvanFasnacht
Music Fan

Likely an issue with running Windows 10. I've read several post with people having problems with W10, there is most likely still bugs and on going issue with Windows10/Spotify compatibility. I personally have not used W10 yet so my ability to help is limited, sorry!

 

Just wanted to offer a heads up, hope someone with more experince with W10 jumps in to help!

 

- E.

 

 

Solution!

Ox1
Roadie

Hello!
Please try changing your default playback device to your computer's speakers (http://www.7tutorials.com/how-change-default-playback-recording-audio-device) restart Spotify and try it again.
Tell me if it worked, please. You can give me a kudo too if you want 😉

polvda
Regular

On my computer Spotify skips all songs in a playlist when the computer has waken from sleep mode.

Restarting the computer fixes it till after the next sleep mode.
All other sound apps work without problems.

Windows 10 - Spotify 1.0.12.161.g64b0797c

xent
Newbie
I had this similar problem and when I was going to change default playback device I got an error about the enhancement driver for my headset.
Spotify worked after changed default playback device

mattebad
Casual Listener

That was really weird, I never changed my default playback device or used bluetooth since I bought this a few days ago. When I went into my playback settings it said audio enhancements are causing problems for my speakers and microphone. Weird, but it does work for the moment, thanks a lot.

Ox1
Roadie

No problem 😉
I'm glad I could help you.

Mwiseley
Newbie
Had same problem after upgrading my Lenovo laptop to Windows 10. Just going into the dialog where the default playback device is set did the trick. That dialog popped up some notice about another playback device (my headset) and suggested I disable "audio enhancements" for it. Saying OK to that solved the problem.

polvda
Regular

This solution worked for me. I have an USB Asio sound card (Tascam US-366)

 

http://line6.com/support/topic/133-audio-in-windows-8-randomly-stops-working-with-ux2/

 

Greets.

zrazzle
Newbie

Hi there,

 

Spotify is also skipping tracks for me and it is totally unuseable.

 

I use an M Audio MP3 interface because the headphone connection on my laptop is broken so cannot change the default to my laptop speakers.

 

Help please? 

 

It's worked fine for me this way the last five years so don't  see why there should be a problem now!

Very frustrated!!

 

Thanks

 

Martyn

 

 

Solution!

Ox1
Roadie

Hello @zrazzle!
Change it to your laptop speakers, restart Spotify, change it back to your headphones and restart Spotify again.
Tell me if it worked, please 😉 Kudos would be appreciated!

Coomzie
Casual Listener
This worked a treat! Windows had switch to "headphones" as the default playback device which caused me all the issues. Thanks ThePonti!

gregsound922
Newbie

Wow....Thanks. That worked for me. I am not a computer friendly person, but I was able to do what you suggested and BOOM!!!....just like that I have my music again. THANKS ALOT.........Listening to Dinosaur Jr. right now  

DaneKurb
Casual Listener

This did not work for me

 

I'm running Windows 8.1, all latest updates.

I have a Pioneer DDJ-SX sound card that I use to send 1/4" TRS line audio to my studio monitors

I have always used Spotify with this sound card before getting a new computer with Windows 8.1 installed (previously used Win 7)

 

Here's what I've tried...

 

1) installing and reinstalling spotify

2) changing the default sound card to the native sound driver from the pioneer one (this works, if I want to use my laptop speakers, but I don't)

3) updated Pioneer driver to the latest release

4) restarting the computer several times before and after doing anything

5) checking and unchecking hardware acceleration box and restarting before and after each of those attempts

 

Can't get Spotify to send the audio to this USB Pioneer DDJ-SX sound card so I can use it as a playback device for my studio monitors

 

PLEASE HELP!

 

KingShockz
Newbie

haha such an easy simple fix it worked

dudenugget2000
Newbie

THANK U SO MUCH!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Ox1
Roadie
No problem, I'm glad I could help 😉
Have a great day!

asrasers
Casual Listener

I'm having the exact same problem --  I also have a Lenovo, and spotify continually skips songs when my speakers are plugged in, but not when playing through laptop speakers.  I've tried restarting, checking the playback device settings, and none of that works.

Ox1
Roadie

Hello!
Sorry for the inconvenience 😞 Please contact Spotify support using their Twitter or contact form.
If they will reply with a no-reply email, reply to it, even though it is a no-reply.
Have a great day!

mmaga
Newbie
Finally!!! thanks so simple and such a nightmare
SUGGESTED POSTS