Announcements

[Windows]Blank screens

Solved!

[Windows]Blank screens

Spotify update: We've posted a workaround to this issue here. Thanks for hanging in there - we're working on a permanent solution.

 

Hi there,

 

I'm a Premium user since 3 years and a half. The first couple of years I was super happy with the whole experience of sharing songs with friends and stuff, top notch, really. But since the last year and a half I have a REALLY ANNOYING problem in the computer version of Spotify that I've been trying to fix all the time with no success. I tried to find a solution for it, but nothing helped me, that's why I'm writing here finally, because today the problem got even worse with the new update that I just installed.

 

My initial problem/bug is that one day, with a new update, I wasn't able of sending/sharing songs anymore with my friends. I right-clicked on the song that I wanted to send/share, clicked on ''share'', and suddenly, instead of the classic tab where I used to write the message with the ''SEND'' button, I got a blank white tab. I was always using this very same method, but it stopped working for me for some reason with one of the updates. I couldn't write or send anything. I uninstalled the program and re-installed again several times but didn't work. I really enjoyed that part of spotify, but I eventually gave up.

 

Some months later, new spotify update, the problem got worse. Not just couldn't send or share songs anymore, now not even the sections ''Explore'' and ''Discover'' showed up. They were white, blank. Nothing will show up there. This is the first screen you see when Spotify opens, right? For me it's completely blank since long time ago. Sometimes it looks like it's charging, but nothing really.

 

But what happened today is completely wrong. With this new update, this new version of spotify, I'm not even able to look for new songs or new artists. Guess what happens, it's blank. I look for a song, click on the artist/band name and it doesn't load. I can even see the band page with their albums and songs...

 

Basically what I can only do now is just seeing my own playlists, and I'm afraid this will end in the moment you guys make a newer version of Spotify...

 

I'm using Windows 7 64bits. Please, I need some urgent help. I'm sure someone else has the same **bleep**ty problem. This is getting really awful!

 

I'm attaching some images so you guys can see it properly.

 

Thanks!

 

EDITED subject to make it clearer

Sin título-1.jpg
Reply

Accepted Solutions
Marked as solution

I solved my issues : spotify.exe and SpotifyLauncher.exe was in compatibility mode, so I disabled this option and now everything is back to normal ! 

View solution in original post

Marked as solution

Are you administrator of your session ? If not, try to log in with an administrator session. 

View solution in original post

Marked as solution

If you are still having problems, try launching spotify from the Run command with 

 

%APPDATA%\Spotify\spotify.exe --disable-accelerated-layers --disable-accelerated-fixed-root-background

View solution in original post

Marked as solution

Yeah there is. Right click on the spotify shortcut you use to launch spotify (you may want to create a copy on your desktop instead) and go to properties. Go to the shortcut tab and add  --disable-accelerated-layers --disable-accelerated-fixed-root-background after the current contents of the Target box.

View solution in original post

Marked as solution

You can do it.. First enable the option "Don't open automatically" in preferences then follow the steps here to put a copy of the shortcut you made in the startup folder.

View solution in original post

Marked as solution

Using the Run command to run "%APPDATA%\Spotify\spotify.exe --disable-accelerated-layers --disable-accelerated-fixed-root-background" works like a charm. This seriously needs to be brought to the attention of Spotify developers, if they don't already know about it. The fact that even when the screen was blank I could still click and get songs to play told me that the content was there in some fashion but that I just wasn't seeing it. Thanks a bunch for this temporary work-around/solution. They need to look into this accelerated layers and fixed root background thing. It seems like the visual cool factor they are going for might be undermining functionality at this point, at least on some systems for whatever reason (the discover, browse, follow, and messages tabs worked fine on my work computer and Android phone).

View solution in original post

Marked as solution

This worked great for me! Running Windows 8.1 on a latop with dual graphic cards Intel/ATI.

 

"Using the Run command to run "%APPDATA%\Spotify\spotify.exe --disable-accelerated-layers --disable-accelerated-fixed-root-background" works like a charm."

 

Thanks Justinilla!!

View solution in original post

Marked as solution

Hey everyone, thanks for continuing to report this issue. We're still looking into it - don't worry!


For the time being, we're grateful for the workaround that some of you have posted. Just for extra visibility, here it is again:

 

(Windows)

1. Close Spotify

2. Open Run (Start > Run, or just Picture of the Windows logo key+R).

3. Paste "%APPDATA%\Spotify\spotify.exe --disable-accelerated-layers --disable-accelerated-fixed-root-background" (without the quotes into the box).

4. Press Enter.

 

Spotify should now open up with all the screens looking at they should.

 

We hope that helps. And hopefully we'll have a proper fix ready for you soon.

Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

View solution in original post

Marked as solution

But of course!

I think the easiest way is to copy the current Spotify icon on your desktop and then edit the copied icon. I will now try to explain how to do this on a PC in a way so anyone can do it,

 

Click on your current desktop icon for Spotify so it is highlighted/selected (only single click, not double click).

To copy that icon press down the CTRL key with one finger and hold it down, then press the letter C with another finger, and then let both go.

To paste the new icon on the desktop press down the CTRL key with one finger and hold it down, then press the letter V with another finger, and then let both go.

 

You should now have two Spotify icons on your desktop, one with the word "copy" in it.

 

Select the new icon by clicking on it once so it is highlighted/selected and then right click on it once.

On the menu that appears choose "Properties".

 

On the tab called "Shortcut" go to the very end in the field called "Target:" so that the cursor is behind "spotify.exe". Do not remove anything on this line and it is very important that the cursor is at the very end. Easiest way to make sure that you are at the end is to simply click somewhere in that field and click on the END-key on the keyboard.

 

Now press space once on the keyboard and then paste the following (make sure you have copied it first):

 

 --disable-accelerated-layers --disable-accelerated-fixed-root-background

 

When that is done you can click on "OK" and then doubleclick on your new Spotify icon and enjoy all the functions. 🙂

 

And remember to thank for the solution, not me!

 

 

View solution in original post

Marked as solution

Marked as solution

Marked as solution

I think I'll unsubscribe from Premium and go back to Apple Music. I have never used a service with so many bugs. And I don't mean little glitches, I mean things that make it totally unusable. And the ones that are known for years and still not fixed. Spotify developers are a disgrace.

View solution in original post

106 Replies

Second image

Sin título-2.jpg

And third!

Sin título-3.jpg

Experiencing the exact same problem, only my screens are black. 

Same here, black or white screen on explore, discover, radio, artist page.. etc. VERY ANNOYING problem, impossible to use Spotify. 

Marked as solution

I solved my issues : spotify.exe and SpotifyLauncher.exe was in compatibility mode, so I disabled this option and now everything is back to normal ! 

How lucky!

 

I tried the same, but I can't disable. It's not an option for me. 😞

Sin título-1.jpg
Marked as solution

Are you administrator of your session ? If not, try to log in with an administrator session. 

Marked as solution

If you are still having problems, try launching spotify from the Run command with 

 

%APPDATA%\Spotify\spotify.exe --disable-accelerated-layers --disable-accelerated-fixed-root-background

Woah!! 😄

 

Thanks a lot, jwylot! That worked perfectly. Actually what I did was reinstalling Spotify completely, but it was useless because the same problem happened again with no changes... Ugh.

 

Then I tried what you said, and spotify opened with all the features working. **See attached image**

 

AWESOME. 🙂

 

The thing is, I realized that after closing my session and re-opening Spotify again using the normal shortcut icon, the problem is still there. No features, white/black screens again. So I guess it's only gonna be a solution using that command... which is okay, but, is there a way to fix it permanently?

 

Thank you again guys!

 

 

Sin título-1.jpg

Hi, thx for that, I have a windows 8 system and was able to get things to work again by unchecking compatibility mode in properties.  

Not good though that we have to go to all this trouble....  

With sincerest appreciation, c.

 

 

 

Marked as solution

Yeah there is. Right click on the spotify shortcut you use to launch spotify (you may want to create a copy on your desktop instead) and go to properties. Go to the shortcut tab and add  --disable-accelerated-layers --disable-accelerated-fixed-root-background after the current contents of the Target box.

I'm having a related problem with the new Spotify as I've posted elsewhere. I use Spotify on a Toshiba Satellite L670 (Windows 7). Look: hardly any words. And this is what it looks like after uninstalling and re-downloading. (In pic, disregard "No Internet connection." I had just disconnected it from my wired connectin to take it to someone to do screenshot. Problem remains.)

 

IMG405 (1).jpg

@NukeMetaphysics That's a different issue. Let's keep it in the original thread please.

Okay. Will do. New here. My desperation is showing, isn't it?

Haha......relax. We'll get it working 🙂

 

Hey, could you please help me with adding this part to the properties.

When I tried to add it to this box(1st screen), an error occurred, saying that the name of the access path is incorrect (3rd screen).

Am I doing sth wrong? 

 

EDIT: 

Ok, nevermind, it works  😉

I must have copied the path somehow in a wrong way, cause when I copied it from your previous message (containing a run command) it worked. 

 

Thanks 😉

1.png
2.png
3.png

hi, does my suggestion in the attachment work? - c 

Hi, see my attachment, this works for me - c 

jwylot, that worked perfect! I pasted that in the shortcut icon on the desktop. Seems I have Spotify working as good as back in the day.

Thanks a lot, really appreciate your help. 🙂

 

CathalandMary, I couldn't click on the option ''Run as administrator'' for some reason, but anyway, what jwylot suggested worked for me. Thank you too.

 

I have a final doubt, but it's okay if it doesn't fix because it's not so annoying after all, really, but I will talk about it just in case.

I have the option of starting Spotify right from the beginning, when Windows starts, and even if I wrote that command in the shortcut tab, the same old problems happens again. I have to quit Spotify and starting it again from the shortcut icon to have the proper functional Spotify... Any way to solve this issue? Should I paste the magic command somewhere else?

 

Thanks again!

Suggested posts