[Desktop] Playback issues on devices with Xonar sound cards

Status: Fixed






Windows Desktop (custom build)

Operating System

Windows 10


My Question or Issue

I was playing music on my Spotify Desktop app when it suddenly cut out by itself. I tried playing back the same playlist, but it just quickly skips through the songs one by one and stops playing altogether.

I hardly had issues playing songs on the app before in the past (Been using Spotify on this computer for >4 years).


What can I do to get it playing again?


I've tried the following:

- Restarted computer

- Soft reboot of computer

- Uninstalled and reinstalled Spotify desktop (Both downloaded and the one on Microsoft Store)

- Deleted all files I could find associated with Spotify when uninstalling (including the ones under ProgramData and AppData/Roaming)

- Updated all sound drivers

- Tried playing it on the web player (it works on the web)

- Played different playlists, downloaded and non downloaded, random songs.

- Changed streaming quality between Automatic, Normal, High, and Very High.

- Disabled hardware acceleration.

- Changed audio output device.

- Logged out and back in.

- Logged into a different account, it also doesn't work.

Hi everyone,
We really appreciate your reporting this and providing us all the relevant info.
Our tech team made some adjustments backstage and users with an Asus Xonar soundcard should no longer experience this issue. We're therefore marking this as 'Fixed' and we've also updated the title to clarify what issue we were looking into.
If this Ongoing Issue doesn't match your experience, but you're also having issues with playback on your desktop device, we'd recommend you check out this Spotify Answer first and if that doesn't help try the following steps:
  • Check your firewall and antivirus software/apps to make sure Spotify is whitelisted or set as an exception.
  • Uninstall any ad-blocker apps.
  • Remove ALL entries from the Windows hosts file (not just the Spotify ones).
  • Unplug or disconnect any third-party peripherals/audio devices (e.g. DJ mixing controllers, USB headsets, digital-to-analog converters) to see if that makes a difference.
  • If you have any DJ apps/software for mixing or creating tunes, try disabling the option to exclusively use a specific sound card.
  • Run the app as administrator.
  • Try a different device or the web player.
In case you're still having issues, please visit our help boards to see if it's already been reported or start a new topicWe'll be happy to take a closer look and lend a hand there!



Thanks. I have the same setup and I can confirm that disabling "DSP mode / Xear 3D" is a workaround for this problem.




Spotify has been working with this setting enabled for years without any problems.


I have Windows 10 (10.0.18363), Spotify (, and an Asus Xonar DSX soundcard and was having the same problems as described in the thread. Messing around with input/output devices didn't fix the issue and until the Xonar software DSP mode note above the only way Spotify would play music is if I ran it in administrative mode.


The workaround posted above involving turning off DSP modes worked for me. So, uh, yeah. Thanks for the tip and hopefully the Spotify devs can dig deeper and figure out what went wrong.


I’m having trouble playing through the desktop app when I first boot up the PC. It says “the song can not be played right now, if you have local file..etc”. I recently installed a new disk drive to the computer which is when this started. However, if I play the song on the browser first the desktop app will then work fine until I next restart the computer and have to repeat the process.


I recently installed a new SSD to the system which is when the problem started. It worked fine before this running on the old HDD. Spotify was installed fresh onto the SSD.


Any help appreciated.


@VirmiculumIt works. Big thanks!


Hey @ivan,

I have the same problem the problem is from today, yesterday worked fine, Spotify ver OS ver 1909 build 18363.900 pro, did al lthe steps above, and some other solutions from other posts, also tried reinstalling Xonar DX didn't help. Works fine on web client too. Current workaround is running the app as admin. My UAC is strict might be related, but no UAC pop-up when launching the app

Status changed to: Need more info

Hey folks,


Thanks for reporting this to us.


First, we'd recommend trying a clean reinstall of the app on your device by following the steps here.


If after that you’re still having trouble with this, could you provide us with the following info:


  • device + OS version
  • exact Spotify version
  • does this happen with online or offline content? 
  • approximate time and date when you experienced the issue


Once we have that, we will pass it on to the relevant team, who will look further into it.




@Virmiculum, yep, that's the solution, thanks!

Status changed to: Under investigation

Hey there folks,


Thanks for staying with us on this one. We've passed all your info on to our tech teams and they are looking into it.


If you're experiencing this issue, we'd first off recommend a clean reinstall of the app as well as following the steps in this Spotify Answer to see if that makes a difference. 


You might also want to try out the solutions suggested by @nikcster and @iza46d here or if you have an Asus Xonar soundcard, check out the workaround by @Virmiculum here.


Should none of the above steps work for you, let us know by adding your +VOTE and leaving a comment with the following details below:

  • Exact Spotify version
  • Device (make + model) + OS version
  • Approximate time and date when you experienced the issue
  • Are you listening through internal/external speakers?
  • Is this happening while listening offline/online or both? 
  • Does it work when you run the app as administrator?

Thanks - Keep us posted!


I had the same issue and did the same things as you. As a last resort I deleted every playlist in my library and cleared all files... Tracks became playable again. I restored all my playlists and everything was fine... Still working...

Worth trying...


Thank you! After a month of trying all kinds of settings, uninstalling and download, and reboots -- it finally is working. Genius!!