Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Song/Podcast skipping when clicking/sliding the progress bar in the desktop app

Hey folks, 


We've received reports from some users that songs and podcasts skip to the next content in the queue when clicking on the progress bar to set it to a certain portion while playing. This is only happening on the desktop app. 
This is now being investigated by our teams.

Thanks for reporting this issue to us.


We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.


Could you also make sure to provide us with the following info, if you haven’t already:

  • device + OS version
  • exact Spotify version

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

 

In the meantime, you can try out the following workaround:

1. Go to Settings > Audio quality and set the Streaming quality to High.

2. Scroll all the way down to Compatibility and disable hardware acceleration.

 

Cheers!

Comments
ynixt

Spotify Plan - Premium

Country - Brazil

Device - Windows 11

 

Same bug here.  Apparently was fixed after change streaming quality/download to very high, as suggested by someone on the comments.

ynixt_0-1670121300598.png

 

k-bob

Same problem here.

PC player both windows UWP app and native app from spotify.com don't work. This is latest version

Spotify for Windows
1.1.99.878.g1e4ccc6e

on Windows 11 22H2

 

Clearing AppData cache also doesn't work. From what I think its either they messed up the callback function for the scrubber/seeker bar, or have some sort of overlay interfering with the scrubber. Webplayer works though.

 

Also interestingly, assume you are playing a song on PC and open your mobile app while still playing, then you try scrubbing - instead of sending a command to the PC player to play let's say minute 1:32 it will play the next song on PC, so I suspect the "skipToTime(_)" on PC has somehow been linked to "skipToNext()" or something of the sort.

splatypus

Just checked the suggested workaround, and it fixes the issue! I had to put mine to "very high" though, and now it's alright.

LimpBiscuit89

i am experiencing the same issue whatever i do click on the slider its skip to the next song or forward to next song however i also uninstall and re-install the app and still happen the issue additional note i have tried also the windows store version of spotify still the same issue and im running on windows 11 pro x64-bit Os

LimpBiscuit89

actually that solved for me at least i put steam quality to high works perfectly + i switched it back to automatic works fine no issue

MirkoF

Plan

Free/Premium

Country

 

Device

Desktop (Windows)

Operating System

Windows 11 Version 22H2 Build 22621.525

Spotify for Windows
1.1.99.878.g1e4ccc6e

 

My Question or Issue

Hey guys. So lately I've been getting this issue. Whenever I seek a song, Spotify tends to skip the current song and move on with the next. For Example, if I sought from 1:00 to 0:30 or vise versa, it skips. This issue has been going on for a very long time and eventough I've completely removed Spotify from my PC, and re-installed it, the issue persists. I've gotten to the point where I've completely re-installed Windows and re-installed everything but still to no avail, the issue is there.

 

If anyone has a solution please let me know.

sahibdsv

I have the same problem!

MirkoF

I also forgot to mention the fact that, if I were to rewind a song as it was about to finish, Spotify also skips the current song. But if the song just started, let's say 0:02, and I rewind it, it works. But anything past 0:02 will also skip the current song.

julescaff

Same problem here and utterly annoying. Please solve this asap.

mike_lmao

Turn off auto adjust quality in the settings tab then it will work