Help Wizard

Step 1


Spotify on Samsung Galaxy Watch not working and loading continuously

Hey everyone,


Recently we've received reports about the Samsung Galaxy Watch app not working at all, both as a remote and in stand-alone (Offline mode). The app seems to be loading continuously and unable to update.


The right teams at Spotify are aware of this issue and are currently looking into it.

Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone! 


If you're still having trouble, make sure to post a new thread in the relevant help board here.







United States


Samsung Galaxy Watch / Pixel 3 XL

Operating System

Tizen / Android 12


My Question or Issue


I just got a Samsung Galaxy Watch and tried to pair the Spotify from the store with Spotify on my phone. Nothing seemed to work. If I tried to log in with premium features or use the watch app standalone, it would allow me to go through the login/pairing process but then just dump me into an endless loading loop animation. Meanwhile, the remote feature seemingly could not detect my phone at all. 


I tried a few different tricks (wifi only, wifi off, uninstall and reinstall apps, etc.) but made no progress. Does anyone know any solution or workaround to this? Is there a patch in the works? Thanks.


Spotify on the watch is version 1.2.15, Spotify on my phone is version


Hi @FreeAAgent,


Thank you for reaching out to the Community and welcome. 


To start, please go to your Account's apps and check if there's any record of your account being linked to Samsung. If you find it, please remove it.


Then, try doing the pairing process again while connected to mobile data. You can create an internet hotspot and connect your watch to it. 


Let us know how this goes.


Thanks for the reply. I deleted the previous Samsung connection and tried your suggestion, and a few different variations, but the app unfortunately seemed to have the same issue in all cases. One thing to note is that every time I would finish the pairing process and reach the infinite load loop, a "Samsung wearable" connection would reappear on the account apps page. Don't know if this is a good or bad sign.


Anything else I can try? Or do I just have to wait for an update to fix it?


Thanks again, it was a good idea.


The latest app version is 2.5.40, I don't know why the Galaxy Store is installing this old version


You are absolutely right. That's really strange.


So I tried uninstalling and reinstalling, it still installed 1.2.15. I noticed there was an "update" button. It went through a whole process of downloading, installing, and transferring files to my watch... only to stay on version 1.2.15. It let me "update" as many times as I wanted without ever changing. 


Is this a known issue? I'm a bit confused at this point.


Hey folks,


Thanks for the replies.


Could you try running a reset to Factory settings on your smart watch and then re-linking the watch to your phone and Spotify account.


Let us know which is the final version to which the watch app updates.


It would also be helpful to let us know the exact model of the watch and the current OS version.


Keep us in the loop.


Hey Alex,


I reset my watch, re-paired it, and reinstalled Spotify and it seems to be in precisely the same predicament as before, unfortunately.


My watch is the original Samsung Galaxy Watch 46mm with no LTE (Model # SM-R800)

The watch OS is Tizen version (which is apparently up to date)

Spotify on the watch remains at version 1.2.15, and will not update to version 2.5.40

Spotify on my phone is version (also up to date, I believe)


I hope these stats help. At this point, it seems like the main issue is that Spotify on the watch will not finalize and apply any updates. Other apps on my watch are installing and updating without issue, so I'm not sure what the holdup is. Any suggestions?


Thanks once again for all the help thus far.


Exact same thing here with a SM-R805U Galaxy Watch and have the same difference in app version and Galaxy store version. I can pair/register with Spotify but the app is useless after that.


I spent over an hour yesterday on the phone with Samsung support and in the end she said the only recommendation is to buy a new watch... I find this ridiculous since it is obviously a software issue.

It almost seems like the app is not pointed to the right directory to download the files from Spotify's and is stuck in waiting for the server. The widget says unknown for the album and song and keeps cycling through a loading circle as well with a 1 second pause and a 2 second circle load in an endless loop.




That seems highly plausible. It's like the galaxy store is being directed to download version 1.2.15, so even though it can see that there is a newer version it is simply unable to retrieve those newer files. That would also explain why the updates seem to run smoothly but never make progress. It successfully updates from 1.2.15 to... 1.2.15. Thus the cycle continues.


I opened an almost identical thread on the Samsung community forums, maybe that will gain some traction. At any rate, I'm glad to know I'm not the only one. The more it becomes a known issue, the more likely it is to be fixed. 


In the meantime, any leads or potential solutions are appreciated from anyone.

It's a known issue, there are other threads about it here on the spotify community, they don't seem to care.

The "official" solution is to follow some guy's tutorial on reddit to manual install spotify using the installer file you can download from his google drive.