BMW ConnectedDrive not working

Solved!

BMW ConnectedDrive not working

heimalis_

Plan

Premium

Country

Belgium

Device

Nexus 6P

Operating System

(iOS 10, Android Oreo, Windows 10,etc.)

 

My Question or Issue

 

So I have a BWM 1 series for about a week now and was able to connect spotify without any problems until it stopped working once i got back in my car two days ago. It still shows up in my apps, and sometimes I can click it and continue to the next screen but it doesn't load any further than that. I also get a notification on my phone that it's connected.

 

The problem started when I used the spotify app on my computer and connected to Sonos. But I already changed it in the computer app so the music plays from my computer itself.

 

The funny thing is that it does play spotify from my phone connected via bluetooth, just not from the app that's in the list.

 

Any idea how I can fix this? Already tried to reinstall the app, open the spotify app through the connected drive app, and disconnect/reconnect my phone.

 

 

Reply
457 Replies

AshAlex34

No problem! 🙂 

marccarney

I'd have to disagree.  It's a proposed workaround rather than a solution.  I won't install untrusted apps from unknown sources, such as that link, for security reasons, so the workaround is not suitable for me, I need a proper fix in a new version of the Spotify app.

AshAlex34

Just install the earlier version of Spotify -8.4.77.779  and it will work again, I spent two days troubleshooting including flashing an older version of Oreo onto my phone and found Spotify was the culprit

I am posting the link to the earlier version below 

Link : {snip - edit by Community Moderator}

 

Amraam

So it seems I have been bashing BMW for no reason.  I too worked out that it was Spotify at fault on the way home after testing that other BMWConnected apps work fine.  With Spotify, I can see the logo as an in Connected Drive, but when I select it as a source, all I get is a blank screen with no audio; completely and utterly useless.  MY67 530e

 

In the end, I paid the £1 to test the Online services, and the 2 mins I've played around with it it is impressive. It works so much better than Spotify that I'm tempted to cough up £120 to have the online services for the last 12 month of my lease.

 

SPOTIFY! SORT THIS OUT.  PLEASE!!

Amraam

No likes for this solution is an insult to you, so have some likes.  I'd kiss you but my girlfriend wouldn't be happy ha

heimalis_

I could kiss you. You're a lifesaver.

 

Just tried this. Works like a charm again. Turned off auto updates.

dan1431

Same issue.

heimalis_

Try downloading an older version of Spotify.

 

Link : {snip - link removed for security reasons by Community Moderator}

marccarney

What about the proper fix?  Putting an old version on there is a workaround not a solution.

 

Will you be forever stuck on an old version of Spotify for eternity?

 

Any news from Spotify Developers when we can expect an update that will work?

 

marc

AshAlex34

My idea is just to get Spotify to work with the connected drive which for me was extremely frustrating,it allows me to use all the functions I need. I agree this should work with the latest build but this obviously needs to be addressed by the Spotify Developers and not us users. Being a paid subscriber to Spotify I would love to see this work on the new build too however I am happy not to update the app to continue using this feature. Hope Spotify sort this out on their next version.

marccarney

I have created a support case with Spotify for this issue and have linked it to this thread and the other similar thread.

 

Hopefully Spotify will update the threads in due course.

 

marc

dan1431

The downloading and use of an older version is fine in the interim, but at the end of the day Spotify should correct whatever caused the issue to begin with.

 

My biggest complaint, is not that the issue occured, but that nobody seemed willing to take responsiblity. I first contacted BMW and they blamed Spotify and then I contacted Spotify and they blamed BMW.

 

That is passing the buck and it does not solve the issue, it simply leaves me feeling frustrated and gets me out of the front line support person's hair.

AshAlex34

I agree , definitely Spotify at fault on this one though, they need to atleast address the issue and say we are working on a solution and it will be fixed on the next build.

dan1431

I cannot speak for Spotify directly, but that seems to be a problem with many tech companies, communication is lacking.

Regardless, I do agree that Spotify should take responsibility and let us the customer know that they are working on it.

dan1431

I got an update for Spotify today, I do not know if it has fixed the issue pertaining to this thread or not as I had already driven my car for the day.

 

If anyone else is able to test, please post to update the thread.

chrislhurley

Not good news I'm afraid. Still reliant on the old version. 

AshAlex34

Thanks for trying , clearly our rants our falling on deaf ears. Spotify clearly arent bothered.

dan1431

I am not sure it is deaf ears as much as probably none of the Android engineers drive BMWs and thus are not experiencing the issue themselves.

 

Added to that, it probably doesn't help that this thread is marked as solved, a work around is not solved.

 

Regardless if I have some free time I am going to try and Google around for Spotify Android Engineers and then try and email a few and see if that helps and I would encourage others to do that as well.

marccarney

I installed the later version and it's exactly the same behaviour in the car, so it hasn't worked for me.

 
The BMW Connected says on the Hub screen "The following apps have been certified by BMW and can be used in your vehicle" , Spotify being one of them.
 
 
Does this mean it's no longer certified?
 

dan1431

I honestly do not know one way or the other, but my gut says that there would have to be a major change for Spotify to be suddenly decertified by BMW.

 

Plus, Spotify still works with iOS, so my gut says it is a bug and not a policy change.

Suggested posts