Announcements

Help Wizard

Step 1

NEXT STEP

Denon AVR-X2100W - No Spotify Connect

Solved!

Denon AVR-X2100W - No Spotify Connect

Just purchased a new Denon receiver and everything is working OK except Spotify connect, it doesn't show as a device on the connect page. I can stream everything via AirPlay OK, but connect doesn't show. They are both running on the same network, but I wonder if there are any settings I need to consider for spotify specifically. I have tried searching the forums but haven't come up with anything so far. If anyone could point me in the direction of some help it would be much appreciated!

Reply
505 Replies

I Tried, message is:

Initializing...

Then: no network, check config...

But if I do a diagnostic of the network on the avr menu, everything is ok...

Not sure. The 1st two times I ran it I didn't see it do anything. My network config checked out ok the whole time also. 

I did make sure it was set to Online Music the final time I ran it and it's been working fine since. 

For anyone else having problems mine was fixed by changing to static ip address either on router or through denon reciever. My problem was that if I assigned any ip between 2-99 denon reads it as 002-099 my router reads it as 2-99 soon as i changed the address to between 100-200 it worked and read as same on both sides. Did not have to turn off the DCHP on the Denon. Hope this helps for some.

###SOLUTION IN POST - see below###

 

So like many before me I have had problems out of the blue with Spotify Connect on the Denon x1200w. For me the avr was detected without trouble through Spotify app on android, and would also connect to it and play music. However if I turned my phone's screen off for longer than a minute (whilst the receiver continued to play Spotify music) and then turned the phone's screen on again, the receiver would immediately crash and sometimes even have audible static noise for a short time. The avr then did some sort of a reset ("Connecting... Please wait... Assigning... Please wait) and after a few minutes would show up again in Spotify connect. If I tried again, the cycle repeated itself. The problem only arose when my phone had the Spotify app active in the background.

 

I tried everything from static IP assigned in router, static ip set on avr and DHCP off, turning uPnP off in router, unplugging receiver, etc. etc. Nothing seemed to work.

 

###THE SOLUTION###

The problem appeared to be connected to Android's battery optimisation when Spotify runs in the background. Turning off battery optimisation for the Spotify app (Setting -> battery -> etc.) seems to have solved the issue for me. Found the solution in a similar topic for Marantz receivers, which apparently suffer from similar problems.

 

I find it ridiculous that the Spotify app can actually crash my receiver remotely, but oh well, this solution beats having to send my receiver back for repairs and undoubtedly getting it back with the message "nothing seems wrong after testing for 10 seconds".

Dear Sirs,

 

I have the same problem during listening to Spotify. AVR: Denon AVR-X1200W. I activated premium Spotify through PS4. PS4 Spotify application everything works fine. I can listen to music from PC Spotify program. When I would like to manage music form smartphone (Samsung A5) Denon AVR is kicked out from router. Message: please wait, initializing, etc. I tried to off the battery usage, but it seems the problem is still exists.

Denon AVR connected to router through Access point with cable connection in fixed ip.

 

Please share me your opinion how I could solve this annoying problem!

 

Many thanks for your cooperation!

 

T.

The same thing happens to me recently, always perfect spotify connect between mobile and denon x1200w but since denon update or app does not work. Denon loses network constantly and spotify does not work

Yup, super frustrating. 

 

I thought the fix to change the battery optimization for the Spotify app worked. I had no issues for a few hours after doing it but then it started happening intermitatnly again. At least its not everytime I wake my phone up now. Maybe 25% of the time it crashes the Denon's network connection. 

Hopefully there's a permanent fix coming...

Hello together,

 

I have the exact same issue as described in the postings before. I also have a Denon AVR-X2100W Receiver.

When I leave my smartphone (Samsung Galaxy S7 btw.) unattended for some minutes and then wake it up, my receiver makes some scratchy noise and then the network connection seems to crash and I don't see the receiver in the list of available devices in my spotify app anymore. It then takes some time (while the network restarts within the receiver I guess) and then I see the receiver in my app again and can stream music. I can stream it for hours as long as I do not touch my phone (which is ridiculous of course). As soon as I wake my phone again, the same procedure as last time...

I am using static IP address for the network connection by the way.

As I have not received any firmware update for the receiver lately and the issue started happening I guess a month ago or so, it seems to be some bug which came with a new Spotify app version.

But at least Denon should also check on their firmware because in my opinion it is a really critical issue when a spotify app on some smartphone can cause a crash in the network stack of the Denon receiver. This should not happen anyway...

 

Another question:

As this thread has been marked as resolved, does it make sense to start a new thread with this certain topic, as this has not been resolved yet? Or does another thread already exist maybe?

Does it also make sense to report a bug to Spotify or did someone already do that?

I think they should check on that because its 100% reproducable (at least for about 25-50%).

 

What do you guys think?

I believe this is the only avenue for reporting bugs to Spotify as far as I'm aware. 

It would be nice if they marked this as Not Solved though. 

Can someone from Spotify support do that? Perhaps an update on the status of the issue. Should this be reported to Denon? 

Hi Velotime, 

 

Someone has already opened a separate thread for this topic, where I also replied:

 

https://community.spotify.com/t5/Other-Partners-Web-Player-etc/Denon-AVR-X2200W-Spotify-connect-cras...

 

It would be great, if everyone having this issue could push the appropriate button within that thread. Maybe we will get the attention of the Spotify support then!

 

Thanks in advance! 

Guys, 2 months ago i persistently reported DENON the overall instability of their Spotify Connect. They did not seem aware of this issues in details and span but i did my best giving them the link to this tread. Looks like i inspired DENON team to look into the issue and soon there was a new firmware for X4100W. As I also reported earlier, the issue with Spotify Connect seem to cover various DENON AVR models and roots in misallignment between chages made to Spotify App and DENON implementation. Some fixes work for somebody but not for others. Some work for a day, other last longer. Worth mentioning that since last firware for X4100W I do not have issues.

I hope DENON continue reading and put more programming resources in coordination with Spotify for older AVRs models. It's of mutual interest at the end of the day.

Would be good if anyone owning newest DENON AVR to report if there is issue. Best regards/ Alex

Hi AlexAtanassov, 

 

How did you contact Denon so that they would really listen to you? 

Just E-Mail or some contact form on their Website?

 

Thanks in advance! 

If its possible could you let me know what FW version your X4100W is on?

Dear Sirs,

 

I have deleted Spotify app from cell phone. The problem has not been solved. Phone is ringing, I pick it up, Denon is kicked off from network. I do not have any idea how it can happen.

 

Hopefully we will receive firmware update soon. This issue is very annoying...

 

BR, Tomi5

Hey,

I have a AVR-X2200W with the same issue since last firmware update. The Denon even brakes the stream to my chrome casts when they are playing. I think it has to do with the Zeroconf network, when the phone is out of standby it checks the devices in the zeroconf (chrome cast etc.) then Denon crashes and brings the network down.

I have now disconnected the Denon from my LAN and run the music thru my chrome cast with out problems. As soon as i reconnect the LAN cable to the Denon and interact with a phone it all crashes.

Denon have to release a new firmware with a fix!

Email support Denon UK

Regards

Already done some week ago, but no response.

@ Velotime

X4100W firmware I have is 6005-3195-6094-07

I have a DENON AVR-S900W

Recently I was having some issues with Spotify not working. I did a factory reset on the device. (You can find this in your manual) or click this link.

 

http://manuals.denon.com/AVRS900W/NA/EN/GFNFSYvyalrwrt.php

After the factory reset I went into the Denon's network settings and I turned OFF DHCP. I gave the DENON a STATIC IP address. Then I went into my router and reserved that IP. It can no longer have an IP conflict.

Things are now working fine. Hope this helps someone.

 

Denon AVR-X3100W

 

Denon firmware:
-  25/10/2017
-  FW VER 1600-3161-6072

 

I do have exactly the same issues. Since the last Denon fw update the problem was getting worse and worse. At the moment a Android 6 of 7 phone is entering / connecting my network the Denon IP Stack is reinitializing. The Denon is already using a static IP address. 

Next step is trying to keep out the Androids for A couple of days.

Suggested posts