Announcements

Spotify in Firefox Doesn't work

Solved!

Spotify in Firefox Doesn't work

arodd2000

Everytime I open spotify web player in firefox I get a pink bar along the top that says, "Oooops, something went wrong with the playback." I have tried reloading, disableing addons, updating adobe flash,  installing an opensource of flash, I have also tried opening it in private mode, but nothing works. It works just fine in chrome. Anytime anyone else has asked the question it is never solved. How do I make this work?

 

I am running 64bit Opensuse 42.2, firefox version 52.1.0-57.6.1

Screenshot from 2017-05-06 06-50-58.png
Reply

Accepted Solutions
Marked as solution

Sebasty

Hey @jdwohlever!

 

The web player does NOT use Flash. You can throw Flash out of your window (my FF has it disabled by default because it's slow), and the web player should still work. 🙂

 

However, I do recommend checking this:

1. go to about:addons

2. Go to Plugins section.

You're supposed to see something called 'Widewine Content Decryption Module provided by Google Inc.' If you see it, make sure it's allowed to 'Always activate'!
Then go to about:preferences, find the checkbox for playing DRM content (for me it's under General) and allow Firefox to play DRM-controlled content.

 

Extra information about DRM content on Firefox - read this article. 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

Marked as solution

arodd2000

I got it working! It is not a Firefox problem. I installed a bunch of codecs and one of them made it work. Not sure which one though. The way I installed a bunch was installing a video player (VLC) and selected every optional descrepency.

View solution in original post

Marked as solution

BlackbeardII

One thing I have that MIGHT be causing problem, but shouldn't
about:config
media.autoplay.enabled is set to FALSE

The reason this is set to this is to stop hundreds of websites that autoplay videos when you open their page (CNN is a big one that does it, but many others)
All this flag does it make it so you have to click on play button first before media content will play.
So all that should happen is when I click on a song, it should still play if I hit the play button.
But Spotify is not regonizing the play button as activation.

 

View solution in original post

Marked as solution

BlackbeardII

In Firefox, if the about:config flag "media.autoplay.enabled" is set to false
then the spotify webplayer will NEVER work.
This flag is important to stop nasty web sites that bombard users with videos or ad-videos the user has no control over.
Please allow the web player to work correctly with this flag set to false.
I would have no problem with the music playing once I click play, but this flag stops a-hole sites that load a video without waiting for user to click play.

View solution in original post

19 Replies

CryticalAce
Hello arodd2000,

I see you may have an adblocker enabled in Firefox, I would recommend disabling that and see if it works then.

Best,
Jordan

Sebasty

...Mm, this player doesn't use Flash anymore, unlike the previous version (play.spotify) that does use Flash. This one's HTML5-based.

Would you type about:preferences to your Firefox address tab, navigate to Content and see if "enable DRM blayback" is checked? 🙂

 

(sidenote - slightly old version of Firefox.)

 

Something in here (Mozilla's support file for audio playback issues) might be useful.
If you go to the Hosts file, then comment out or delete those entries that contain Spotify or Fastly in their addresses.

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

arodd2000

I tried with adblock disabled and it didn't work. I do have play drm content checked.

Sebasty

In this case head over here, it's an Issue on the dysfunctional web player. Initially posted by a Chrome user, but this issue hits users using a variety of browsers. There might be some solutions, tricks and tips that could be worth a shot in there as well. 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

gatchan

I have the same problem.

 

open.spotify work well on Chrome. But on FF last version (54.0 64bits version), I click on the play button and nothing happend. After fews seconds, the song change, but nothing change.

 

I dont't have any adblocker on this and the DRM is authorized.

 

If I take netflix for example, I don't have any problem to use it.

Exact same issue on latest firefox 54.0.1   64bit.  DRM enabled, Netflix is fine, everything else works great.

Spotify press play.   playing is stuck at 00.00  no sound.

jdwohlever

Version 57+ of Firefox.
Disabled ALL plugins.
Forced allow Flash for Spotify.
Hit play. Nothing happens.
Works fine in Chrome.
Serious issue as I refuse to use Google's **bleep**.

 

Marked as solution

Sebasty

Hey @jdwohlever!

 

The web player does NOT use Flash. You can throw Flash out of your window (my FF has it disabled by default because it's slow), and the web player should still work. 🙂

 

However, I do recommend checking this:

1. go to about:addons

2. Go to Plugins section.

You're supposed to see something called 'Widewine Content Decryption Module provided by Google Inc.' If you see it, make sure it's allowed to 'Always activate'!
Then go to about:preferences, find the checkbox for playing DRM content (for me it's under General) and allow Firefox to play DRM-controlled content.

 

Extra information about DRM content on Firefox - read this article. 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Marked as solution

arodd2000

I got it working! It is not a Firefox problem. I installed a bunch of codecs and one of them made it work. Not sure which one though. The way I installed a bunch was installing a video player (VLC) and selected every optional descrepency.

BlackbeardII

Sadly, It's already set to always activate.
I have tried about 20 different things over the last 24 hours.
I honestly think something in latest Firefox broke the webplayer.

BlackbeardII

If you could find out what codex it was, that would be beneficial.

 

BlackbeardII

Play DRM Content is checked.

 

Marked as solution

BlackbeardII

One thing I have that MIGHT be causing problem, but shouldn't
about:config
media.autoplay.enabled is set to FALSE

The reason this is set to this is to stop hundreds of websites that autoplay videos when you open their page (CNN is a big one that does it, but many others)
All this flag does it make it so you have to click on play button first before media content will play.
So all that should happen is when I click on a song, it should still play if I hit the play button.
But Spotify is not regonizing the play button as activation.

 

arodd2000

I found what I did to make it work. I used the yast 1 click install from this guide.

Marked as solution

BlackbeardII

In Firefox, if the about:config flag "media.autoplay.enabled" is set to false
then the spotify webplayer will NEVER work.
This flag is important to stop nasty web sites that bombard users with videos or ad-videos the user has no control over.
Please allow the web player to work correctly with this flag set to false.
I would have no problem with the music playing once I click play, but this flag stops a-hole sites that load a video without waiting for user to click play.

npr77

I am on Fedora 27 running Firefox 57

I just had to install the ffmpeg-libs package and Spotify Web Player was working just fine.

$ sudo dnf install ffmpeg-libs

BlackbeardII

Type in URL bar: about:config
What is your "media.autoplay.enabled" flag?
I'm betting it's set to true.
However, due to so many **bleep** websites adding auto play videos and autoplay ads that blast the user without their consent, most people change that flag to False.
The way it's SUPPOSED to work, is the user has to hit the PLAY button videos etc. for the media to play.
For some reason, the spotify webplayer is not accepting the play button as activation.
WIth this flag at true, the player works.
But, myself and many others refuse to have this flag on true because of stated above reasons.
Chrome has a similiar flag, (they call it "user gesture) but because of their ad network and revenue, it doesn't work on most sites anyway because crappy sites found a loophole around Chromes implemention.
I refuse to go back to using a web that Chrome decides for me.

durnau

It worked!!! Thanks.

Bewildered
I'm running Ubuntu 16.04, Firefox 57.0.1 64 bit. Encountered the same issue. Steps I took to fix this issue: 1. enable widevine. 2. install VLC media player. 3. run sudo apt-get update. VLC seems to install some necessary dependencies for open.spotify to run properly.

Suggested posts

Env: prod