Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Web Player not working in Chrome - buttons misbehaving

Solved!

Web Player not working in Chrome - buttons misbehaving

Morning,

 

I've used Web Player for years at work, as downloads are locked on our office network.


Since last week the Web Player is working correctly in every way except it won't play anything!
I can search, browse albums/playlists, add tracks to playlists, but as soon as I try to hit a Play button nothing happens.


It's as if the button just doesn't work.


All the buttons in the play bar at the bottom of the screen are equally useless. Shuffle is currently on but a click does nothing, it just remains green.

 

Any ideas?


I've already followed all the troubleshooting guides I can find.

I'm running Chrome browser on Windows 8.1.

 

Thanks

Reply

Accepted Solutions
Marked as solution

Fixed it!

I'm not exactly sure what the steps were and not convinced I could easily replicate it but it seems to be something to do with Spotify Connect and using multiple devices.

I got home last night and tried the Web Player and was having the same issue on my home laptop.

Not something I normally do at home as I cast from my phone. 

 

I switch between a few different ways of listening (phone, Chromecast, Web Player, Roberts radio) and it looks like that might have confused it the Web Player. 

 

From my phone, I tried switching between a few devices and that seemed to sort it out. Web Player now working perfectly.

 

Thanks for all your help.

 

View solution in original post

30 Replies

Hey @thepest! ^^

 

That doesn't sound nice.

Have you tried this?:

  1. In Chrome go to yout toolbar, tap More.
  2. Tap History, and then tap Clear browsing data.
  3. Under "Clear browsing data," select the checkboxes for Cookies and site data and Cached images and files.
  4. Use the menu at the top to select the amount of data that you want to delete. 
  5. Tap Clear browsing data.

Let me know if that helps, thanks! ^^

Peace

No luck, Nico. Still not working.

 

Thanks for the suggestion though.

 

 

@thepest

 

I've escalated your issue to the support.

I will reply on this thread with help soon. ^^

 

Peace

@thepest

 

Can you try to use the web player with an incognito window?

 

Thanks! ^^

Peace

No, that's not worked either.

I've checked a couple of other people in the office that I know use Web Player and it's working fine for them.

 

 

Hey @thepest!

 

Sorry, for the long delay.

Do you have the ability to try an alternate web browser on the work computer?

Can you talk to your IT department in the workplace, to see if they've changed any settings recently. This might have triggered something that started this occurence from their end.

 

Let me know how it goes! ^^

Peace

 

I have the exact same issue on Firefox at my office.

Marked as solution

Fixed it!

I'm not exactly sure what the steps were and not convinced I could easily replicate it but it seems to be something to do with Spotify Connect and using multiple devices.

I got home last night and tried the Web Player and was having the same issue on my home laptop.

Not something I normally do at home as I cast from my phone. 

 

I switch between a few different ways of listening (phone, Chromecast, Web Player, Roberts radio) and it looks like that might have confused it the Web Player. 

 

From my phone, I tried switching between a few devices and that seemed to sort it out. Web Player now working perfectly.

 

Thanks for all your help.

 

Have you tried the Web Player at home?

See my other response for how I fixed it.

@thepest

You're welcome!

I'm glad we sorted that out. ^^

 

Peace

Thank you, I will try this tonight at home.

Ok it worked! There were indeed some conflict between the spotify player and the web one.

The suggestion of switching back and forth between devices isn't working for me. Am I doing something wrong? I'm on a Mac, lastest update before High Sierra.

Still seem to be having an issue, none of the buttons are responsive and I can't even choose the "Web Player" inside of my phone's spotify

You tried what? Not sure what you mean. Has the problem recurred?

Thank you so much! I was trying so many things. Then I followed your suggestion and just clicked on the devices dropdown to select my computer (also listening while at work) and tada! I have music again. The desktop app is full of bugs and basically unuseable to me so having the web player down was a nightmare. You rock!

Hi, my web player is not working (song will stop halfway and won't be able to play anymore) despite i have tried different ways. My spotify app in my phone works well totally. 

 

Can someone advise in this? 

I just clicked on Go to Full Website.  Played something.  And it worked.  Switched back to the Web Player and all is good.  

I've had this same issue twice now. The first time it accidentally resolved just by fiddling with the android spotify. The second time I didn't have it installed in my phone anymore so I contacted a friend who recently had the same issue. The solution was to go to facebook web page -> [apps and websites] and remove spotify from accessing facebook... or something like that. Then I restarted chromium and suddenly everything works.

Suggested posts