Announcements

Finding local files

Solved!

Finding local files

yinzhi24

There is a new update in Spotify that changed the looks of everything, and I used to listen to local files on the sidebar. This new update is great, but I cannot find the local files page. I looked everywhere but still can't find it. Any pictures that show where local files are will be greatly appreciated

Reply

Accepted Solutions
Marked as solution

rclim95

The Local Files feature has been moved to a tiny (IMO) playlist card right next to your Liked Songs playlist under Your Library > Playlists tab.

rclim95_0-1621186175562.png

(Although, I'm hoping Spotify would reconsider this placement and put it somewhere more prominent, like its own tab inside the Your Library view).

 

View solution in original post

Marked as solution

MattsyKun

You'll have to go to your settings and check the "Show Local Files" button. Mine was unchecked whenever the update happened, so I checked it and then my local files showed up!

View solution in original post

20 Replies

BowlOfSoup

I can't find my local file even though I enabled it

Plan

Free

Country

US

Operating System

Windows 10

 

My Question or Issue

None

watt.PNG

KyleRR
if you cant see your downloaded songs on Spotify you can go to the settings and scroll down until you see local files, turn that on then a little under that you will see a button that says add a source, click that button and use the window to select the folder that your downloaded music is in.
I hope this fixes the problem for you 🙂
KyleRRRising Star 1
This week we're celebrating Star Values! #Respect #Inclusion #Support #Teamwork #Fun #Responsibility
If you like my posts, please give them a like or show some support.
We're celebrating Star Values!
If you like my posts, please give them a like or show some support.
Note: I'm not a Spotify employee.

exwum

reapplying sources does not fix this problem.

despite having more then 1000 valid files in my sources the new desktop spotify client does not have a menu for accessing these files. it worked perfectly fine yesterday on the old client, why doesn't it work now?

Jeremy

Hey there @exwum,

 

Thank you for your reply in this thread.

 

You should be able to find your local files in a separate section next to the liked songs,

 

If you still can't see it, would you mind sending us a screenshot of what you can see so that we can have a closer look directly from your end.

 

We'll keep an eye out for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

exwum

similar to op's screenshot, this is what i see on my end

exwum_0-1616751055073.png

the local files playlist or menu is not shown near the liked songs, which is where i would expect it to be. nor is it shown in the playlist section below - for my own privacy i dont want to show all of my playlist names but none of them have "Local Files"

 

exwum

actually ignore my post from above, it's located here in your library

exwum_0-1616751187479.png

personally as a suggestion i think it would be better if this icon and playlist showed up in the same section on the left side for ease of access. thank you for the reply nonetheless.

 

Jeremy

Hey again @exwum,


Thank you for your reply and feedback.

 

We're always testing things by adding or removing features to make Spotify better overall and we’re constantly aiming to improve our features.

 

We have a thread about the new desktop experience where people can leave their feedback. You can find it here

 

Once again - thanks for the feedback, we appreciate it. Let us know if we can help with anything else. 

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂
Marked as solution

rclim95

The Local Files feature has been moved to a tiny (IMO) playlist card right next to your Liked Songs playlist under Your Library > Playlists tab.

rclim95_0-1621186175562.png

(Although, I'm hoping Spotify would reconsider this placement and put it somewhere more prominent, like its own tab inside the Your Library view).

 

yinzhi24
That's where I looked at! I can't seem to find it as I have no playlists, p.s. i have local files turned ON in my settings, I can accept it as a solution until I see it, thanks for the reply

taran360

Thanks helped me as well

 

Ivan

Hey @taran360

 

Thanks for posting here. 

 

We're glad to hear that things are now working properly for you. 
 

Give us a shout if you experience this again - we're always here to help.

 

Еnjoy your music! 

Marked as solution

MattsyKun

You'll have to go to your settings and check the "Show Local Files" button. Mine was unchecked whenever the update happened, so I checked it and then my local files showed up!

siberianwm

same problem for me, settings option is "on", folder added, but there is still no any local files in app, please resolve this. i use russian language but there is no difference.

there is the proofs below

IMG_20210602_225329.jpg

IMG_20210602_225415.jpg

IMG_20210602_225501.jpg

IMG_20210602_225134.jpg

siberianwm

not solved, my app seems different than yours.

Kiruthikakumaran

I can't see my local files even though I enabled it .

Eni

Hey there @Kiruthikakumaran

 

Thanks for getting in touch about this.

 

Would you mind letting us know on which device are you experiencing this? 

 

On another note, we suggest that you make sure to follow these steps to sync your local files. 

 

Lastly, could you let us know which troubleshooting steps you've already tried? That way we can avoid any repeating steps.

 

We'll be on the lookout.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Macy_y

I've been having the same issue, i've enabled local files, changed the file locaton, reapplied sources, restarted both the app and my macbook air, redownloaded the app, tried on a different macbook , and every time i click local files it just says go to settings, ive added local files before on the other macbook that i mentioned but now it dosnt work. im starting to get really frustrated to any help would be appreciated. Thank you.

 

 

AndresM

Hey @Macy_y,

 

Thanks for reaching out to the Community and welcome. 

 

Just to confirm, have you tried following these steps?

 

On another note, check if the files aren't DMR (Digital Rights Management) protected. In case you're importing your songs from iTunes, you can check if your tunes are DRM protected tracks here.

 

We'll be on the lookout for your reply.

AndresMModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

Dian

Hey guys,

 

Thanks for the replies and the posts.

 

Just wanted to drop in and mention, that recently we've made some changes to how the Local Files are being handled by the app. You can find out more information on the new discovery mode on this page.

 

Keep in mind, that there is no syncing of local files between devices over the Spotify app anymore.

 

On the note of the thread - if you can't see the Local Files folder icon, you have to first enable the Local Files setting in the app settings.

 

Hope this helps,

 

Cheers!

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Suggested posts

Env: prod