Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Volume buttons on device don't work when casting

Volume buttons on device don't work when casting

As of Spotify 8.9.xx and newer I can't control the volume on my iPhone when casting to a Chromecast device. I need to go into the slider inside the Spotify app to change the volume.

 

This is not an iOS or apple issue:

My non working version of Spotify is 8.9.16.556 and just today updated to 8.9.18.xx which has the same bug.

On another iPhone a WORKING version of Spotify is 8.9.14.526

The latter works perfectly fine. It is not a iOS problem but a Spotify bug!

Both iPhones run iOS 17.3.1

 

If this is not being actively solved by Spotify I'm sorry to say I will cancel my subscription and change to Tidal. This is a CORE functionality.

Reply
371 Replies

This is dismal - this started over 6 months ago.!  
I love it when a Helpdesk closes a problem as “solved” when the answer is we can’t do anything.  Impressive customer service Spotify - a great way to satisfy and retain your customers.. 

I just marked it as "not the solution". Reason being: it's not!

Problem is back. Volume buttons are rarely working now. Have to disconnect from Google nest speaker and reconnect because the volume buttons fail to work again…

Hi folks

I can see quite a few people are saying this has stopped working for them.

Mine is still okay, but it's glitchy - it's basically how it was before it fully broke. 

 

Try this (appreciate not ideal!):  When you notice it's stopped working, restart the Spotify app and open it. Watch the screen to see what happens. On mine, I briefly see the volume and device pop up in the middle of the screen. This means to me that Spotify has acquired control of the device. It seems that when Spotify opens it scans the local network to acquire control of the device that is currently playing a Spotify stream. I believe it is this acquisition of control that it is loosing and hence why volume control stops working.

 

I don't know if this is what's happening but this has pretty much been like this for years with my set up with Bose systems connected to my local wifi network.

 

However, just to note, what I have previously commented on above, it did stop working completely - as we discussed above - for a while no matter what I did, and then the app got updated and it worked again. I just have this loss of control problem that I had prior to complete break.

 

cheers

I’m still finding that maybe 1 out of every 10 times that I connect to my speakers I can actually control the volume with my phone’s volume controls. The rest of the time I can’t though. 

I have this bug too. 
Can’t we downgrade a Spotify Version without this bug???

Stopped working again! Spotify will you fix this asap? I will cancel subscription if you don’t 

Partially working. Hit or miss. Not acceptable

I also have this issue and it is truly disappointing that spotify offers no solution or promise to fix this. It is a core functionality of the app and is making me reconsider my spotify subscription that I've had for over 10 years now, what a way to lose loyal costumers.

This seems to have finally been fixed. At least it’s working in Spotify 8.9.50.491. 

I noticed in the past when everything worked, I would see a little airplay pop up when I opened the app that would show our Sonos. When it was broken that had stopped appearing. 

Suddenly that little pop up is back again and I’m able to properly control the volume with my phone buttons or watch crown. Yay. 

Still not fixed. Driving me nuts. 

Plan

Premium

Country

USA

Device

Windows 11

My Question or Issue

Adjusting the in Application volume slider changes the volume mixer slider in windows 11 making it basically impossible to control the volume level in application. Fix this please. 

Suggested posts