Announcements

Can't play right now, Sorry! You can't play this content while connected to another device.

Solved!

Can't play right now, Sorry! You can't play this content while connected to another device.

tarnblade

Ok just came across an issue where spotify premium will not allow me to play local files I have syncd on my Amazon Echo Dot.

 

Can't play right now, Sorry! You can't play this content while connected to another device.

 

I get the above error message and my Echo dot is greyed out.

 

It will however play the same song fine on both my pc and smartphone.

 

So clearly it can sync up no after hitting the Download button no problem, but refuse's point blank to let me stream to my echo dot, which is the entire reason I upgraded to premium in the first place.

 

I will notify amazon of this as well, but could you please work together to get this fixed, I have no doubt it will affect other users upgrading to premium as well.

Reply

Accepted Solutions
Marked as solution

Stevii89

The way you get it to work is say, "Alexa, bluetooth connect." You will have limited volume control, however, the local files will play. You'll know its working because you won't get the special volume icon to directly control your echo's volume, rather just the phone. Most importantly you'll know it works since the local files are playing. 

 

View solution in original post

Marked as solution

Stevii89

On the contrary, I do understand. Spotify doesn't sync your local files up to a server, and your echo can't see your computer's file system. It can only play music provided by Spotify's server.

 

I was only providing a simple work around. Regardless for those unware of that feature. 

View solution in original post

Marked as solution

Thatzlife

Thanks for clearing it up with this bad news. But like you said can they please check unsolved for this issue. Because it has not been solved. All it does is let us know that we are paying a lot of money and can't even get a simple thing done.

View solution in original post

24 Replies

MarkPedersen

Try restarting your spotify and if it dosnt work try to reinstall it the 3 option is to write to @Spotifycares on twitter for profesional support 

Mark

tarnblade

I messaged spotify support directly via their chat support.

 

They claim that currently spotify will not work with local files via amazon echo dot, if you have found this to be incorrect please let me know. 😄

kebykepow

1. unlink local files folder "Edit > Preferences > Local files > "disable" (driveletter):/(foldersongs)

 

2. go to that folder where the songs are change its name "(Foldersongs)" to

"(Foldersongs1)" 

 

3. link local files folder "Edit > Preferences > Local files > "enable" (driveletter):/(foldername(Foldersongs1))

 

4. unlink local files folder "Edit > Preferences > Local files > "disable" (driveletter):/(foldername(Foldersongs1))

 

5. go to that folder where the songs are change its name back to "(Foldersongs)"

 

6. link local files folder "Edit > Preferences > Local files > "enable" (driveletter):/(foldersongs) again.

 

Fixed it for me! hope you dont have to redo this often (spotify PLS fix XD)

 

 

 

tarnblade
Thanks for the steps. Sorry to say it didnt work for me, but apreciate the help.

gipdavis

I also get this "Can't play right now" when trying to stream my downloaded local files to my Amazon Echo (not Dot) and my Bose Soundtouch 10.  What the heck Spotify?  Not being able to stream downloaded local files to wifi devices when other downloaded files play just fine does not make any sense.  Please fix this.

 

Marked as solution

Stevii89

The way you get it to work is say, "Alexa, bluetooth connect." You will have limited volume control, however, the local files will play. You'll know its working because you won't get the special volume icon to directly control your echo's volume, rather just the phone. Most importantly you'll know it works since the local files are playing. 

 

tarnblade

Not sure you understand the issue, If I want to just link my phone to play files via bluetooth, then yes I can do that, but I dont in any way need spotify for this functionality.

 

You are describing Phone > Bluetooth > Speaker.

 

What we are trying to do is play local files found within spotify on pc via the echo dot.

 

And it point blank refuses to do so.

Marked as solution

Stevii89

On the contrary, I do understand. Spotify doesn't sync your local files up to a server, and your echo can't see your computer's file system. It can only play music provided by Spotify's server.

 

I was only providing a simple work around. Regardless for those unware of that feature. 

tarnblade

Understood, just clarifying that it doesnt actually sort the origional request.

 

Considering the premium being paid just to stream to the echo dot, how much harder would it be to implement, other people on various forums have said this worked in the past.

Scottyboi505

That is stupid, airplay allows me to play my files via the Spotify, and I am able to

play my music via bluetooth directly connecting to the receiver, but to not allow a simple stream of music that I own, using voice commands is silly! Especially as you can only connect echo and use Spotify unless you're a premium customer!!

 

Very disappointing!!!!!

 

Sort it out, otherwise you will lose many echo customers in the long term...

fsuis1

I tried every suggestion posted and nothing worked but finally I solved it!  My problem was that I had imported all of my playlists from Itunes so here is what I did:

1. go to the playlist and highlight all songs.

2. right click and add them to the same playlist (make sure to click on "add all"  NOT "skip duplicates).

4. Right click again and click remove from playlist. This will remove your old iTunes song leave only the ones you've just added from Spotify. 

 

Now your songs will play on Amozon Echo, or Gramafon or wherever.

 

I hope this helps.

Kabuli

No, you don't. He is right. If you pay for Spotify premium, it supposed to play your local files and make it available in their server even so other people can enjoy his playlist too. I have premium and have the same problem. If I wanted Bluetooth, I can do that without Spotify, so why I am paying for Spotify 15 dollars a month?

tarnblade

I do apreciate that some people are trying to post soloutions, but and this is a big but, just having spotify link files it has on its servers instead of your own local content is not a fix, they dont have every song in existence and have a bad habbit of removing songs without notice as well.

 

Neither is linking the device I want to play songs with via bluetooth to my speakers, If I want to do that, I do not in any way need spotify or spotify premium for this.

 

 

I can go into roaming data and delete the relevant file to refresh files I place in a local folder and point spotify at, but yet again it still refuses to play them on my echo dot unless it has a copy of said song in spotify's own library. 

 

Its clear to me by now, considering the mass amount of posts along the same lines that neither spotify or amazon have any interest in fixing this issue.

 

And If I didnt have various family members using spotify, Id drop my subscription in a heartbeat. Its not like we are asking for something complicated, just the option to stream content properly.

 

But aparently its too much for spotify support to handle.

tarnblade

By the way, could somone please point me at a option to mark this topic as "NOT SOLVED".

 

I find it agravating that someone seems to have selected this issue has been fixed, when in fact it has not.

 

I also find it very annoying that even the error message "Can't play right now, Sorry! You can't play this" has also been removed when clicking on the file.

 

Its almost like spotify picked up on the fact error message = someone will post about it and ask for a soloution, so hey lets not even give that option!

 

 

musicaddict8

This is weird but it works for me. If the device you want to stream through is grayed out and says "Can't play this right now", make sure you are trying to play music and not a podcast. Just find some music (any music) hit play and try reconnecting. That should take care of it. You should be able to switch back to a podcast after that if that's what you want to do. 

tarnblade

Hey all just a quick update.

 

Got onto spotify chat support tonight and they have def confirmed that the option to play local files via alexa, is no longer a option.

 

Yes if spotify already has the content you wont notice as it plays fine in those specific cases, but where spotify doesnt have the licence for that bit of music, forget it.

 

 

Goldcoast_RN

Bluetoothe connect worked. Thanks!!!!!

DarthChile

You do realize that for this to work, Sportify would need to: a. upload your files to their servers - wil lnever happen for copy rights and legal reasons, or b. somehow make all network speaker devices proxy to your local PC throught the Spotify connect link. You don't realize it but this is a huge thing, the way this works is that your PC, your phone and your speakers they all connect to the Spotify Server, which has the content. In the case of Local Files, the content resides on your local PC which means the Spotify service would have to stream the content from you PC to the Server and back to your speakers, it wouldbe really slow. Unless they provide some option like a local Spotify server in your PC, this will not be solved. There is not an easy technical solution.

gipdavis

When I download a Spotify playlist to my local device (my iPhone) to play offline later, at that point don't I have all the "content" I need right on my local device?  Why would I need to stream it back through the Spotify server?  The same principle would apply to local files that I have added to Spotify app that are now also downloaded to my local device, my iPhone.  All the "content" is on the device.  What am I missing here?

 

Suggested posts

Env: prod