Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Suddenly, certain songs "play" silence.

Suddenly, certain songs "play" silence.

Description

I've been running Spotify on my Android device for a few months now. Just yesterday it started with this problem, where it would appear to play a song, but there was no audio. The UI shows that it seems to be playing. When it gets to the end of the song, nothing else happens, it does not continue on to the next song.

 

Now, I exclusively stream. There are no local files. This is on 3G, and in the same locales that I have been in for the past few months.

 

If I fast-forward onto the next song, that one will play. But, eventually another song will not play. I have not been able to get the silent song to play properly. Skipping ahead and then back, seeking around that silent track, closing and stopping Spotify and then restarting, are all things I have tried to get the song to play, and have not worked.

 

I have cleared the Spotify cache and data, uninstalled, shut down my phone, pulled the battery, and then reset everthing back again, to no avail.
 

What are the steps you took to get to the error/issue?


Just select some music, and start playing it. I usually select an album to listen to. After a track or two (or three or four) I'll not hear anything, though it appears from the UI that it is playing as I already said.

 

What I expected to happen

I expect to hear the song, thanks!

 

Did you restart your device when troubleshooting in section B?

Yes

 

Did you read the connection troubleshooting tips?

Yes

 

Your device

Samsung Galaxy Nexus on Verizon.

 

Device’s Operating System

4.0.4 Ice Cream Sandwitch

 

What type of account do you have?

Premium

 

Space left on your device

13.51GB

 

Space left on your SD card (if applicable)

N/A

 

Space left on your External SD card (if applicable)

N/A

 

Is your device rooted?

No

 

Are you using a custom ROM, if so which one, exactly?

No

 

Did you set your external SD card as storage location?

No

 

Did you manually install an older version before installing the latest version from the Play Store?

No

 

Do you have the same issue when switching between WiFi/Mobile Data (If applicable)?

I do not use my phone on WiFi.

 

If you said "No", when does the issue not occur?

 

 

My mobile Spotify version

0.7.2.402-g40e8dcb4

 

My desktop Spotify version (if applicable)

N/A

 

My mobile provider and country

Verizon US

 

My username

jlyonm

 

Do you have a Spotify (non-Facebook) login?

Yes

 

Are you logging in with Facebook or with your Spotify login details?

Spotify login

 

Do you have any screenshots you can attach to more clearly explain your issue?

No

Reply
31 Replies

@TheSillypig Can I just check something you said originally. Do you get this problem if you synch a playlist containing only local files (mp3s on your PC) as well?

I have this problem too. Works on my iphone but not on my android phone. (Note these are mp3s that I own and have put in spotify playlists.) I was under the impression that spotify was able to sync them to my phone but they don't play at all even though you can see the song "playing" without any sound...

 

 

Hi @StephanL Could you long press the playlist and select "undownload" then long press and "download" to resynch it and see if it works once the synch has finished.

Haha, it's an awfully long playlist! But I can give it a go in the name of science! 😛

Hi, everyone.

 

I'd just like to add to the discussion that I'm occasionally experiencing the same problem - both on desktop and Android.

 

The problem has been there as long as I can remember. It's still so seldom for me that I haven't reported it. But since it's a multi-platform problem, I'm guessing the problem is with the server communication, just like half-loaded web pages occasionally appears in web browsers. Nevertheless, I think it's a bug that should be fixed, since it's absolutely essential to the software - even if it's just occasional.

I know this is an old thread but I'm having the same issue on an android phone. I noticed recently that some songs that don't play in offline mode do play when online, however, I started having this problem before I figured out offline mode. Although it's possible I was turning off the data for my phone when I wanted to listen to music id downloaded but not use up data streaming. But now that I think about it I'm pretty sure I had the problem even when online. I tried closing and reopening Spotify and also reinstalling it and redownloading all my playlists, however this just caused the silent problem to affect different sings than before. Any solution for this?

I've always had the issue of it 'playing' while buffering. But for the last few days, I've also had an issue of it doing this on downloaded playlist, at the beginning or middle of random songs, even in offline mode. I've cleared my cache, reinstalled, restarted phone, done literally everything I can think of. And it won't play.

Also, I'm on Android 4.3, T-Mobile Galaxy s3, Spotify version 2.2.0.636


@jmdilts wrote:
Also, I'm on Android 4.3, T-Mobile Galaxy s3, Spotify version 2.2.0.636

Lots of reports of this. My curent suggestion is to revert to an previous vesion of the app until an update is pushed.

 

You can grab older versions from the link in my signature.


Please use the search feature before posting a problem/bug/idea.
What's a Spotify Rock Star, and how do I become one?
     Using Spotify Since March 10th 2009
     Twitter: @mechanimal82

Android Troubleshooting:
[COMPLETE GUIDE] How to fix most Android issues
Spotify Android Version History

Hey. I am listening to spofity on my computer. Selected tracks are silent while others work. I don't know what is going on. But when I try to listen to certain songs they are silent. There many that work.

I've just come back to Spotify after a few months with Tidal and hit this issue.  I thought it was just an offline playlist issue with selected tracks that play quiet but not it appears to be wider in that some albums in their entirety will not play either in offline or connected mode.  

 

The progress bar moves but there is no output.

 

I am contemplating a return to Tidal but will sit tight for a bit to see if this is a short term issue.

 

Will also explore the possibility of reverting to a previous app version to test.

OK ... the old 'clear cache' trick seems to have worked for me ... all songs playing OK on and offline now (so far) ...

 

Now, if Spotify could just come to the party with a decent Sonos integration then I won't regret coming back from Tidal 🙂 

Suggested posts