Debian 9, higher versions dependencies

Reply
4 people liked this

Debian 9, higher versions dependencies

Music Lover
‎2017-04-19 09:58 PM

Sorry for my English…

Debian 9 Stretch now has higher dependencies than Spotify needs. Version libssl1.0.2 is installed, Spotify wants version libssl1.0.0. Libavcodec57 is installed, but libavcodec54 is still required. Additional dependencies were not displayed when the installation was attempted.

Is it possible to expect an early remedy?

8 Replies

Re: Debian 9, higher versions dependencies

Music Lover
‎2017-05-02 04:21 AM

ALAC playback and sync to portable devices is broken for me (too) on Debian 9 because of the incompatible (newer) libavcodec57.

1 person liked this

Re: Debian 9, higher versions dependencies

Music Lover
‎2017-05-02 10:39 PM
Does one answer here? I pay for my product (Spotify) and no one logs in or provides a newer version? Performance = consideration
2 people liked this

Re: Debian 9, higher versions dependencies

Edited
Spotify
‎2017-05-10 10:37 PM

I sometimes answer in these forums. That's about it. The regular customer service will not and does not know the answer to most of the linux questions, because linux desktop client is not a supported client.

 

libssl1.0.0 is the supported package in Ubuntu 16.04 LTS which is the current target desktop environment, not Debian 9, but they are very similar, except for this package. Ubuntu 16.04 LTS is the target, mostly because there is so little development time spent on the linux client.

 

There are a few different options available, but very little progress is spent on them.

 

The simple open source solution would be to have one binary per distribution, linking to that distribution's version of the package. That won't happen.

 

Another solution would be to start using libssl1.0.2 and stop using libssl1.0.0. A transition like that has happened before (between libssl0.9.8 and libssl1.0.0). That was also painful. It would mean to drop support for 16.04LTS. That probably won't happen.

 

A not so simple solution would be to dynamically open libssl1.0.2 or libssl1.0.0 depending on what is available. This could happen.

 

Another solution would be to use a container technology like snap/flatpak where a security supported version of a libssl version is included. That would mean people would have to stop using the debian package and start using that release instead. This could also happen.

 

 

Another solution would be to drop the feature that libssl is used for (communicating with embedded playbuttons on the web) and then stop depending on the library. Will probably also not happen.

 

Re: Debian 9, higher versions dependencies

Music Lover
‎2017-05-11 04:52 AM

LibSSL is relatively easy to work around (it’s just a package that generally works in newer Debian versions).

 

It’s libav that is really difficult to get all dependencies for since it consists of a large number of other packages that have to be present for Spotify to function fully.

Re: Debian 9, higher versions dependencies

Spotify
‎2017-05-11 10:31 AM

Yes. libav* libraries are in a similar situation.

 

There is code in the client to dynamically load the latest version of libavcodec and libavformat that is installed on the system. However, there was a problem in that loading code which made the client misbehave or crash when loading anything newer than libavcodec54, so newer versions were disabled until we would have time to fix it.

 

Highlighted
2 people liked this

Re: Debian 9, higher versions dependencies

Music Fan
‎2017-06-24 06:51 AM

Here is a quick guide for those looking for a solution on Debian 9.

https://wiki.debian.org/spotify

 

4 people liked this

Re: Debian 9, higher versions dependencies

Music Fan
‎2017-06-26 12:12 PM

Re: Debian 9, higher versions dependencies

Music Fan
a month ago

This one worked for me too! Thank you so much! :)

SUGGESTED POSTS