Help Wizard

Step 1


Additional mouse buttons do not work

Additional mouse buttons do not work

8 Replies



I have same problem with my multimedia keyboard. It's not a Spotify bug.

You just need to remap keys, you may use xev and xmodmap. Or you can try use your system keyboard settings to modify key shortcuts.

In KDE 4.9.5 it can be found in System Settings  > Keyboard.

Feel the music. Get involved. Be Inspired.

which keycodes need to be generated? I can remap the buttons for sure, but to what? And why is there no way to simply use the XFree89Back and XFree89Forward keycodes?

Same problem here. I'm using a Logitech M705 and Ubuntu 12.10. The side buttons are recognized as normal left clicks. It would be very great too see this fixed, because I use this buttons in many other programs (Chrome, Firefox, File Manager, Software Center) for browsing and it's really annoying that I have to click the GUI buttons to get back/forward.

Fix for this would be highly appreciated, I hate pressing the back button and having my music interrupted 😞

My back/forward buttons move screens back and forward and I have configured my mouse wheel left/right to switch tracks with the logitech mouse settings app. Using the Performance Mouse MX and never had any issues.

Any news on this issue?

I have a wireless mouse and Spotify. When you are using Spotify some mouse buttons (as the scrolling button or 4 and 5 buttons) may change to control Spotify instead of controlling the PC scrolling up/down or back/forward. I found that if I press for 3 seconds the DPI button on my mouse it continues to control normal the PC functions. 

If I press DPI button again for 3 seconds it changes again to media mode and continues to control Spotify. 

Install xbindkeys and xautomation packages.

Use the following .xbindkeysrc config:


# Back
"xte 'keydown Alt_L' 'key Left' 'keyup Alt_L'"

# Forward
"xte 'keydown Alt_L' 'key Right' 'keyup Alt_L'"

Suggested posts