Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Cannot play any file (everything is greyed out)

Cannot play any file (everything is greyed out)




  1. Your device and operating system:
    Dell Precision 5750 / Arch Linux / Swaywm
  2. Type of Spotify account you have (Free/ Premium):
  3. The app version of Spotify you’re using:
    Spotify version
    Spotify version


My Question or Issue

Since a couple of weeks, I cannot use the Linux Spotify client anymore. All Songs are greyed out. Playing a Song results in "Spotify cannot play this right now, If you have the file on your computer you can import it" Network seems to work. I can see what my friends are listening to. Furthermore, I can control other devices via Spotify Connect.


What I tried so far


1) Reboot

2) Update System

3) Clear Spotify cache rm -rf $HOME/.cache/spotify/Storage

4) uninstall / reinstall spotify

5) install spotify from snap instead of pacman

6) Make sure, there is no firewall

7) Using different DNS servers

😎 Using a BT-Headset

9) Using Internal Soundcard

10) Using Docking Station Sound card

11) Using a different Network (multiple)

12) Deleted every single folder/file with 'spotify' in it

13) Change all kind of settings (streaming quality, etc)

14) Probably more....



Spotify on Android works fine

Spotify on Windows Virtualbox works fine

Spotify on spotifyd works fine

Spotify on MellowPlayer works fine

Spotify on Web-Player in FF/Chromium works fine


Troubleshooting guide:


1. Is spotify starting normally? Yes

1.5 Can you play a sound? Yes, everything else is playing sounds

2. Is the system recognizing your sound card? Yes

3. Is Spotify running on prefered sound card? Change between sound cards in pavucontrol--> YES




17 Replies

Am having same issue, but on debian.  rm -rf'ed all of the spotify cache and data, but still the error occurs.  Works fine on android, have not tested web player (I don't have DRM in my browser).  I have had similar issues before, but they were to do with Spotify thinking it was offline. 


I am just experiencing it again, so the whole text following now is probably not helpful. No idea why spotify worked for some hours and then stops again... This is ridiculous...




Edit 2: restarting spotify multiple times and playing with pavucontrol (muting unmuting stuff, changing the default sink, etc) and all of the sudden it works again.




Edit  3: Next Day. Everything is back to non working state. 😞





Yes, this is a different issue than the "offline" false positive which is already discussed in many threads here already. Initially I thought, I am experiencing that one, but it is definitely a different root cause.


I am actually a step further already, but cannot really come up with a reproducible solution.


I was suspecting an issue with spotify and the soundserver. I am was using pulseaudio (as it should be the default on most systems). Since I also have some pipewire stuff installed on my box to have screensharing enabled on wayland I thought there might be some sort of conflict. So I installed pipewire-pulse which is a drop-in replacement for pulseaudio and pulseaudio-bluetooth.


At first it seemed like nothing changed. However, after another system upgrade and reboot spotify magically works again.




Then I tried something else. I have another Laptop with a very similar setup (arch, X, i3). I fully upgraded the system and installed the latest spotify form AUR. Voila, same issue, all songs are grey...


That one is still on pulseaudio. I did not bother to try the pipewire trick since I do not really use that computer currently but it seems like the issue is reproducible and I wonder if there are more users with that problem...




Not sure if any spotify DEVs are reading this, but I am giving it a try:


The whole Spotify user experience is getting worse and worse. There is so many issues and the new user interface really sucks. So many people are already complaining about it. But then, from the technical side, the client is**bleep**. (No proper online detection, no error messages at all, no log files, no verbose mode, no customer support.) I spent hours to find a solution. A proper error message instead of "If you have the file on your computer you can import it" would definitely more than appropriate.


I am definitely moving on and see if Deezer and Tidal are better options if you don't get**bleep** together soon.



Contacted customer support chat about this today. They escalated my request to the "technical team".  Staying tuned now...

Spotify Support's answer:


I highly suggest contacting Linux support so they could give you specific troubleshooting steps and to also look at why you're unable to play anything with Spotify.


I am speachless, really.

Alright Spotify, not paying anymore for this rubbish. Moving on to somewhere else. Good Bye

Face the same problem, only I could listen to music till this week.

I'm on Gentoo and just upgraded Spotify from spotify-1.0.72-r1 to spotify-1.1.56.

Couldn't play anything. I am not using PulseAudio (but ALSA directly) and in the terminal I could see it was trying to feed FLOAT_LE format to my software volume device (normally applications output S16_LE or S32_LE). I had to add a plug device as a format converter before that, now it works again.

Could it be so that the format change somehow messes up PulseAudio also? Have you guys tried without PulseAudio?

wth, the spotify community page just swallowed my answer.... sorry, but I think I am done with those amateurs...


Same issue on manjaro, I hope they fix this soon...

Found a fix.


The issue is actually with NetworkManager's Connectivity Check.. On gnome the default URL to ping to see if you are connected to the internet is `` which appears to be broken at the moment. So Spotify thinks its offline because the URL configured for the network check is not reachable.


To fix the issue create a new configuration file like so:

sudo nano /etc/NetworkManager/conf.d/20-connectivity.conf


Enter this into the configuration file:

[connectivity] uri= interval=0


Save the config file. (Ctrl + X & CTRL + Y)
Then restart the network manager:

sudo systemctl restart NetworkManager


Hope this helps.


Again, the forum ate my message... Damn, Spotify.... Really? You so annoy me....



Long story short:


The issue I have is NOT a connectivity issue not is it related to network manager. Your solution solves other problems and was discussed a lot in other threads/forums, but it definitely does not fix what I am experiencing...



Btw: The URL you posted returns 404

I fixed this issue by installing qt4. Rebooted after installing just to be sure. Now spotify plays again on Arch Linux and on Manjaro Linux. Qt4 is deprecated and would not ship with a modern upgraded Linux distro. I imagine that the spare-time linux devs at spotify used a qt4 library for something like audio playback or network connectivity and just never made time to update it.

@Greenfuse Thanks!


I can confirm this works on Manjaro. It didn't fix itself but after I installed qt4-bin and did a reboot, it started working again.

I've been having an issue where all songs are unplayable and greyed out, I have been looking for hours for a solution and so happy I stumbled upon @ultimate55's fix. I am on qtile in Debian and this is the only solution that worked for me! Thanks a bunch!

(Using Linux Mint 20.2, but this works in various distros)

On home network, Run Spotify, all songs greyed out;

Set up a hotspot on your phone with 4G, connect laptop network to the hotspot;

Bingo! Spotify now playing correctly.

Conclusion: it is a network problem and the reply by Ultimate55 (below) is on the right track - I have not tried it yet.  This is an easy way to pin down the problem area.

ultimate55's response led me to find and fix the cause of this issue for me. But different.

Turns out there are many ways where spotify can think there is reason to not let the user play audio...

Setup: Ubuntu 20.04, but not with NetworkManager and this is what caused trouble for Spotify.

I use renderer: networkd with static IP config in yaml in a /etc/netplan/interfaces.yaml file.

This works IP-wise for the system, network is happy and all but it leaves NetworkManager running and Spotify insists on asking it 'if there is a working network', and apparently without it controlling the network is says NO to Spotify which makes Spotify-client grey out everything.

The solution is stupid simple: systemctl stop NetworkManager . And a subsequent disable.


I have 2 feature requests for our Spotify devs :

- clearly log the question to NetworkManager and its outcome in --show-console

- add a 'pretend that I am online just fine' button in the advanced settings

I'm sure this would help a lot of other people.


Oh, and thanks for the Linux port of Spotify of course 🙂

Still essential on Pop! OS 22.04 ( Debian/Ubuntu based ), if I enable connectivity - songs un-grey themself almost instantaneously. I'd appreciate to be able to use Spotify with it disabled ( and not having to download songs ).

Suggested posts