Help Wizard

Step 1


Centos Spotify Segmentation Fualt

Centos Spotify Segmentation Fualt

Hi all, I've been running spotify on centos 6.3 for quite a few months now. This morning I started getting segmentation faults when it started up.


Tried the usual deleting $HOME/.cache/spotify and $HOME/.config/spotify to no avail.


Tried running with the -offline switch and got spotify to open but it crashed whenever I went online,


Tried unticking the view people and the other online view thing (cnat remember what it was) but still seg faulted when I went online.


Tried re-installing using this script provided here


Still getting segmentation errors (tried the deletion of config/cache files).the -offline switch no longer seems to work: -

spotify -offline
10:52:52.946 I [breakpad.cpp:61                 ] Registered Breakpad for product: spotify

10:52:52.947 I [translate.cpp:123               ] Reloading language file
10:52:52.948 I [breakpad.cpp:191                ] Searching for crashdumps: /home/mbrown/.cache/spotify/*.dmp

10:52:54.547 I [breakpad.cpp:202                ] Not allowed to upload file

10:52:54.698 A [CefModule.cpp:325               ] Check failed: g_cef_handle:
<section removed to limit post to < 20000 chars>
10:53:04.311 I [mainview:6209                   ] onAppActivate(1)
10:53:04.627 I [ap:1229                         ] Connected to AP:
10:53:04.730 I [mainview:6768                   ] Load complete (0) url: sp://feed/index.html
10:53:05.209 I [gui-model:2846                  ] Login Code: 0
/usr/local/bin/spotify: line 3:  7387 Segmentation fault      (core dumped) /usr/bin/spotify

10:53:22.394 I [breakpad.cpp:61                 ] Registered Breakpad for product: spotify

10:53:22.394 I [translate.cpp:123               ] Reloading language file
10:53:22.396 I [breakpad.cpp:191                ] Searching for crashdumps: /home/mbrown/.cache/spotify/*.dmp

10:53:24.110 I [breakpad.cpp:202                ] Not allowed to upload file

10:53:24.265 A [CefModule.cpp:325               ] Check failed: g_cef_handle:
10:53:32.477 I [user_cache:135                  ] UserCache::initiateGetUsers() will query for 1 users
10:53:32.677 I [ap:1755                         ] Connecting to AP           
<section removed to limit post to < 20000 chars>
10:53:32.794 I [ap:1229                         ] Connected to AP:
10:53:32.827 I [mainview:6209                   ] onAppActivate(1)
10:53:32.905 I [mainview:6768                   ] Load complete (0) url: sp://feed/index.html
/usr/local/bin/spotify: line 3:  7409 Segmentation fault      (core dumped) /usr/bin/spotify


has anybody (it would be great if spotify, who I am paying for this service had any ideas!) got *any* ideas?


I event tried using spotify in the browser ( firefox ) but got the message that the browser was not supported ( dev fail there methinks )




3 Replies

Unfortunately, the linux client is only a preview, so not officially supported by Spotify. (although some of the linux guys are really helpful!)

I'm not really what the issue is, Segmentation fault is not the most usefull of errors!


What version of firefox do you have? Also, what version of flash? 

If you have it, Google Chrome is always a safe bet for the web player! 



Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014

If this post was helpful, please add kudos below!

Hi Peter,


thanks for taking the time to respond!


I installed google-chrome and it all works lovely,


many thanks


If you want to give the native client a chance, you might try the installer at We recently checked some CentOS/RHES related patches, there seem to be som successful users out there. Note the feedback thread (link on github)

Suggested posts