Change Download Location *Acces Denied*

Reply

Change Download Location *Acces Denied*

thecrip
Casual Listener

Hey,

quick question, my Download folder is overflowing, so I wanted to change its location to a different hard drive. When I'm trying to select it in Settings>Offline Songs Storage, I get a Permission Denied error when I'm navigating to that hard drive.

Then I tried to make a symlink as seen here, but then spotify crashed during startup and I see nothing.

The application runs with my user privliges and the user has access to the drive, so where is that error coming from?

 

Thanks and kind regards,
Niklas

4 Replies

Re: Change Download Location *Acces Denied*

Spotify
Spotify

Crash on startup certainly sounds wrong. Since the app is sandboxed it doesn't have permission to read/write everywhere, this might be tricky, but at least it shouldn't crash.

 

What version of spotify you have, did you install the snap or debian package and what version of Ubuntu or other distro do you run? Here are some commands that show my information.

 

$ spotify --version
Spotify version 1.0.72.117.g6bd7cc73, Copyright (c) 2018, Spotify Ltd

$ dpkg-query --show spotify-client
dpkg-query: no packages found matching spotify-client

$ snap list spotify
Name     Version                  Rev  Developer  Notes
spotify  1.0.72.117.g6bd7cc73-35  6    spotify    -

$ lsb_release -a
Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial

 

 

Re: Change Download Location *Acces Denied*

thecrip
Casual Listener

I'm using Ubuntu 16.04.4 LTS.

Actually I noticed that I had both snap(1.0.70.399.g5ffabd56-26) and debian(1.0.6 9.336.g7edcc575-39) packages installed. I removed both and tried each one. The error persists in the snap version, but not in the debian package, which works flawlessly.

I can try and reproduce the error if it is of interest to anyone, otherwise I'm happy!

Edit: the content filter is surprisingly sensitive

Re: Change Download Location *Acces Denied*

Spotify
Spotify

Yep. Makes sense for snap (except for the crash) because it is locked down. It has been discussed in this thread: https://community.spotify.com/t5/Desktop-Linux/Ubuntu-How-to-change-Offline-songs-storage-folder-to-...

 

Can you please try the workarounds with the snap, either the mount into home directory or reinstalling with --classic and see if they work.

Re: Change Download Location *Acces Denied*

thecrip
Casual Listener

Both method 1 and 2 work for me

 

Also, I can recreate (for the non-classic version)

rm -r ~/snap/spotify/6/.cache/spotify/Storage
ln -s /mounted/storage/Spotify ~/snap/spotify/6/.cache/spotify/Storage
/bin/snap/spotify
  Segmentation fault (core dumped)

So this is where that crash happened.

SUGGESTED POSTS