Announcements

Fedora: Can't add local files source.

Fedora: Can't add local files source.

Plan

Premium

Country

 Germany (currently)

Device

DELL Latitude E6230

Operating System

Fedora 28 (Linux)

 

My Question or Issue

On my laptop with Fedora 28, the "add source" button in Spotify does not work. (I can press it, but it won't do anything). I am aware of the other thread there is resolving this on Ubuntu ( https://community.spotify.com/t5/Desktop-Linux/Unable-to-Add-a-Directory-to-Play-Local-Files-linux/t... ), but I have tried using these commands (also replacing every "apt" with "dnf", but I am not very experienced with the command line, so I didn't know what else to change), and the files/directories don't seem to be correct. How would I resolve this problem in Fedora?

 

Thanks

Reply
6 Replies

Hey @Panther98, welcome to the Community!

 

Sorry to hear you're having trouble with this. Though we don't officially support Spotify on Linux, we'll be glad to help.

 

When did this start happening? Have you already tried removing the app and installing it again to see if it helps? 

 

Let us know if that helps.

Hi, thanks for your reply...

 

I had never tried adding local files sources to Spotify before, so I suppose it's just a bug that has been there since I installed Spotify. Yes, I have reinstalled the app and it did not help.

 

A different thread states that this is a known problem with Spotify for Linux and solves it for Ubuntu by running a few commands, but of course these commands are not applicable to Fedora. Maybe there is a version of these commands for Fedora?

Only for feedback, works normally on linux mint 18.3

 

I think that your problem is spotify try to open file manager, but not find a compatible one.

Try to open spotify via command line (to obtain error logs) and try to add local files again. You probably will see a error message.

Thank you, I haven't tried doing that before!

When opening Spotify via command line I get this message:

Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
ATTENTION: default value of option force_s3tc_enable overridden by environment.

And then Spotify opens normally.

When I try adding a local files source, I get the following message in the terminal:

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Segmentation fault (core dumped)

I don't really know what to do with this error message, though...

pk-gtk-module is provided by the PackageKit-gtk3-module package

canberra-gtk-module is provided by the libcanberra-gtk3 package

They can both be installed via:

sudo dnf install PackageKit-gtk3-module libcanberra-gtk3


Pro Tip: You can use the dnf provides command to see what package provides such things.

For example:

dnf provides canberra-gtk*

 

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

This is a harmless message which means pretty much what it says. A dialog window was created without a parent Gtk application parent window, and that's apparently discouraged for some reason or another by the Gtk devs.

Who knows what caused the Segmentation fault?

I know this is very much late but just in hope it helps someone I got this working in fc33 by giving:

sudo dnf install ffmpeg ffmpeg-libs.x86_64 compat-ffmpeg28 audacious-plugins-freeworld-ffaudio

Suggested posts