Master volume and pulseaudio

Reply
Highlighted

Master volume and pulseaudio

Bigon
Newbie

Hello,

 

On most distribution (except Ubuntu and Fedora) pulseaudio is using by default "flat volume". That means that by default any client setting its volume to 100% will set the master volume also to 100%.

 

The linux spotify client is doing that from time to time (randomly) and I often have to check the volume if not too high when putting my headphonne. I several time forgot about this and my ears were ringing for hours.

 

Would it be possible to check why this is happening and to stop changing the volume randomly in the linux client?

 

In the documentation, it states: " With flat volumes enabled, it means the maximum volume that the sound hardware is capable of, which is usually so high that you absolutely must not set sink input volume to 100% unless the the user explicitly requests that (note that usually you shouldn't set the volume anyway if the user doesn't explicitly request it, instead, let PulseAudio decide the volume for the sink input)"

SUGGESTED POSTS