Help Wizard

Step 1


[SOLVED] [Ubuntu 22.04] spotify-client depends on nonexistent libssl1.1

[SOLVED] [Ubuntu 22.04] spotify-client depends on nonexistent libssl1.1

The 'spotify-client' .deb package specifies 'libssl1.1' as one of its dependencies. Ubuntu 22.04 (currently in beta and due for stable release in 10 days from today) has dropped libssl1.1 in favour of libssl3 (see OpenSSL 3.0 transition plans for reference), meaning that spotify-client no longer installs successfully on this version of Ubuntu unless we can provide 'libssl1.1' through other means.


I am not sure what (if anything) can be done about this from Spotify's side, but I still highly prefer the .deb package when compared to the Snap one, so if Spotify is able to provide libssl1.1 as part of its own repo (not sure if that is a good idea) or build the client package against libssl3 (possibly requiring some code changes before it would work), then we might still be able to install the .deb on Ubuntu 22.04.


15 Replies

This can be worked around by installing the old libssl package from 21.10 manually:


then: sudo dpkg -i ./libssl1.1_1.1.1l-1ubuntu1.2_amd64.deb

Same problem here. spotify-client claims to require libssl1.1, but that's wrong.

spotify-client uses libcurl3-gnutls which already uses libssl3 on 22.04. So there is no direct dependency to this library. I've modified the control file for spotify-client, just removed all references to libssl1 and updated the version. Works fine for me.


In Ubuntu  libcurl3-gnutls does not have libssh1.1 as a dependency which is wrong somehow.

Both of the above workarounds were successful for me as well.


Is there anybody on this forum working for Spotify who can confirm that libssl1 is not (or no longer) a real dependency, and - once confirmed - help with updating Spotify's public .deb package (specifically the control file) accordingly?

Just attaching my modified control file. The real name is control, without .txt at the end

FWIW, I have now submitted a request to the package maintainer address and asked if they can update the official package accordingly.

Effectively, it's a matter of updating the dependencies, although I think it's safer to add libssl3 than just remove the other versions of libssl from the dependencies.

If you are an advanced user, you can use dpkg-deb to unpack, modify dependencies in the control file, and repack.

Hi, I’ve the same problem. Here the terminal-output, if I try to install spotify on 22.04:

Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 spotify-client : Hängt ab von: libssl1.1 ist aber nicht installierbar oder
                                 libssl1.0.2 ist aber nicht installierbar oder
                                 libssl1.0.1 ist aber nicht installierbar oder
                                 libssl1.0.0 ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


Try the workaround as proposed by PonyoSunshine at the beginning of this thread. It does not fix the root cause, but it works by installing a package that's not required for the program.

For those wondering how to edit spotify-client's control file, I found these instructions from Debian:


Worked for me using latest .deb fetched from here:

apparently the manteiner updated the control file (27th of april) adding libssl3 but didn´t remove libssl1 (in order not to break dependencies with older ubuntu versions i guess)

so we're back to square one.

any solution apart from a dirty hack?

This worked well for me:


sudo apt install gdebi
sudo gdebi spotify-client_1.1.84.716.gc5f8b819_amd64.deb

Apparently apt update and apt install still pick the version, as if the apt repository metadata files had not been updated yet.



Using gdebi is overkill. Any apt based system should have dpkg as its base and if you look at the dependencies for libssl1.1, you'll see you already have everything it needs installed with a base install.


You can use apt (not apt-get) with a path instead to the deb file or dpkg. This does not require another utility to make work.

I really wanted to install spotify-client via apt so I googled some and came up with this solution:


cd ~

cat pubkey_5E3C45D7B312C643.gpg | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/spotify.gpg >/dev/null
echo "deb stable non-free" | sudo tee /etc/apt/sources.list.d/spotify.list


And then run:
sudo apt update && sudo apt install spotify-client

You can remove pubkey_5E3C45D7B312C643.gpg from ~ when you're done.

If you get errors regarding apt-key when using apt update, you probably used:
"curl -sS | sudo apt-key add -"
To revoke this you can use apt-key del "F9A2 1197 6ED6 62F0 0E59 361E 5E3C 45D7 B312 C643"

Hope it makes sense and helps 🙂



The libssl versions are listed as alternatives. I you try to uninstall libssl1.1 manually, you'll see that apt would not uninstall spotify-client with it.

This appears to be fixed in the official "stable" repository now. Will update thread title accordingly.

Suggested posts