Help Wizard

Step 1


Settings don't open on Linux


Settings don't open on Linux

1. Device: Lenovo X1 Carbon running Debian Jessie
2. Spotify Premium Account.
3. Spotify version 1:
4. When I click the arrow in the upper-right hand corner and click Settings, nothing happens.
5. Steps to reproduce:

1. Click the arrow in the upper right hand corner.
2. Click Settings.


I tried the steps from but they did not resolve my issue.


I also tried removing .config/spotify and .cache/spotify to no avail. I know that at one point in time this menu did work, but it has been quite some time.


Accepted Solutions
Marked as solution

Yes. Using Fedora 25 on Wayland. Keyboard workaround ok here.

View solution in original post

31 Replies

Hello @mhoran85,


Welcome to Spotify Community!

Can you try catch the console output when clicking on the settings button?

Open up Spotify from the terminal and click spam Settings button. If you notice any output in the console caused by the click on Settings button, copy-paste it here so I can take a look : )

Hey @Dreadlord,


I noticed that there was nothing in the console when I clicked on settings, so I figured something else might be up. Instead of trying to click settings, I hit the enter key when settings was highlighted. That worked!


So there seems to be something funky about click targets and Spotify. I can click most other things just fine -- it's just the settings menu that's acting up.


I have a HiDPI screen, so maybe that has something to do with it?

Thanks. This was the first time I heard about keyboard working, not mouse. I've seen this problem being reported a few times now, but I have never been able to reproduce it. This might help narrow it down.

Same behavior on arch linux.

Same problem on two machines running Fedora 25 with Wayland. I have a third machine on Fedora 24 without Wayland and it doesn't have this problem.

On a machine with Fedora 25 and Wayland, I can't access the settings options. For a workaround, I logged on the system with the Xorg. After updating the settings, I logged again with the Wayland.


I realized that some applications used by me do not seem to be fully compatible with Wayland (like the Spotify client) and bugs happen.

For those of you that have this problem because Spotify has some problem with Wayland, does the keyboard workaround described above work?

Yeah the keyboard workaround works for me on Wayland in Fedora 25.

I'm not running wayland, but the behavior is the same, nothing on clicking but keyboard works.


(Arch Linux 4.8.13-1-ARCH + Openbox)

Use the keyboard works for me too.

I have the same issue, running Spotify 0.9.17 on Debian 8.6 with X.Org X Server 1.16.4


The workaround of hilighting then hitting enter instead of clicking does work for me as well.

I just updated to version 1.0.44 of Spotify and the issue still exists.

Cursed my **bleep** off today when I tried to log my girlfriend out so I could listen using my account while she was out jogging and using here phone. I can confirm that navigating the dropdown menu with the keyboard works, but clicking the items with the mouse just makes the menu disappear.


There's also a ghost menu item between Settings and Log out (you have to press down twice to get from Settings to Log out).


Ubuntu 16.04, latest Spotify client installed (did an apt-get upgrade to rule out that it had been fixed already), standard 1080p TV used as display (aka. no HiDPI).


In summary, since not only Wayland hipsters are affected this is pretty serious, hopefully you'll fix it soon.

Marked as solution

Yes. Using Fedora 25 on Wayland. Keyboard workaround ok here.

Same problem on Arch with wayland


Spotify version

Same problem on Ubuntu/i3...


OS: Ubuntu 14.04 trusty
Kernel: x86_64 Linux 3.13.0-71-generic
Shell: bash 4.3.11
Resolution: 2560x1024
WM: i3

CPU: Intel Core i5-2500 CPU @ 3.301GHz
GPU: Gallium 0.4 on AMD CEDAR
RAM: 3776MiB / 7940MiB


The same on ArchBang linux.

kernel version 4.9.6-1

spotify version

No terminal output when leftclicking on settings button. Enter works well

Same issue here running Arch Linux 4.9 on Gnome with xorg. I've also noticed that right clicking the right hand friend pane doesn't do anything and since there's no menu I can't find a way to hide it. This seems to confirm that there's something not functioning right with mouse interaction.

Happening for me. Shortcut keys work, but clicking on the menu items only hides the menu.



Ubuntu 16.10

Gnome 3.2 Wayland

HIDPI (4k) with window scaling set to 2

Suggested posts