Spotify Client crashes when adding a directory to local files [Linux]

Spotify Client crashes when adding a directory to local files [Linux]








Operating System

Pop!_OS 20.04 (Linux, seems to happen on all distributions)


My Question or Issue

So, it seems downloading the client with no update from and using the Debian / Ubuntu repo works fine when adding a local files directory, but when I download the Snap & Flatpak version of the client the whole program crashes when trying to add a local files directory. This seems to be an issue with Spotify itself since I've tried this as well on a Manjaro install with the same issue. 


EDIT: I don't know if this happens on other desktop enviornments other than GNOME since it's the only DE I've used Spotify on

22 Replies

Yeah, I think the update has messed something up cause a few days ago this was not happening for me as well.


I'm having the same problem here running Linux Mint 19.3 (with Cinnamon DE), running the latest client from Spotifys own repository.


Happens on both my laptop and desktop (running same OS). So it truly seems like an error on Spotifys side.

Still having the same issue
Running Ubuntu 20.04 LTS

Same issue here, Arch Linux with kernel 5.9.3, Plasma desktop 5.20.2. The issue existed in Plasma 5.19 as well. Since all Linux users regardless of desktop environment and distribution are reporting this issue, this is clearly the fault of Spotify. And of course, they still haven't bothered to fix a pretty huge issue. They're breaking the app with every update, and still haven't fixed the **bleep**ing MPRIS implementation, because Spotify just doesn't give a single damn about its Linux users. Absolute BS.

Same here, i am using Ubuntu 20.10 and actually it crashes in everything that need to browse into your files like change your donwload directory or change your profile photo. I tried to do that using the spotify from the snap, flatpak and the Debian/Ubuntu but it happens in all of them.


Same issue, arch, kernel 5.9.8-arch1-1, bspwm


USE XFCE or I3 to edit settings, then save and go back to gnome.


That's my current workaround.



Same problem on Ubuntu 20.04


Ubuntu 20.10 here. Also crashes, regardless of deb package from repo, snap or even flatpak. Really annoying.

Fairly certain it is a problem with gnome.

Using i3 or xfce circumvents the problem

Problem also occurs with regolith, which uses gnome-flashback.


It is not really a problem with GNOME, but something that Spotify changed. Version from made in February 2020 works normally while the newest version from September does not. I'd say Spotify changed something that affects only GTK-based DEs (although I think somebody said they were having trouble with KDE Plasma too).

Same for Fedora 33 w/ Gnome 3.38.1


Xenrida Do you have steps for this? Ubuntu 20.04. Mine crashes when I click add source.


The solution was to manually downgrade the Flatpak version to an older version of the app. Using the version of commit "runtime: update to 20.08 (39ce772c)" is an efficient workaround for the issue. You can see how to downgrade a Flatpak package in:

Unfortunately, we can't wait for a real fix too soon, given that as alleged by Spotify themselves, Linux version is "not officially supported".


Same issue on Ubuntu 20.04


Same here. Unable to find a fix. Waiting for Spotify to release the local files on phones. Heard it's coming soon.


Same problem here. Fedora 33 as well.

The workaround for me was to keep an old version of Spotify's Flatpak (masked, with updates disabled of course) and the newest packaged ("official") version of the client both installed. Then what I do is, after adding my local folder(s) on the old version, doing the copy of "local-files.bnk" and "watch-sources.bnk" files from the Flatpak config folder (sorta "~/.var/app/com.spotify.Client/config/spotify/Users/[your number]-user/" directory) to the native version config folder ("~/.config/spotify/...same structure...").


Ps.: for a good UX, I recommend you all to hide the Flatpak version from your app menu.

As far as I get, it's a problem with GNOME-based Desktop Environments, specifically with Nautilus (the files explorer) and other libraries. I'd say, if you are able to, switch temporarily from GNOME to XFCE or other environments (as stated by xenrida), until they fix it(?), although it has been around for quite some time by now 😕


I have to say that it happened to me with a fresh Kubuntu install. That's KDE. No Gnome, no Nautilus.

Suggested posts