Announcements

Spotify Web Player only plays 9 seconds of a song and then is muted

Solved!

Spotify Web Player only plays 9 seconds of a song and then is muted

Pacleal

Sorry to post this in this thread, Desktop (Linux), but I couldn't find one that was suitable.

 

Plan

Premium

Country

Portugal

Device

hp slimline 260-a100np

Operating System

Chrome OS (CloudReady 94.3.20 (Home Build) stable-channel 64-bit)

 

My Question or Issue

Recently, when I open the Spotify Web Player and select a song to play it plays for about a second and skips to the next one repeating the process about 5 times and when it finally stops it only plays about 9 seconds of a song and the sound turns off (apparently the song keeps playing in silence indefinitely).

 

I saw that there have been similar problems in the past and tried the different suggestions that were given at the time, such as:

 

- try opening the web player in icognito window;

- clear browsing data;

- allow protected content;

- try the Chrome OS app.

 

None of these worked.

 

On my android phone, everything works normally in both the web player and the app.

 

Reply

Accepted Solutions
Marked as solution

jthistl3

This is an issue with Widevine CDM, which is the DRM service used by Chrome browser. It seems that older versions of Widevine no longer work with some websites, including Spotify. To fix this you can update your browser to the latest version. This applies both when using Chrome and Firefox (though Firefox should automatically update the plugin - the most recent update to it was today, the 10th December).

 

This is particularly a problem if you use ungoogled-chromium, since Widevine must be installed manually and as such does not recieve updates. If you use this, you must update Widevine manually following the usual instructions. 

 

 

View solution in original post

3 Replies
Marked as solution

jthistl3

This is an issue with Widevine CDM, which is the DRM service used by Chrome browser. It seems that older versions of Widevine no longer work with some websites, including Spotify. To fix this you can update your browser to the latest version. This applies both when using Chrome and Firefox (though Firefox should automatically update the plugin - the most recent update to it was today, the 10th December).

 

This is particularly a problem if you use ungoogled-chromium, since Widevine must be installed manually and as such does not recieve updates. If you use this, you must update Widevine manually following the usual instructions. 

 

 

Pacleal
Thank you very much. All good now.

naushikha

Solution worked. Widevine CDM was the culprit. Thanks!

Suggested posts

Env: prod