Spotify on Linux Mint muting whenever a different program starts playback

Reply
2 people liked this

Spotify on Linux Mint muting whenever a different program starts playback

CloakerSmoker
Newbie

Plan

Premium

Country

US

Device

Desktop PC

Operating System

Linux Mint 19 Tara 64-bit (MATE 1.20.1)
Spotify Version
1.0.80.480.g51b03ac3

 

My Question or Issue
Whenever any process besides Spotify starts playback, Spotify gets muted (Playback continues, volume slider doesn't change, but inside of "Sound Preferences" Spotify has the "Muted" box checked).
I first noticed this on a looping MP4 in firefox, as firefox first would pop up on the application list (Spotify would mute) I would unmute Spotify, and when the MP4 looped again (Making firefox drop off the list, and re-appear) Spotify would get muted.
I have disabled ALSA's auto-mute and dug through as many sound settings as I can, but I can't figure out why this happens. I only have one output device, and this hasn't happened with any other programs.

Steps to recreate:
1:
Open any application that will output audio (TeamSpeak 3 is what I tested with, since I knew firefox did it already)

2:
Start playback (In TS3 I did this by joining a server)

And that's it.
Any help is appreciated!
(spotify-dump.txt not included because .txt is an illegal extension for attachments, but since it was very small I will paste what was in it below)
[0922/233558.715047:ERROR:gl_context_glx.cc(227)] Couldn't make context current with X drawable.
[0922/233558.715410:ERROR:gles2_cmd_decoder.cc(4508)]   GLES2DecoderImpl: Context lost during MakeCurrent.

1 Reply

Re: Spotify on Linux Mint muting whenever a different program starts playback

Maximus_Prime
Newbie

I was having your exact same problem and couldn't figure it out for months. Maybe you've already fixed it but just in case here is the solution that worked for me.

SUGGESTED POSTS